Bug 334846

Summary: kde crash dialog appeard after logging in via VNC
Product: kdelibs Reporter: Steve King <steven.r.king>
Component: kshareddatacacheAssignee: kdelibs bugs <kdelibs-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: mpyne
Priority: NOR Keywords: drkonqi
Version: 4.12.5   
Target Milestone: ---   
Platform: Fedora RPMs   
OS: Linux   
Latest Commit: Version Fixed In:

Description Steve King 2014-05-15 22:41:30 UTC
Application: krunner (4.11.9)
KDE Platform Version: 4.12.5
Qt Version: 4.8.6
Operating System: Linux 3.14.3-200.fc20.x86_64 x86_64
Distribution (Platform): Fedora RPMs

-- Information about the crash:
- What I was doing when the application crashed:

Loging into Fedora 20 64-bit via VNC and saw the bug report diaglog.

-- Backtrace:
Application: Run Command Interface (krunner), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
81	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[KCrash Handler]
#6  0x0000003205211298 in _xend () at ../nptl/sysdeps/unix/sysv/linux/x86/elision-unlock.c:33
#7  __lll_unlock_elision (lock=0x7f5fe0d2e008, private=128) at ../nptl/sysdeps/unix/sysv/linux/x86/elision-unlock.c:29
#8  0x000000311e23c32b in unlock (this=0x1cf75d0) at /usr/src/debug/kdelibs-4.12.5/kdecore/util/kshareddatacache.cpp:1245
#9  ~CacheLocker (this=<synthetic pointer>, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.12.5/kdecore/util/kshareddatacache.cpp:1317
#10 KSharedDataCache::find (this=0x1cf7ee0, key=..., destination=destination@entry=0x7fff77ed5ce0) at /usr/src/debug/kdelibs-4.12.5/kdecore/util/kshareddatacache.cpp:1608
#11 0x000000311f9fd728 in KIconLoaderPrivate::findCachedPixmapWithPath (this=0x1cfcb00, key=..., data=..., path=...) at /usr/src/debug/kdelibs-4.12.5/kdeui/icons/kiconloader.cpp:854
#12 0x000000311f9fdafa in KIconLoader::loadIcon (this=0x1cda8c0, _name=..., group=group@entry=KIconLoader::Desktop, size=16, state=0, overlays=..., path_store=path_store@entry=0x0, canReturnNull=canReturnNull@entry=false) at /usr/src/debug/kdelibs-4.12.5/kdeui/icons/kiconloader.cpp:1123
#13 0x000000311f9f5ae0 in KIconEngine::pixmap (this=<optimized out>, size=..., mode=<optimized out>, state=<optimized out>) at /usr/src/debug/kdelibs-4.12.5/kdeui/icons/kiconengine.cpp:104
#14 0x000000311e86efd5 in QIcon::pixmap (this=this@entry=0x7fff77ed60a0, size=..., mode=mode@entry=QIcon::Normal, state=state@entry=QIcon::Off) at image/qicon.cpp:684
#15 0x000000311e860cfb in QWidgetPrivate::setWindowIcon_sys (this=0x1dc1750, forceReset=<optimized out>) at kernel/qwidget_x11.cpp:1490
#16 0x000000311e81442a in QWidget::create (this=0x1dc16e0, window=0, initializeWindow=<optimized out>, destroyOldWindow=<optimized out>) at kernel/qwidget.cpp:1543
#17 0x000000311e81494b in QWidget::winId (this=this@entry=0x1dc16e0) at kernel/qwidget.cpp:2534
#18 0x000000311fb7bd7d in KWindowSystemPrivate::KWindowSystemPrivate (this=0x1dc16e0, _what=1) at /usr/src/debug/kdelibs-4.12.5/kdeui/windowmanagement/kwindowsystem_x11.cpp:137
#19 0x000000311fb7ccf3 in KWindowSystem::init (what=1) at /usr/src/debug/kdelibs-4.12.5/kdeui/windowmanagement/kwindowsystem_x11.cpp:432
#20 0x000000311fb7cf9d in KWindowSystem::connectNotify (this=0x1dc0750, signal=0x311fbb90aa "2windowAdded(WId)") at /usr/src/debug/kdelibs-4.12.5/kdeui/windowmanagement/kwindowsystem_x11.cpp:405
#21 0x000000311cf9d004 in QObject::connect (sender=0x1dc0750, signal=0x311fbb90ab "windowAdded(WId)", signal@entry=0x311fbb90aa "2windowAdded(WId)", receiver=receiver@entry=0x1dbe938, method=0x311fbb9093 "slot_window_added(WId)", method@entry=0x311fbb9092 "1slot_window_added(WId)", type=type@entry=Qt::AutoConnection) at kernel/qobject.cpp:2671
#22 0x000000311fa6354c in createConnections (this=0x1dc0f10) at /usr/src/debug/kdelibs-4.12.5/kdeui/kernel/kstartupinfo.cpp:190
#23 KStartupInfo::KStartupInfo (this=<optimized out>, flags_P=1, parent_P=<optimized out>) at /usr/src/debug/kdelibs-4.12.5/kdeui/kernel/kstartupinfo.cpp:207
#24 0x000000334263bc7d in StartupId::StartupId(QWidget*, char const*) () from /lib64/libkdeinit4_krunner.so
#25 0x0000003342625ec8 in KRunnerApp::initializeStartupNotification() () from /lib64/libkdeinit4_krunner.so
#26 0x0000003342626e60 in KRunnerApp::initialize() () from /lib64/libkdeinit4_krunner.so
#27 0x000000334262771e in KRunnerApp::KRunnerApp() () from /lib64/libkdeinit4_krunner.so
#28 0x0000003342627775 in KRunnerApp::self() () from /lib64/libkdeinit4_krunner.so
#29 0x0000003342627c4d in kdemain () from /lib64/libkdeinit4_krunner.so
#30 0x0000003204a21d65 in __libc_start_main (main=0x4008a0 <main>, argc=1, argv=0x7fff77ed6878, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff77ed6868) at libc-start.c:285
#31 0x00000000004008d1 in _start ()

Reported using DrKonqi
Comment 1 Christoph Feck 2014-06-13 17:15:38 UTC

*** This bug has been marked as a duplicate of bug 334640 ***