Bug 334626

Summary: When doing a transfer, my specification of + or - is ignored
Product: skrooge Reporter: Aaron Wolf <wolftune>
Component: generalAssignee: Stephane MANKOWSKI <stephane>
Status: RESOLVED FIXED    
Severity: minor CC: stephane
Priority: NOR    
Version: 1.9.0   
Target Milestone: ---   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description Aaron Wolf 2014-05-11 23:15:19 UTC
When I enter a transfer, no matter what I do, it is initially entered as a debit from the first listed account to the other. I can add a "+" in front of the number, but it is thrown away. I have to then enter it afterward, then it works.

Reproducible: Always

Steps to Reproduce:
1. Choose operations
2. Select transfer
3. Enter "+ 100" for the amount
Actual Results:  
I get a debit of "-100"

Expected Results:  
I want a +100 for the account specified first
Comment 1 Stephane MANKOWSKI 2014-05-17 12:26:15 UTC
Hi,

If 100 is transfered from account A to account B the this is normal to have -100 in account A and +100 in account B.

So, this is not a bug.
This is the expected result aligned with this incident 192832.
Comment 2 Aaron Wolf 2014-05-17 15:22:16 UTC
Yes, but here's my process:

I am looking at account A, I am entering a bunch of items. One of them is a transfer from another account. It would be easier to keep the first listing as the same selected account in the transfer in the string of entries. I could switch, but it seems like if I *specify* a "+" in the number, doing that should override the expected behavior. If I just have a number, I agree it should work as is, but if I write an explicit +, then it should accept that and not turn it into a -. Furthermore, if I immediately edit and then add a +, it does what I wanted, so it is bad to have the very same action succeed in one case but not succeed when first entered.

At any rate, there's no reason that the two accounts must be FROM A to B instead of TO A FROM B. And simply adding the explicit + should be reasonable to affect this.
Comment 3 Stephane MANKOWSKI 2014-05-18 15:02:18 UTC
Git commit 813e715d08c095f0d2a095195246aae83e5399fd by Stephane Mankowski.
Committed on 18/05/2014 at 15:01.
Pushed by smankowski into branch 'master'.
When doing a transfer, my specification of + or - is ignored

M  +1    -0    CHANGELOG
M  +7    -7    plugins/skrooge/skrooge_operation/skgoperationpluginwidget.cpp

http://commits.kde.org/skrooge/813e715d08c095f0d2a095195246aae83e5399fd