Bug 334503

Summary: Kate editor segfaults while editing
Product: kate Reporter: Samuel Flis <samuel.d.flis>
Component: applicationAssignee: KWrite Developers <kwrite-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash CC: i.zaufi
Priority: NOR    
Version: 3.13.0   
Target Milestone: ---   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description Samuel Flis 2014-05-08 09:39:17 UTC
I've recently experienced several segfaults with Kate while editing and all of the are reproducable every time. The last one is editing a plain text file. What I did was to remove most of the text and then I could write letters but as son as I hit space or enter Kate segfaults. If I instead save the file after deleting some of the text but before I hit enter or space Kate freezes. I only have a backtrace of the segfault. Unfortunately I couldn't find a package with debugging symbols for libQtScript.so.4.
I'm using Kate Version 3.13.0
Using KDE Development Platform 4.13.0

I've attached the file that causes the segfault. I delete all the text except the first word and start to edit when it segfaults.


Application: Kate (kate), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f978fe2a7c0 (LWP 28519))]

Thread 5 (Thread 0x7f977c883700 (LWP 28522)):
#0  0x00007f978f768fbd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f978c8a6fe4 in g_main_context_poll (priority=2147483647, n_fds=1, fds=0x7f97780010c0, timeout=-1, context=0x1c71720) at /build/buildd/glib2.0-2.40.0/./glib/gmain.c:4028
#2  g_main_context_iterate (context=0x1c71720, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.40.0/./glib/gmain.c:3729
#3  0x00007f978c8a730a in g_main_loop_run (loop=0x1c716b0) at /build/buildd/glib2.0-2.40.0/./glib/gmain.c:3928
#4  0x00007f9781c95e16 in gdbus_shared_thread_func (user_data=0x1c716f0) at /build/buildd/glib2.0-2.40.0/./gio/gdbusprivate.c:273
#5  0x00007f978c8cbf15 in g_thread_proxy (data=0x1c26320) at /build/buildd/glib2.0-2.40.0/./glib/gthread.c:764
#6  0x00007f978cd86182 in start_thread (arg=0x7f977c883700) at pthread_create.c:312
#7  0x00007f978f77630d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 4 (Thread 0x7f9777fff700 (LWP 28523)):
#0  0x00007f978f768fbd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f978c8a6fe4 in g_main_context_poll (priority=2147483647, n_fds=2, fds=0x7f97700008c0, timeout=-1, context=0x1c7a630) at /build/buildd/glib2.0-2.40.0/./glib/gmain.c:4028
#2  g_main_context_iterate (context=context@entry=0x1c7a630, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.40.0/./glib/gmain.c:3729
#3  0x00007f978c8a70ec in g_main_context_iteration (context=0x1c7a630, may_block=may_block@entry=1) at /build/buildd/glib2.0-2.40.0/./glib/gmain.c:3795
#4  0x00007f978c8a7129 in glib_worker_main (data=<optimized out>) at /build/buildd/glib2.0-2.40.0/./glib/gmain.c:5541
#5  0x00007f978c8cbf15 in g_thread_proxy (data=0x1c264f0) at /build/buildd/glib2.0-2.40.0/./glib/gthread.c:764
#6  0x00007f978cd86182 in start_thread (arg=0x7f9777fff700) at pthread_create.c:312
#7  0x00007f978f77630d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 3 (Thread 0x7f97777fe700 (LWP 28572)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f976523fffb in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f9765240039 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f978cd86182 in start_thread (arg=0x7f97777fe700) at pthread_create.c:312
#4  0x00007f978f77630d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 2 (Thread 0x7f96e12c3700 (LWP 28614)):
#0  g_mutex_get_impl (mutex=0x7f9768003170) at /build/buildd/glib2.0-2.40.0/./glib/gthread-posix.c:122
#1  0x00007f978c8e89b9 in g_mutex_unlock (mutex=mutex@entry=0x7f9768003170) at /build/buildd/glib2.0-2.40.0/./glib/gthread-posix.c:228
#2  0x00007f978c8a6ef6 in g_main_context_iterate (context=context@entry=0x7f9768003170, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.40.0/./glib/gmain.c:3712
#3  0x00007f978c8a70ec in g_main_context_iteration (context=0x7f9768003170, may_block=1) at /build/buildd/glib2.0-2.40.0/./glib/gmain.c:3795
#4  0x00007f978d6867be in QEventDispatcherGlib::processEvents (this=0x7f9768001320, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#5  0x00007f978d6580af in QEventLoop::processEvents (this=this@entry=0x7f96e12c2de0, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f978d6583a5 in QEventLoop::exec (this=this@entry=0x7f96e12c2de0, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f978d554c5f in QThread::exec (this=this@entry=0x2d87b50) at thread/qthread.cpp:537
#8  0x00007f978d639823 in QInotifyFileSystemWatcherEngine::run (this=0x2d87b50) at io/qfilesystemwatcher_inotify.cpp:265
#9  0x00007f978d55732f in QThreadPrivate::start (arg=0x2d87b50) at thread/qthread_unix.cpp:349
#10 0x00007f978cd86182 in start_thread (arg=0x7f96e12c3700) at pthread_create.c:312
#11 0x00007f978f77630d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 1 (Thread 0x7f978fe2a7c0 (LWP 28519)):
[KCrash Handler]
#6  KateDocument::defStyleNum (this=0x2cf23d0, line=<optimized out>, column=<optimized out>) at ../../part/document/katedocument.cpp:5487
#7  0x00007f9765894149 in KateDocument::isComment (this=<optimized out>, line=<optimized out>, column=<optimized out>) at ../../part/document/katedocument.cpp:5508
#8  0x00007f9765836909 in KateScriptDocument::qt_static_metacall (_o=0x324f3f0, _id=-1919157952, _id@entry=89, _a=0x7fff8fa40b80, _c=<optimized out>) at moc_katescriptdocument.cpp:403
#9  0x00007f9765837963 in qt_static_metacall (_a=0x7fff8fa40b80, _id=89, _c=QMetaObject::InvokeMetaMethod, _o=0x324f3f0) at moc_katescriptdocument.cpp:466
#10 KateScriptDocument::qt_metacall (this=0x324f3f0, _c=QMetaObject::InvokeMetaMethod, _id=89, _a=0x7fff8fa40b80) at moc_katescriptdocument.cpp:467
#11 0x00007f97652abb32 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#12 0x00007f97652acc59 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#13 0x00007f97652acee9 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#14 0x00007f97651b2118 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#15 0x00007f976518ffc0 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#16 0x00007f96e34fb1a4 in ?? ()
#17 0x0000000000000000 in ?? ()
Comment 1 Alex Turbov 2014-05-13 02:21:01 UTC

*** This bug has been marked as a duplicate of bug 332426 ***