Bug 332130

Summary: Unsharp mask acts as blur in the filter paintop.
Product: krita Reporter: Paul Geraskin <paulgeraskin>
Component: Brush enginesAssignee: Krita Bugs <krita-bugs-null>
Status: RESOLVED FIXED    
Severity: normal CC: dimula73, garbi75, halla
Priority: NOR    
Version: git master (please specify the git hash!)   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:

Description Paul Geraskin 2014-03-14 10:14:36 UTC
Hi devs.

Filter Brush does not work with UnsharpenMask and GaussianBlur.

I select standart preset "FX_blur_light". Choose UnsharpenMask or GaussianBlur. And filter brush does not work.

Thanks.
Comment 1 Halla Rempt 2014-03-14 10:44:25 UTC
Hm, if I just create a preset from scratch for gauss blur or unsharp mask, the filter brush just works. Could it just be an incompatibility in the settings?
Comment 2 Paul Geraskin 2014-03-14 10:58:44 UTC
Dmitry confirmed that he has the same issue on his machine.
Comment 3 Halla Rempt 2014-03-14 11:02:40 UTC
And if you _don't_ use that preset? But go to the brush editor, select filterop, select gauss blur or unsharp mask and make sure the settings do something? The default settings for unsharp mask all seem to be zero.
Comment 4 Halla Rempt 2014-03-14 11:04:40 UTC
Out of the box, the fx_blur_light preset uses blur. If I select gauss blur when that preset is active, the radius is 0.5. I guess that that doesn't do much. Same for unsharp mask, where it's all 0.
Comment 5 Paul Geraskin 2014-03-14 11:13:00 UTC
Ok i did it:

- Pressed "Default Preset"
- Selected Filter Brush
- Choosen Unsharpen Mask filter

Brush works like Blur filter. It blurs. But it should sharpen.
Here is screenshot: http://i.imgur.com/ptbMKL4.png

Possibly, new filter is not switched when we make a new choose.
Comment 6 Halla Rempt 2014-03-14 11:24:54 UTC
Yes, _that_ I can confirm. Fixed the subject.
Comment 7 Halla Rempt 2014-03-14 11:30:21 UTC
It isn't that the filter isn't switched, though -- check with some other filters.
Comment 8 Paul Geraskin 2014-03-14 11:43:13 UTC
Pixelize, Invert and others filters works ok.
Noize filter - crash.

I think GaussianBlur and UnsharpenMask should be checked.
Comment 9 MichalG 2014-03-25 01:01:02 UTC
I noticed this irritating bug with bad acting of brushes that use sharpen or blur as well.
Could it be fixed soon and in what release?
Comment 10 MichalG 2014-04-05 19:27:22 UTC
There was Krita v2.8.1 released recently, but the (above described) bug remains... :(
Comment 11 Halla Rempt 2014-04-07 08:10:50 UTC
Yes... There'll always be bugs that won't be fixed in time for the next version...
Comment 12 MichalG 2014-04-19 12:15:39 UTC
OK, I can understand, but could you let me know when this bug will be
corrected, anyway?

2014-04-07 10:10 GMT+02:00 Boudewijn Rempt <boud@valdyas.org>:
> https://bugs.kde.org/show_bug.cgi?id=332130
>
> --- Comment #11 from Boudewijn Rempt <boud@valdyas.org> ---
> Yes... There'll always be bugs that won't be fixed in time for the next
> version...
>
> --
> You are receiving this mail because:
> You are on the CC list for the bug.
Comment 13 Dmitry Kazakov 2014-05-05 08:37:21 UTC
It might be some transaction-related problem, which prevents Unsharp Mask accessing oldRawData
Comment 14 Dmitry Kazakov 2014-05-05 08:50:35 UTC
Git commit 5b3de8cc8ca6d58f0ef8d131c5ef3ff40c32416c by Dmitry Kazakov.
Committed on 05/05/2014 at 08:50.
Pushed by dkazakov into branch 'master'.

Fix using a transaction in the Filter Op

Otherwise the filters like Gaussian Blur and Unsharp Mask will not work
correctly.

M  +4    -0    krita/plugins/paintops/filterop/kis_filterop.cpp

http://commits.kde.org/calligra/5b3de8cc8ca6d58f0ef8d131c5ef3ff40c32416c
Comment 15 MichalG 2014-05-19 12:23:36 UTC
Well, I didn't find it fixed in latest bugfix version (v2.8.3) but I
hope I will see it in 2.8.5 or 2.9!  :P

2014-05-05 10:50 GMT+02:00 Dmitry Kazakov <dimula73@gmail.com>:
> https://bugs.kde.org/show_bug.cgi?id=332130
>
> Dmitry Kazakov <dimula73@gmail.com> changed:
>
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
>              Status|CONFIRMED                   |RESOLVED
>          Resolution|---                         |FIXED
>       Latest Commit|                            |http://commits.kde.org/call
>                    |                            |igra/5b3de8cc8ca6d58f0ef8d1
>                    |                            |31c5ef3ff40c32416c
>
> --- Comment #14 from Dmitry Kazakov <dimula73@gmail.com> ---
> Git commit 5b3de8cc8ca6d58f0ef8d131c5ef3ff40c32416c by Dmitry Kazakov.
> Committed on 05/05/2014 at 08:50.
> Pushed by dkazakov into branch 'master'.
>
> Fix using a transaction in the Filter Op
>
> Otherwise the filters like Gaussian Blur and Unsharp Mask will not work
> correctly.
>
> M  +4    -0    krita/plugins/paintops/filterop/kis_filterop.cpp
>
> http://commits.kde.org/calligra/5b3de8cc8ca6d58f0ef8d131c5ef3ff40c32416c
>
> --
> You are receiving this mail because:
> You are on the CC list for the bug.
Comment 16 Halla Rempt 2014-06-02 09:12:25 UTC
Git commit 13657911836f1996de6154b305386c3e72944c34 by Boudewijn Rempt, on behalf of Dmitry Kazakov.
Committed on 05/05/2014 at 08:50.
Pushed by rempt into branch 'calligra/2.8'.

Fix using a transaction in the Filter Op

Otherwise the filters like Gaussian Blur and Unsharp Mask will not work
correctly.

M  +4    -0    krita/plugins/paintops/filterop/kis_filterop.cpp

http://commits.kde.org/calligra/13657911836f1996de6154b305386c3e72944c34