Bug 331141

Summary: Broken link to database schema in web site digikam.org pointing to project.kde.org
Product: digikam Reporter: jmt <nfoi>
Component: WebsiteAssignee: Digikam Developers <digikam-bugs-null>
Status: RESOLVED FIXED    
Severity: normal CC: aacid, caulier.gilles, sysadmin
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In: 6.0.0

Description jmt 2014-02-14 18:58:19 UTC
The page :
http://www.digikam.org/docs
mentions in section "Documentation/API and database schema" a link "Database schema" that points to :
https://projects.kde.org/projects/extragear/graphics/digikam/repository/revisions/master/show/project/documents/DBSCHEMA.ODS
but returns a 404.

Reproducible: Always

Steps to Reproduce:
1.Open http://www.digikam.org/docs
2.Click "Database schema"
Actual Results:  
No access to database schema

Expected Results:  
Details of database schema, either sqlite or mysql
Comment 1 caulier.gilles 2014-06-16 08:24:28 UTC
I forward this report to KDE admin. There is a problem with https://projects.kde.org/ into digiKam repository entry to show content of directory "documents"

https://projects.kde.org/projects/extragear/graphics/digikam/repository/revisions/master/show/project/documents

Note : parent dir "project" show this dir entry in the list.

Gilles Caulier
Comment 2 Albert Astals Cid 2014-06-16 18:38:22 UTC
To make it more "obvious"
 * Go to https://projects.kde.org/projects/extragear/graphics/digikam/repository/revisions/master/show/project
 * Click on documents
 * Get a 404
Comment 3 Ben Cooksley 2014-06-17 09:47:01 UTC
Caused by yet another routing conflict. I've fixed it for now.
Please avoid linking to projects.kde.org and use quickgit.kde.org as it is more reliable and efficient.
Comment 4 caulier.gilles 2014-06-18 08:00:02 UTC
Thanks Ben, link fixed...

Another Question is about this page :

http://www.digikam.org/sharedlibs

where a link is provided for contributors about libkface API :

http://api.kde.org/extragear-api/libs-apidocs/libkface/libkface/html/index.html

...and this one report a 404 error.

Gilles Caulier
Comment 5 Ben Cooksley 2014-06-18 11:44:51 UTC
You'll probably need to ensure libkface has a Mainpage.dox file at the very least. Otherwise i'd suggest asking Allen why it isn't being generated.
Comment 6 caulier.gilles 2014-06-18 11:55:31 UTC
Right file is missing. It's fixed now...

We will see if API doc will be export to web interface.

Thanks

Gilles Caulier
Comment 7 caulier.gilles 2018-08-25 13:31:42 UTC
Git commit 5eec07143fbdfaa634ca56a3b420b41de7eb2c1d by Human Dynamo.
Committed on 25/08/2018 at 13:23.
Pushed by cgilles into branch 'master'.

fix link to database schema libreoffice file
FIXED-IN: 6.0.0

M  +1    -1    core/libs/database/item/imageinfo.h

https://commits.kde.org/digikam/5eec07143fbdfaa634ca56a3b420b41de7eb2c1d