Bug 330038

Summary: Nepomuk crashed at logout
Product: [Frameworks and Libraries] Akonadi Reporter: Sadako Sasaki <sadako>
Component: Nepomuk Feeder AgentsAssignee: kdepim bugs <kdepim-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: me, vkrause
Priority: NOR Keywords: drkonqi
Version: 4.12   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:

Description Sadako Sasaki 2014-01-16 15:46:28 UTC
Application: akonadi_nepomuk_feeder (4.12)
KDE Platform Version: 4.12.0
Qt Version: 4.8.4
Operating System: Linux 3.11.0-15-generic i686
Distribution: Ubuntu 13.10

-- Information about the crash:
when i want to logout from my kde session nepomuk and sometimes other applications are crashing with segmentation fault error. after close the windows i can logout

The crash can be reproduced sometimes.

-- Backtrace:
Application: Nepomuk-Modul für Akonadi (akonadi_nepomuk_feeder), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[KCrash Handler]
#7  0xb601d282 in QRasterWindowSurface::~QRasterWindowSurface (this=0x89a9020, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:117
#8  0xb601d30c in QRasterWindowSurface::~QRasterWindowSurface (this=0x89a9020, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:121
#9  0xb6038154 in QWidgetBackingStore::~QWidgetBackingStore (this=<optimized out>, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:909
#10 0xb5e46683 in QWidgetBackingStoreTracker::destroy (this=0x89a8fa8) at kernel/qwidget.cpp:221
#11 0xb5e46838 in QWidgetPrivate::deleteExtra (this=this@entry=0x89a0560) at kernel/qwidget.cpp:1835
#12 0xb5e46a3d in QWidgetPrivate::~QWidgetPrivate (this=0x89a0560, __in_chrg=<optimized out>) at kernel/qwidget.cpp:361
#13 0xb5e46cec in QWidgetPrivate::~QWidgetPrivate (this=0x89a0560, __in_chrg=<optimized out>) at kernel/qwidget.cpp:366
#14 0xb6b82056 in cleanup (pointer=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:62
#15 ~QScopedPointer (this=0x8990174, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:100
#16 QObject::~QObject (this=0x8990170, __in_chrg=<optimized out>) at kernel/qobject.cpp:816
#17 0xb5e50265 in QWidget::~QWidget (this=<optimized out>, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1556
#18 0xb68616ec in AbstractSystemPoller::~AbstractSystemPoller (this=0x8990170, __in_chrg=<optimized out>) at ../../kutils/kidletime/abstractsystempoller.cpp:26
#19 0xb6863a7f in ~XSyncBasedPoller (this=0x8990170, __in_chrg=<optimized out>) at ../../kutils/kidletime/xsyncbasedpoller.cpp:100
#20 XSyncBasedPoller::~XSyncBasedPoller (this=0x8990170, __in_chrg=<optimized out>) at ../../kutils/kidletime/xsyncbasedpoller.cpp:102
#21 0xb68638f9 in ~XSyncBasedPollerHelper (this=0x8986ba0, __in_chrg=<optimized out>) at ../../kutils/kidletime/xsyncbasedpoller.cpp:33
#22 destroy () at ../../kutils/kidletime/xsyncbasedpoller.cpp:38
#23 0xb6861149 in KCleanUpGlobalStatic::~KCleanUpGlobalStatic (this=0xb686a17c <._272::operator->()::cleanUpObject>, __in_chrg=<optimized out>) at ../../kdecore/kernel/kglobal.h:62
#24 0xb5a39791 in __run_exit_handlers (status=status@entry=0, listp=0xb5bb63e4 <__exit_funcs>, run_list_atexit=run_list_atexit@entry=true) at exit.c:77
#25 0xb5a3981d in __GI_exit (status=0) at exit.c:99
#26 0xb5a1f90d in __libc_start_main (main=0x8051200, argc=3, ubp_av=0xbf88a6e4, init=0x806cce0 <__libc_csu_init>, fini=0x806cd50 <__libc_csu_fini>, rtld_fini=0xb77135f0 <_dl_fini>, stack_end=0xbf88a6dc) at libc-start.c:294
#27 0x08051278 in _start ()

Possible duplicates by query: bug 327798, bug 320766.

Reported using DrKonqi
Comment 1 Jekyll Wu 2014-01-17 01:53:21 UTC

*** This bug has been marked as a duplicate of bug 261539 ***