Bug 327761

Summary: errors muon update + errors exe. terminal error 404
Product: Discover Reporter: ualacepersa <ualacepersa>
Component: Updates (interactive)Assignee: Jonathan Thomas <echidnaman>
Status: RESOLVED DUPLICATE    
Severity: crash Keywords: drkonqi
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description ualacepersa 2013-11-18 11:09:23 UTC
Application: muon-updater (2.1.1)
KDE Platform Version: 4.11.2
Qt Version: 4.8.4
Operating System: Linux 3.11.0-13-generic x86_64
Distribution: Ubuntu 13.10

-- Information about the crash:
- What I was doing when the application crashed:

_____________________________________________________
1 - He says there are 21 updates but gives error when 
running the update manager muon, 
(tries to load but fails to open)
_____________________________________________________
2 - correction:
I corrected the 404's in this tutorial

and my update repository is the Brazilian

The crash can be reproduced every time.

-- Backtrace:
Application: Gerenciador de atualizaƧƵes do Muon (muon-updater), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f8157cf97c0 (LWP 6395))]

Thread 3 (Thread 0x7f8144d52700 (LWP 6396)):
#0  0x00007f8155357f7d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f81526e46a4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f81526e47ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f8155adda76 in QEventDispatcherGlib::processEvents (this=0x7f81400008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f8155aaf5ef in QEventLoop::processEvents (this=this@entry=0x7f8144d51d70, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f8155aaf8e5 in QEventLoop::exec (this=this@entry=0x7f8144d51d70, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f81559ae88f in QThread::exec (this=this@entry=0x184fad0) at thread/qthread.cpp:542
#7  0x00007f8155a90d13 in QInotifyFileSystemWatcherEngine::run (this=0x184fad0) at io/qfilesystemwatcher_inotify.cpp:265
#8  0x00007f81559b0f2f in QThreadPrivate::start (arg=0x184fad0) at thread/qthread_unix.cpp:338
#9  0x00007f8152bbcf6e in start_thread (arg=0x7f8144d52700) at pthread_create.c:311
#10 0x00007f81553649cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7f8134b40700 (LWP 6411)):
#0  0x00007f8155357f7d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f81526e46a4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f81526e47ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f8155adda76 in QEventDispatcherGlib::processEvents (this=0x7f81280008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f8155aaf5ef in QEventLoop::processEvents (this=this@entry=0x7f8134b3fd70, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f8155aaf8e5 in QEventLoop::exec (this=this@entry=0x7f8134b3fd70, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f81559ae88f in QThread::exec (this=this@entry=0x18be900) at thread/qthread.cpp:542
#7  0x00007f8155a90d13 in QInotifyFileSystemWatcherEngine::run (this=0x18be900) at io/qfilesystemwatcher_inotify.cpp:265
#8  0x00007f81559b0f2f in QThreadPrivate::start (arg=0x18be900) at thread/qthread_unix.cpp:338
#9  0x00007f8152bbcf6e in start_thread (arg=0x7f8134b40700) at pthread_create.c:311
#10 0x00007f81553649cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7f8157cf97c0 (LWP 6395)):
[KCrash Handler]
#6  UpdateModel::setResources (this=0x18f0f60, resources=...) at /build/buildd/muon-2.1.1/updater/UpdateModel/UpdateModel.cpp:248
#7  0x00000000004111a9 in UpdaterWidget::populateUpdateModel (this=this@entry=0x17e2fa0) at /build/buildd/muon-2.1.1/updater/UpdaterWidget.cpp:163
#8  0x000000000041127e in UpdaterWidget::activityChanged (this=0x17e2fa0) at /build/buildd/muon-2.1.1/updater/UpdaterWidget.cpp:148
#9  0x000000000040d2b5 in UpdaterWidget::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=<optimized out>, _c=<optimized out>) at /build/buildd/muon-2.1.1/obj-x86_64-linux-gnu/updater/moc_UpdaterWidget.cpp:72
#10 0x00007f8155ac4a58 in QMetaObject::activate (sender=0x17cbec0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3539
#11 0x00007f81578ee485 in ResourcesModel::qt_static_metacall (_o=0x17cbec0, _id=0, _a=0x0, _c=<optimized out>) at /build/buildd/muon-2.1.1/obj-x86_64-linux-gnu/libmuon/moc_ResourcesModel.cpp:90
#12 0x00007f8155ac4a58 in QMetaObject::activate (sender=sender@entry=0x17cbec0, m=m@entry=0x7f8157b14180 <ResourcesModel::staticMetaObject>, local_signal_index=local_signal_index@entry=1, argv=argv@entry=0x0) at kernel/qobject.cpp:3539
#13 0x00007f81578ee1f3 in ResourcesModel::allInitialized (this=this@entry=0x17cbec0) at /build/buildd/muon-2.1.1/obj-x86_64-linux-gnu/libmuon/moc_ResourcesModel.cpp:184
#14 0x00007f81578fb907 in ResourcesModel::resetBackend (this=0x17cbec0, backend=0x1bc1170) at /build/buildd/muon-2.1.1/libmuon/resources/ResourcesModel.cpp:269
#15 0x00007f81578ee595 in ResourcesModel::qt_static_metacall (_o=0x17cbec0, _id=0, _a=0x0, _c=<optimized out>) at /build/buildd/muon-2.1.1/obj-x86_64-linux-gnu/libmuon/moc_ResourcesModel.cpp:101
#16 0x00007f8155ac4a58 in QMetaObject::activate (sender=0x1bc1170, m=m@entry=0x7f8157b143c0 <AbstractResourcesBackend::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3539
#17 0x00007f81578ed940 in AbstractResourcesBackend::fetchingChanged (this=<optimized out>) at /build/buildd/muon-2.1.1/obj-x86_64-linux-gnu/libmuon/moc_AbstractResourcesBackend.cpp:156
#18 0x00007f814411490f in KNSBackend::setFetching (this=<optimized out>, f=f@entry=false) at /build/buildd/muon-2.1.1/libmuon/backends/KNSBackend/KNSBackend.cpp:112
#19 0x00007f8144114c97 in KNSBackend::receivedEntries (this=0x1bc1170, entries=...) at /build/buildd/muon-2.1.1/libmuon/backends/KNSBackend/KNSBackend.cpp:186
#20 0x00007f8155ac4a58 in QMetaObject::activate (sender=0x1bbf7d0, m=m@entry=0x7f813fffc2c0 <KNS3::DownloadManager::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7fffc7040720) at kernel/qobject.cpp:3539
#21 0x00007f813fdaffd2 in KNS3::DownloadManager::searchResult (this=<optimized out>, _t1=...) at ./downloadmanager.moc:113
#22 0x00007f813fdb014a in KNS3::DownloadManager::Private::_k_slotEntriesLoaded (this=0x1b70ec0, entries=...) at ../../../knewstuff/knewstuff3/downloadmanager.cpp:117
#23 0x00007f8155ac4a58 in QMetaObject::activate (sender=sender@entry=0x16ff820, m=m@entry=0x7f813fffc740 <KNS3::Engine::staticMetaObject>, local_signal_index=local_signal_index@entry=2, argv=argv@entry=0x7fffc70408c0) at kernel/qobject.cpp:3539
#24 0x00007f813fdb770b in signalEntriesLoaded (_t1=..., this=0x16ff820) at ./engine.moc:199
#25 KNS3::Engine::slotEntriesLoaded (this=0x16ff820, request=..., entries=...) at ../../../knewstuff/knewstuff3/core/engine.cpp:280
#26 0x00007f813fdb9f36 in KNS3::Engine::qt_static_metacall (_o=0x16ff820, _id=0, _a=0x0, _c=<optimized out>) at ./engine.moc:129
#27 0x00007f8155ac4a58 in QMetaObject::activate (sender=sender@entry=0x1f1db20, m=m@entry=0x7f813fffc960 <KNS3::Provider::staticMetaObject>, local_signal_index=local_signal_index@entry=1, argv=argv@entry=0x7fffc7040a60) at kernel/qobject.cpp:3539
#28 0x00007f813fdc56ba in KNS3::Provider::loadingFinished (this=this@entry=0x1f1db20, _t1=..., _t2=...) at ./provider.moc:125
#29 0x00007f813fdda4bb in KNS3::AtticaProvider::categoryContentsLoaded (this=0x1f1db20, job=<optimized out>) at ../../../knewstuff/knewstuff3/attica/atticaprovider.cpp:230
#30 0x00007f8155ac4a58 in QMetaObject::activate (sender=0x353f6b0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffc7040c70) at kernel/qobject.cpp:3539
#31 0x00007f8153c2730f in Attica::BaseJob::finished(Attica::BaseJob*) () from /usr/lib/x86_64-linux-gnu/libattica.so.0.4
#32 0x00007f8153c274e9 in Attica::BaseJob::dataFinished() () from /usr/lib/x86_64-linux-gnu/libattica.so.0.4
#33 0x00007f8155ac4a58 in QMetaObject::activate (sender=0x353e880, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3539
#34 0x00007f8155ab8bf8 in QMetaMethod::invoke (this=this@entry=0x7fffc7041180, object=object@entry=0x353e880, connectionType=Qt::DirectConnection, connectionType@entry=Qt::AutoConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1664
#35 0x00007f8155abb0b8 in QMetaObject::invokeMethod (obj=obj@entry=0x353e880, member=member@entry=0x7f814b0e1645 "finished", type=type@entry=Qt::AutoConnection, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1179
#36 0x00007f814af79bbc in invokeMethod (val9=..., val8=..., val7=..., val6=..., val5=..., val4=..., val3=..., val2=..., val1=..., val0=..., type=Qt::AutoConnection, member=0x7f814b0e1645 "finished", obj=0x353e880) at /usr/include/qt4/QtCore/qobjectdefs.h:418
#37 KDEPrivate::AccessManagerReply::emitFinished (this=this@entry=0x353e880, state=state@entry=true, type=type@entry=Qt::AutoConnection) at ../../kio/kio/accessmanagerreply_p.cpp:484
#38 0x00007f814af7b840 in KDEPrivate::AccessManagerReply::slotResult (this=0x353e880, kJob=0x3302cd0) at ../../kio/kio/accessmanagerreply_p.cpp:427
#39 0x00007f8155ac4a58 in QMetaObject::activate (sender=sender@entry=0x3302cd0, m=m@entry=0x7f81562c9600 <KJob::staticMetaObject>, local_signal_index=local_signal_index@entry=3, argv=argv@entry=0x7fffc7041670) at kernel/qobject.cpp:3539
#40 0x00007f8155f390c2 in KJob::result (this=this@entry=0x3302cd0, _t1=_t1@entry=0x3302cd0) at ./kjob.moc:208
#41 0x00007f8155f39100 in KJob::emitResult (this=this@entry=0x3302cd0) at ../../kdecore/jobs/kjob.cpp:318
#42 0x00007f814afb5e3a in KIO::SimpleJob::slotFinished (this=this@entry=0x3302cd0) at ../../kio/kio/job.cpp:496
#43 0x00007f814afb6f8e in KIO::TransferJob::slotFinished (this=0x3302cd0) at ../../kio/kio/job.cpp:1099
#44 0x00007f8155ac4a58 in QMetaObject::activate (sender=0x1de22d0, m=m@entry=0x7f814b35f580 <KIO::SlaveInterface::staticMetaObject>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0x0) at kernel/qobject.cpp:3539
#45 0x00007f814b053d33 in KIO::SlaveInterface::finished (this=<optimized out>) at ./slaveinterface.moc:185
#46 0x00007f814b055276 in KIO::SlaveInterface::dispatch (this=<optimized out>, _cmd=104, rawdata=...) at ../../kio/kio/slaveinterface.cpp:176
#47 0x00007f814b052d6e in KIO::SlaveInterface::dispatch (this=0x1de22d0) at ../../kio/kio/slaveinterface.cpp:92
#48 0x00007f814b0479d6 in KIO::Slave::gotInput (this=0x1de22d0) at ../../kio/kio/slave.cpp:344
#49 0x00007f8155ac4a58 in QMetaObject::activate (sender=0x1bb8f90, m=m@entry=0x7f814b358aa0 <KIO::Connection::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3539
#50 0x00007f814af831e0 in KIO::Connection::readyRead (this=<optimized out>) at ./connection.moc:106
#51 0x00007f814af838d1 in KIO::ConnectionPrivate::dequeue (this=0x2108560) at ../../kio/kio/connection.cpp:82
#52 0x00007f8155ac8dce in QObject::event (this=0x1bb8f90, e=<optimized out>) at kernel/qobject.cpp:1194
#53 0x00007f81564a1dfc in QApplicationPrivate::notify_helper (this=this@entry=0x165a2c0, receiver=receiver@entry=0x1bb8f90, e=e@entry=0x1bd9260) at kernel/qapplication.cpp:4567
#54 0x00007f81564a8470 in QApplication::notify (this=this@entry=0x7fffc70423c0, receiver=receiver@entry=0x1bb8f90, e=e@entry=0x1bd9260) at kernel/qapplication.cpp:4353
#55 0x00007f81571aba6a in KApplication::notify (this=0x7fffc70423c0, receiver=0x1bb8f90, event=0x1bd9260) at ../../kdeui/kernel/kapplication.cpp:311
#56 0x00007f8155ab08bd in QCoreApplication::notifyInternal (this=0x7fffc70423c0, receiver=receiver@entry=0x1bb8f90, event=event@entry=0x1bd9260) at kernel/qcoreapplication.cpp:946
#57 0x00007f8155ab3e1f in sendEvent (event=0x1bd9260, receiver=0x1bb8f90) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#58 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x1625500) at kernel/qcoreapplication.cpp:1570
#59 0x00007f8155ab42c3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1463
#60 0x00007f8155ade073 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#61 postEventSourceDispatch (s=0x1654b70) at kernel/qeventdispatcher_glib.cpp:279
#62 0x00007f81526e43b6 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#63 0x00007f81526e4708 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#64 0x00007f81526e47ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#65 0x00007f8155adda55 in QEventDispatcherGlib::processEvents (this=0x1626de0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#66 0x00007f81565439d6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#67 0x00007f8155aaf5ef in QEventLoop::processEvents (this=this@entry=0x7fffc70422c0, flags=...) at kernel/qeventloop.cpp:149
#68 0x00007f8155aaf8e5 in QEventLoop::exec (this=this@entry=0x7fffc70422c0, flags=...) at kernel/qeventloop.cpp:204
#69 0x00007f8155ab4e5b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#70 0x00007f81564a034c in QApplication::exec () at kernel/qapplication.cpp:3828
#71 0x000000000040ce11 in main (argc=1, argv=0x7fffc70424f8) at /build/buildd/muon-2.1.1/updater/main.cpp:59

Possible duplicates by query: bug 327544.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-11-18 12:22:58 UTC

*** This bug has been marked as a duplicate of bug 327544 ***