Bug 324770

Summary: Tearing with NVidia drivers every time KDE starts
Product: [Plasma] kwin Reporter: BasioMeusPuga <disgruntled.mob>
Component: scene-openglAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: major    
Priority: NOR    
Version: 4.11.1   
Target Milestone: ---   
Platform: Arch Linux   
OS: Linux   
Latest Commit: Version Fixed In:

Description BasioMeusPuga 2013-09-10 21:40:19 UTC
I'm getting significant tearing every time I start KDE. 
It goes away after I change the 'Scale method' under System Settings > Desktop Effects > Advanced > General Options (The actual setting is not important, but a change is required every time); OR if the OpenGL Compositing type is changed (Again, just a change is needed).

After a reboot, the tearing recurs and the process has to be repeated.

I'm using KDE 4.11.1 (bug has been present since 4.11.0), the proprietary Nvidia drivers (325.15) with OpenGL 3.1 compositing and Raster graphics. The tearing prevention is set to Re-use Screen Content.

Reproducible: Always

Steps to Reproduce:
1. Start KDE
2. Move window with Titlebar drag / Watch video in any player
3. Pronounced tearing in region of movement
4. Go to System Settings > Desktop effects > Advanced > Scale Method and change setting (to anything)
5. Tearing disappears
6. Restart KDE
7. Problem recurs.
Actual Results:  
Significant tearing.

Expected Results:  
No tearing.
Comment 1 Thomas L├╝bking 2013-09-10 21:53:09 UTC
https://git.reviewboard.kde.org/r/112368/

*** This bug has been marked as a duplicate of bug 322060 ***