Bug 322820

Summary: Playlist is not reachable from home screen
Product: plasma-mediacenter Reporter: Shantanu Tushar <shantanu>
Component: PlaylistAssignee: Sinny Kumari <ksinny>
Status: RESOLVED FIXED    
Severity: minor CC: kaushik.varanasi1, rcrukshan17
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Other   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: this is a change in mediacenter.qml file.

Description Shantanu Tushar 2013-07-25 17:38:05 UTC
I can't access the playlist without entering one of the modes, this is confusing.

Reproducible: Always

Steps to Reproduce:
1. Open PMC
2. Look for an option to launch playlist

Actual Results:  
No option to launch playlist

Expected Results:  
There should be an option to launch the playlist
Comment 1 kaushik varanasi 2013-11-05 10:47:08 UTC
@Shantanu

hey, i have been busy with my exams so couldn't concentrate on this.
Just came across this bug so have been working on it.

i have solved the issue, and submitted the patch, if anything is wrong please inform !!
Comment 2 kaushik varanasi 2013-11-05 10:50:01 UTC
Created attachment 83351 [details]
this is a change in mediacenter.qml file.

on clicking in the empty area in the begenning one can access the playlist directly, this avoids the burden of selecting the media type and then going to the playlist.
Comment 3 Shantanu Tushar 2013-11-07 17:50:43 UTC
Hi Kaushik, the patch you submitted will only work when mediaPlayerInstance is null [that is when if(mediaPlayerInstance) returns false]. So it will not work once the user has played something (because then mediaPlayerInstance will be loaded and it will have some value).

We want an entry or something similar to "Fullscreen", "Exit" for "Playlist" which will in turn show the playlist. See if you can do something like that. Also, this is just a suggestion, feel free to suggest other approaches which might be simpler.
Comment 4 rukshan 2014-03-05 05:24:24 UTC
Hi, 
Is this bug still exist or is someone fixing? if not can i working on fixing this?
Comment 5 Shantanu Tushar 2014-03-05 05:25:49 UTC
(In reply to comment #4)
> Hi, 
> Is this bug still exist or is someone fixing? if not can i working on fixing
> this?

This bug still exists and I think you can go ahead and pick it up
Comment 6 rukshan 2014-03-05 06:27:14 UTC
thanks Tushar.
 I will work on this.
Comment 7 Shantanu Tushar 2014-03-06 17:43:15 UTC
Git commit 67032817d71905261d94a2c9775f033eb62863b1 by Shantanu Tushar.
Committed on 06/03/2014 at 17:41.
Pushed by shantanu into branch 'master'.

Show the playlist when empty area is clicked and there is no media playing.

Patch by Ashish Madeti <ashishmadeti@gmail.com>
REVIEW: 116620

M  +1    -1    shells/newshell/package/contents/ui/mediacenter.qml

http://commits.kde.org/plasma-mediacenter/67032817d71905261d94a2c9775f033eb62863b1