Bug 321847

Summary: Text gets cut off on the bottom when the taskbar is set to a small enough height
Product: [Plasma] plasma4 Reporter: Kåre Särs <kare.sars>
Component: widget-taskbarAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED DUPLICATE    
Severity: normal CC: hein
Priority: NOR    
Version: 4.10.90   
Target Milestone: ---   
Platform: Other   
OS: Linux   
Latest Commit: Version Fixed In:
Sentry Crash Report:
Attachments: Patch to fix text being cut off
Patch to fix text being cut off at the bottom

Description Kåre Särs 2013-07-02 01:32:13 UTC
When the taskbar-height is smaal enough the text is cut off at the bottom. The icon size is also to tiny. (horizontal mode)

Reproducible: Always

Steps to Reproduce:
1. Resize to a smaler size than default minimum

Actual Results:  
The text is cut off at the bottom and the icon is almost unvisible

Expected Results:  
As long as the text would fit, the margins at the top and bottom shrink. And the icon would not be shrunk so much.
Comment 1 Kåre Särs 2013-07-02 01:37:21 UTC
Created attachment 80891 [details]
Patch to fix text being cut off

Attached patch vertical-centers the text in the task item and removes the top/bottom margins around the icon if the height is smaler than "theme.smallIconSize"
Comment 2 Kåre Särs 2013-07-02 03:32:45 UTC
Created attachment 80893 [details]
Patch to fix text being cut off at the bottom

The previous patch was a little too agressive on removing margins
Comment 3 Christoph Feck 2013-07-02 11:49:24 UTC
Kåre, thanks for the patch! Could you put it on https://git.reviewboard.kde.org/ please? Otherwise it might get lost.

*** This bug has been marked as a duplicate of bug 314879 ***