Bug 316187

Summary: qapt-deb-installer cannot install from paths containing !latin characters
Product: muon Reporter: Volkan <volkangezer>
Component: qapt-deb-installerAssignee: Jonathan Thomas <echidnaman>
Status: RESOLVED FIXED    
Severity: normal CC: atalanttore, rohan, sbw, sitter, themanchicken
Priority: NOR    
Version: 1.4.1   
Target Milestone: ---   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description Volkan 2013-03-05 20:00:04 UTC
When you click on .deb file to install it without commands, it opens a
dialog to install (QApt) and when you click on Install, it asks for
password.

Continuing to operation shows DONE, but actually it installs nothing.

Using terminal does not have the same problem.

Reproducible: Always

Steps to Reproduce:
1. Download a .deb file
2. Click to open qapt installer
3. Click Install
4. Wait until it shows "DONE".
Actual Results:  
It does not install the package.

Expected Results:  
It should install the package.

Type: dpkg -i google...... and it installs without any problems.

PS: I reinstalled qapt packages, but no progress...
Comment 1 Volkan 2013-03-13 13:54:02 UTC
I also forgot to add that I am using Kubuntu 12.10 x64
Comment 2 Volkan 2013-12-13 03:16:56 UTC
Aha! It seems this bug cannot be reproduced in English. This bug is valid for all non-English languages.
Comment 3 Volkan 2014-02-24 14:19:02 UTC
Any updates to this?
Comment 4 Harald Sitter 2014-02-27 10:48:07 UTC
Happens because qaptworker2 invoked via dbus and therefore has no LANG variable, so it will try to decode the path as ISO which will of course fail because it is UTF8 and the rest of the system in general will use UTF8.

So most likely qaptworker needs a way to set the LANG it should be run as.

This is also the reason that qapt output in general will not be correctly encoded when the native dpkg/apt output is localized and contains non-latin characters (e.g. when setting a german locale you get broken umlauts).
Comment 5 Rohan Garg 2014-03-05 16:06:22 UTC
Seems to be fixed in 2.1.70
Comment 6 Harald Sitter 2014-03-05 16:11:45 UTC
It is not.

You need a non-ascii folder name such as Überdirectory
Comment 7 Rohan Garg 2014-03-05 16:14:43 UTC
Ahhh yeah, can reprdouce now.
Comment 8 Harald Sitter 2014-07-03 10:47:47 UTC
Git commit 4b6cd0f2e21febae0ca6c4e9818c9e9ea98b1ade by Harald Sitter.
Committed on 03/07/2014 at 10:47.
Pushed by sitter into branch 'master'.

Merge branch '2.2'


http://commits.kde.org/libqapt/4b6cd0f2e21febae0ca6c4e9818c9e9ea98b1ade
Comment 9 Ettore Atalan 2014-10-30 13:45:50 UTC
I still have this problem with version 2.2 on Kubuntu 14.10 x64.

I got this console output:
~/Arbeitsfläche> qapt-deb-installer 4pane_3.0-2.utopic_amd64.deb
Bus::open: Can not get ibus-daemon's address. 
IBusInputContext::createInputContext: no connection to ibus-daemon 
found error while replying QDBusError("org.freedesktop.DBus.Error.InvalidArgs", "")
Comment 10 sbw 2017-07-12 11:32:17 UTC
This problem seems reappeared in 3.0.x, please see https://bugs.kde.org/show_bug.cgi?id=382272