Bug 314854

Summary: regression with KDE 4.10: Lyrics background has the wrong colour
Product: amarok Reporter: Christian (Fuchs) <kde>
Component: Context View/LyricsAssignee: Amarok Developers <amarok-bugs-dist>
Status: RESOLVED FIXED    
Severity: normal CC: e.m.a.t.i.r.o.v, hrvoje.senjan, matej, simon.esneault, stefano, thomas
Priority: NOR Keywords: regression
Version: 2.8.0   
Target Milestone: 2.9   
Platform: Gentoo Packages   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: Screenshot showing the problem
old state 1
old state 2
Color change depending on Selection Background setting

Description Christian (Fuchs) 2013-02-10 21:04:22 UTC
Since updating to KDE 4.10, the lyrics background colour is wrong. 
It used to be the same blue-ish background as the other context views (e.g. wikipedia, similar artists) have, now it is all white (see attached screenshot). 

Not sure if an amarok or plasma problem, but so far I only see amarok affected.

Reproducible: Always

Steps to Reproduce:
1. Get KDE 4.10
2. Start amarok
3. Switch to lyrics view
Actual Results:  
Background has wrong colour

Expected Results:  
Background has the same colour as other context views
Comment 1 Christian (Fuchs) 2013-02-10 21:04:41 UTC
Created attachment 77106 [details]
Screenshot showing the problem
Comment 2 Myriam Schweingruber 2013-02-11 09:00:35 UTC
Confirmed.
Comment 3 Matěj Laitl 2013-03-18 19:42:22 UTC
Please also provide screenshot of the "old" state for clarity.
Comment 4 Christian (Fuchs) 2013-03-18 20:06:54 UTC
Created attachment 78184 [details]
old state 1
Comment 5 Christian (Fuchs) 2013-03-18 20:07:11 UTC
Created attachment 78185 [details]
old state 2
Comment 6 Mikhail Ivchenko 2013-12-04 10:21:50 UTC
Still not fixed for Amarok v2.8.0 and KDE 4.11.3
Comment 7 Thomas Mitterfellner 2013-12-30 21:28:04 UTC
To me it seems that it's not the /lyrics/ color's background is wrong, but rather e.g. the one of the wikipedia plugin. The wikipedia background seems to be connected somehow to the global "Selection Background" setting. But it does not get exactly the color chosen there but rather some transparency/intensity-modified version thereof. In fact, all of the background colors seem to be derived from the global "Selection Background", see screenshot. Different global Selection Background settings lead to different 'one color themes'.

While this feature is nice, for the page background that is not what I would expect. I'd rather expect the page background to be derived from the global "View Background" setting, just as is the case for the lyrics browser (IMO the 'correct' behavior).
Comment 8 Thomas Mitterfellner 2013-12-30 21:29:43 UTC
Created attachment 84354 [details]
Color change depending on Selection Background setting
Comment 9 coolguysarehere+kde 2014-02-26 21:47:11 UTC
I would like to fix this bug. Please
Comment 10 coolguysarehere+kde 2014-02-26 21:48:42 UTC
I would like to fix this bug. Please guide me.
Comment 11 Myriam Schweingruber 2014-02-27 15:21:51 UTC
(In reply to comment #10)
> I would like to fix this bug. Please guide me.

Go ahead. The source is available online, so is the documentation, as a developer you should be able to find this on your own.

Please submit your code to reviewboard (steps are in the online documentation as well.
Comment 12 Stefano Pettini 2016-06-19 01:06:53 UTC
Please review fix:
https://git.reviewboard.kde.org/r/128246/

I believe the look and feel of every context applet should be the same, that is a lighter version of the highlight color. This is true for current track, similar artist and other applets, so I support the opinion of the original bug reporter.

I fixed the bug by making the textbox of the lyrics browser transparent.

The lyrics browser also has an "edit lyrics" mode. In this case, the textbox background color is switched to the default on and switched back to transparent after exiting the editing mode.

If you agree with the solution, please review the code and merge my patch.
Comment 13 Matěj Laitl 2016-08-07 10:17:51 UTC
Git commit bdbb3a27f556c41910d3b814e5a4c73a2a93362f by Matěj Laitl, on behalf of Stefano Pettini.
Committed on 07/08/2016 at 09:42.
Pushed by laitl into branch 'master'.

Use transparent background for lyrics browser

This makes the lyrics browser similar to every other context applet.
Please note that, when editing lyrics, the default textbox background
is still used.

REVIEW: 128246

M  +1    -0    ChangeLog
M  +5    -7    src/context/applets/lyrics/LyricsBrowser.cpp

http://commits.kde.org/amarok/bdbb3a27f556c41910d3b814e5a4c73a2a93362f