Bug 314811

Summary: nm 0.9.0.7, can't switch to ipv6 only mode
Product: Network Management Reporter: Philippe ROUBACH <philippe.roubach>
Component: generalAssignee: Lamarque V. Souza <lamarque>
Status: RESOLVED NOT A BUG    
Severity: normal    
Priority: NOR    
Version: 0.9   
Target Milestone: ---   
Platform: openSUSE RPMs   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: snapshot of what the software manager display about dhcp software
network manager log

Description Philippe ROUBACH 2013-02-10 08:31:45 UTC
opensuse 12.2 x86_64
nm 0.9.0.7

my isp supplies an ipv6-ipv4 connection

using opensuse in hybrid mode works well
then
now i want to test ipv6 only mode
then
in networkmanager settings in "ipv4" tab i uncheck "ipv4 is required for this connection"
then
i stop the current ethernet connection
then
i start the ethernet connection
then
with firefox i go to http://ds.testmyipv6.com/
then
i have this result :
Congratulations, you have connected to a server that will display your method of connectivity, either IPv6 (preferred) or IPv4 (old and crusty). etc.

i confirm this by testing with success at the same site the ipv4 test and the ipv6 test


i am still in hybrid mode !

where is the pb ?

Reproducible: Always
Comment 1 Lamarque V. Souza 2013-02-10 12:19:48 UTC
Which dhcp client do you use? My guess is that your dhclient client is not respecting NetworkManager's configuration and trying to get both IPv4 and IPv6 addresses. Please, also send me the NetworkManager's log when the problem happens.
Comment 2 Philippe ROUBACH 2013-02-12 08:37:33 UTC
Created attachment 77186 [details]
snapshot of what the software manager display about dhcp software


here is a snapshot of what the software manager display about dhcp software.
Comment 3 Philippe ROUBACH 2013-02-12 09:00:22 UTC
Created attachment 77189 [details]
network manager log

fist i use ipv4 only
then
i add ipv6
then
i uncheck "ipv4 required..."
Comment 4 Lamarque V. Souza 2013-02-12 11:43:13 UTC
What is contents of file /etc/NetworkManager/system-connections/<connection name>? Remove any line containing screts before pasting it here.
Comment 5 Philippe ROUBACH 2013-02-12 12:31:27 UTC
[802-3-ethernet]
port=mii
mac-address=00:

[connection]
id=Free filaire (ethernet)
uuid=63c757d7-da4f-4892-af1f-1df7deba3147
type=802-3-ethernet
timestamp=1360672138

[ipv6]
method=auto
may-fail=false
ip6-privacy=0

[ipv4]
method=auto
Comment 6 Lamarque V. Souza 2013-02-12 13:37:51 UTC
The configuration is correct. By what I could understand about NetworkManager it always tries both IPv4 and IPv6. The "may-fail" flag is used just to prevent NetworkManager from trying again and again to get configuration for IPv4 or IPv6, but it always tries both at least once, only when one of them fails it uses the may-fail flag to stop trying. With that in mind I think there is no IPv6-only mode in NetworkManager, I mean, there is no way to force NetworkManager to ignore an IPv4 DHCP server except by setting the interface to static address.
Comment 7 Philippe ROUBACH 2013-02-12 15:04:05 UTC
 
in "ipv4" tab i tried : method : unactivated

now i have this :

1. i think it is not normal when you choose "ipv4 not required" it remains these statements :

[ipv4]
method=auto

2.
in "ipv4" tab i tried : method : unactivated

now i have this :

[802-3-ethernet]
port=mii
mac-address=00:

[connection]
id=Free filaire (ethernet)
uuid=63c757d7-da4f-4892-af1f-1df7deba3147
type=802-3-ethernet
timestamp=1360676964

[ipv6]
method=auto
may-fail=false
ip6-privacy=0

[ipv4]
method=disabled

i make test with http://ds.testmyipv6.com/

ipv4test fails
ipv6test succeeds

with another site i ping my pc :
- ipv6 address with success
- ipv4 address with failure

i can rich opensuse site, kde sites , in general a very few sites 

definitively in case we don't want ipv4 it must have a flag "unactivate in the ipv4 part of the networkmanager connection file according to do nothing and keep ipv4 settings for future use

P.S. i found errors about kcm-networkmanager in adding dns
- it accepts only 2a01:5d8:e0ff::1
- it don't accept address like 2A01:5D8:E0FF::1
you can't write or past such address

curiously once an address 2a01:5d8:e0ff::1 is added then it displays  2A01:5D8:E0FF::1 !

and a very annoying one :

the windows about to give root password to record a modification is always displayed behind the modification window, (rarely before)
Comment 8 Lamarque V. Souza 2013-02-12 17:16:40 UTC
Git commit e3ed3cb5b3e57ff427f5d64dec27add6b1f3f678 by Lamarque V. Souza.
Committed on 12/02/2013 at 17:28.
Pushed by lvsouza into branch 'master'.

Fix crash when parsing IPv6 configuration from dbus.

M  +24   -20   backends/NetworkManager/settings/ipv6dbus.cpp
M  +1    -1    plasma_nm_version.h

http://commits.kde.org/networkmanagement/e3ed3cb5b3e57ff427f5d64dec27add6b1f3f678
Comment 9 Lamarque V. Souza 2013-02-12 17:23:22 UTC
Git commit 89f6240d1c8d505930039684df80779fe4a68f96 by Lamarque V. Souza.
Committed on 12/02/2013 at 17:12.
Pushed by lvsouza into branch 'nm09'.

Accept upper case hexadecimal digits in SimpleIpV6AddressValidator.
(cherry picked from commit 332a1faee9daabe1c3275bfe4e04c2f5be340685)

M  +1    -1    libs/ui/simpleipv6addressvalidator.cpp

http://commits.kde.org/networkmanagement/89f6240d1c8d505930039684df80779fe4a68f96
Comment 10 Lamarque V. Souza 2013-02-12 17:26:43 UTC
Git commit 0c86d302fd4e60423de4d14c70845026db072bdd by Lamarque V. Souza.
Committed on 12/02/2013 at 17:28.
Pushed by lvsouza into branch 'nm09'.

Fix crash when parsing IPv6 configuration from dbus.

M  +24   -20   backends/NetworkManager/settings/ipv6dbus.cpp
M  +1    -1    plasma_nm_version.h

http://commits.kde.org/networkmanagement/0c86d302fd4e60423de4d14c70845026db072bdd
Comment 11 Lamarque V. Souza 2013-02-12 17:32:39 UTC
(In reply to comment #7)
> definitively in case we don't want ipv4 it must have a flag "unactivate in
> the ipv4 part of the networkmanager connection file according to do nothing
> and keep ipv4 settings for future use

Good to know that :-) I did not create that dialog so I did not remember there was an option to completely disable IPv4 there.
 
> P.S. i found errors about kcm-networkmanager in adding dns
> - it accepts only 2a01:5d8:e0ff::1
> - it don't accept address like 2A01:5D8:E0FF::1
> you can't write or past such address

I have just fixed that issue.
 
> the windows about to give root password to record a modification is always
> displayed behind the modification window, (rarely before)

Well, that is probably the polkit window, which Plasma NM does not have control of since it is NetworkManager itself that triggers it. Unfortunately forcing a dialog over other is not trivial in Xorg.

Marking this bug as invalid since the original report can be solved with a configuration change. If there is any other issue please fill in another bug report.
Comment 12 Philippe ROUBACH 2013-02-12 17:52:10 UTC
thanks