Bug 314761

Summary: Rekonq crashes when searching with address bar
Product: rekonq Reporter: Matthias Mailänder <matthias>
Component: generalAssignee: Andrea Diamantini <adjam7>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: 2.1   
Target Milestone: ---   
Platform: openSUSE RPMs   
OS: Linux   
Latest Commit: Version Fixed In:

Description Matthias Mailänder 2013-02-09 14:31:20 UTC
Application: rekonq (2.1)
KDE Platform Version: 4.10.00 "release 546"
Qt Version: 4.8.4
Operating System: Linux 3.7.6-2-desktop i686
Distribution: "openSUSE 12.2 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:
  * opened up several tabs, some might be still loading
   * created a new tab and tried to search in the URL bar
  * remembered that I had to add a prefix and pressed POS 1 and :

- Unusual behavior I noticed:
  * freeze and then crash

-- Backtrace:
Application: rekonq (kdeinit4), signal: Segmentation fault
Using host libthread_db library "/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0xb54f3740 (LWP 1596))]

Thread 13 (Thread 0xb07b9b40 (LWP 1597)):
#0  0xb77da424 in __kernel_vsyscall ()
#1  0xb6c58a4c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb3fc4b3d in ?? () from /usr/lib/libQtWebKit.so.4
#3  0xb3fc4b6f in ?? () from /usr/lib/libQtWebKit.so.4
#4  0xb6c54e32 in start_thread () from /lib/libpthread.so.0
#5  0xb5fc37ee in clone () from /lib/libc.so.6

Thread 12 (Thread 0xafe98b40 (LWP 1598)):
#0  0xb77da424 in __kernel_vsyscall ()
#1  0xb6c5badb in read () from /lib/libpthread.so.0
#2  0xb59ecc7e in ?? () from /usr/lib/libglib-2.0.so.0
#3  0xb59ad622 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#4  0xb59ada82 in ?? () from /usr/lib/libglib-2.0.so.0
#5  0xb59adc51 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#6  0xb6e1c64f in QEventDispatcherGlib::processEvents (this=0xaf500468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#7  0xb6de912c in QEventLoop::processEvents (this=this@entry=0xafe98258, flags=...) at kernel/qeventloop.cpp:149
#8  0xb6de9421 in QEventLoop::exec (this=0xafe98258, flags=...) at kernel/qeventloop.cpp:204
#9  0xb6cd4b3c in QThread::exec (this=this@entry=0x8246128) at thread/qthread.cpp:542
#10 0xb6cd4c9b in QThread::run (this=0x8246128) at thread/qthread.cpp:609
#11 0xb6cd7f48 in QThreadPrivate::start (arg=0x8246128) at thread/qthread_unix.cpp:338
#12 0xb6c54e32 in start_thread () from /lib/libpthread.so.0
#13 0xb5fc37ee in clone () from /lib/libc.so.6

Thread 11 (Thread 0xadb50b40 (LWP 1654)):
#0  0xb77da424 in __kernel_vsyscall ()
#1  0xb6c58a4c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xaaf12b18 in queue_processor(void*) () from /usr/lib/IcedTeaPlugin.so
#3  0xb6c54e32 in start_thread () from /lib/libpthread.so.0
#4  0xb5fc37ee in clone () from /lib/libc.so.6

Thread 10 (Thread 0xaa5aeb40 (LWP 1655)):
#0  0xb77da424 in __kernel_vsyscall ()
#1  0xb6c58a4c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xaaf12b18 in queue_processor(void*) () from /usr/lib/IcedTeaPlugin.so
#3  0xb6c54e32 in start_thread () from /lib/libpthread.so.0
#4  0xb5fc37ee in clone () from /lib/libc.so.6

Thread 9 (Thread 0xa9dadb40 (LWP 1656)):
#0  0xb77da424 in __kernel_vsyscall ()
#1  0xb6c58a4c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xaaf12b18 in queue_processor(void*) () from /usr/lib/IcedTeaPlugin.so
#3  0xb6c54e32 in start_thread () from /lib/libpthread.so.0
#4  0xb5fc37ee in clone () from /lib/libc.so.6

Thread 8 (Thread 0xa753db40 (LWP 1675)):
#0  0xb77da424 in __kernel_vsyscall ()
#1  0xb6c58a4c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xa89cabaf in ?? () from /usr/lib/browser-plugins/libflashplayer.so
#3  0xa8591575 in ?? () from /usr/lib/browser-plugins/libflashplayer.so
#4  0xa89cae6c in ?? () from /usr/lib/browser-plugins/libflashplayer.so
#5  0xa89cb516 in ?? () from /usr/lib/browser-plugins/libflashplayer.so
#6  0xb6c54e32 in start_thread () from /lib/libpthread.so.0
#7  0xb5fc37ee in clone () from /lib/libc.so.6

Thread 7 (Thread 0xa6d3cb40 (LWP 1676)):
#0  0xb77da424 in __kernel_vsyscall ()
#1  0xb6c58a4c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xa89cabaf in ?? () from /usr/lib/browser-plugins/libflashplayer.so
#3  0xa8591575 in ?? () from /usr/lib/browser-plugins/libflashplayer.so
#4  0xa89cae6c in ?? () from /usr/lib/browser-plugins/libflashplayer.so
#5  0xa89cb516 in ?? () from /usr/lib/browser-plugins/libflashplayer.so
#6  0xb6c54e32 in start_thread () from /lib/libpthread.so.0
#7  0xb5fc37ee in clone () from /lib/libc.so.6

Thread 6 (Thread 0xa653bb40 (LWP 1677)):
#0  0xb77da424 in __kernel_vsyscall ()
#1  0xb6c58a4c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xa89cabaf in ?? () from /usr/lib/browser-plugins/libflashplayer.so
#3  0xa8591575 in ?? () from /usr/lib/browser-plugins/libflashplayer.so
#4  0xa89cae6c in ?? () from /usr/lib/browser-plugins/libflashplayer.so
#5  0xa89cb516 in ?? () from /usr/lib/browser-plugins/libflashplayer.so
#6  0xb6c54e32 in start_thread () from /lib/libpthread.so.0
#7  0xb5fc37ee in clone () from /lib/libc.so.6

Thread 5 (Thread 0xa5d3ab40 (LWP 1678)):
#0  0xb77da424 in __kernel_vsyscall ()
#1  0xb6c58a4c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xa89cabaf in ?? () from /usr/lib/browser-plugins/libflashplayer.so
#3  0xa8591575 in ?? () from /usr/lib/browser-plugins/libflashplayer.so
#4  0xa89cae6c in ?? () from /usr/lib/browser-plugins/libflashplayer.so
#5  0xa89cb516 in ?? () from /usr/lib/browser-plugins/libflashplayer.so
#6  0xb6c54e32 in start_thread () from /lib/libpthread.so.0
#7  0xb5fc37ee in clone () from /lib/libc.so.6

Thread 4 (Thread 0xa42e4b40 (LWP 1835)):
#0  0xb5a63e3d in clock_gettime () from /lib/librt.so.1
#1  0xb6d36945 in do_gettime (frac=0xa42e3f80, sec=0xa42e3f78) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb6e1d12e in QTimerInfoList::updateCurrentTime (this=0xad208db4) at kernel/qeventdispatcher_unix.cpp:354
#4  0xad2056b8 in ?? ()
#5  0x00000000 in ?? ()

Thread 3 (Thread 0xa0bc0b40 (LWP 1862)):
#0  0xb77da424 in __kernel_vsyscall ()
#1  0xb6c58e04 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xa89cab86 in ?? () from /usr/lib/browser-plugins/libflashplayer.so
#3  0xa890f613 in ?? () from /usr/lib/browser-plugins/libflashplayer.so
#4  0xa89cae6c in ?? () from /usr/lib/browser-plugins/libflashplayer.so
#5  0xa89cb516 in ?? () from /usr/lib/browser-plugins/libflashplayer.so
#6  0xb6c54e32 in start_thread () from /lib/libpthread.so.0
#7  0xb5fc37ee in clone () from /lib/libc.so.6

Thread 2 (Thread 0x9f59ab40 (LWP 1866)):
#0  0xb77da424 in __kernel_vsyscall ()
#1  0xb6c58e04 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xa89cab86 in ?? () from /usr/lib/browser-plugins/libflashplayer.so
#3  0xa890f613 in ?? () from /usr/lib/browser-plugins/libflashplayer.so
#4  0xa89cae6c in ?? () from /usr/lib/browser-plugins/libflashplayer.so
#5  0xa89cb516 in ?? () from /usr/lib/browser-plugins/libflashplayer.so
#6  0xb6c54e32 in start_thread () from /lib/libpthread.so.0
#7  0xb5fc37ee in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb54f3740 (LWP 1596)):
[KCrash Handler]
#7  data (this=0x610062) at /usr/include/QtCore/qsharedpointer_impl.h:587
#8  Application::eventFilter (this=0xbfd9b078, watched=0x814db70, event=0xbfd9a94c) at /usr/src/debug/rekonq-2.1/src/application.cpp:465
#9  0xb6dea7ce in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x8140e40, receiver=0x814db70, event=0xbfd9a94c) at kernel/qcoreapplication.cpp:1056
#10 0xb62b8b6d in QApplicationPrivate::notify_helper (this=0x8140e40, receiver=0x814db70, e=0xbfd9a94c) at kernel/qapplication.cpp:4558
#11 0xb62bd644 in QApplication::notify (this=0x8140e40, receiver=0x814db70, e=0xbfd9a94c) at kernel/qapplication.cpp:4423
#12 0xb755cb61 in KApplication::notify (this=0xbfd9b078, receiver=0x814db70, event=0xbfd9a94c) at /usr/src/debug/kdelibs-4.10.0/kdeui/kernel/kapplication.cpp:311
#13 0xb6dea65e in QCoreApplication::notifyInternal (this=0xbfd9b078, receiver=0x814db70, event=0xbfd9a94c) at kernel/qcoreapplication.cpp:946
#14 0xb62bd0ac in sendSpontaneousEvent (event=<optimized out>, receiver=<optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:234
#15 QApplication::setActiveWindow (act=0x814e748) at kernel/qapplication.cpp:2641
#16 0xb6340db8 in QApplication::x11ProcessEvent (this=0xbfd9b078, event=0xbfd9acac) at kernel/qapplication_x11.cpp:3569
#17 0xb636a8a4 in x11EventSourceDispatch (s=0x8141d20, callback=0x0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#18 0xb59ad7d3 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#19 0xb59adb70 in ?? () from /usr/lib/libglib-2.0.so.0
#20 0xb59adc51 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#21 0xb6e1c631 in QEventDispatcherGlib::processEvents (this=0x811a450, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#22 0xb636a48a in QGuiEventDispatcherGlib::processEvents (this=0x811a450, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#23 0xb6de912c in QEventLoop::processEvents (this=this@entry=0xbfd9afa8, flags=...) at kernel/qeventloop.cpp:149
#24 0xb6de9421 in QEventLoop::exec (this=0xbfd9afa8, flags=...) at kernel/qeventloop.cpp:204
#25 0xb6dee6da in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#26 0xb62b6a14 in QApplication::exec () at kernel/qapplication.cpp:3823
#27 0xb18e5105 in kdemain (argc=1, argv=0x80eae50) at /usr/src/debug/rekonq-2.1/src/main.cpp:235
#28 0x0804fb6a in _start ()

Possible duplicates by query: bug 314015, bug 313898, bug 312990.

Reported using DrKonqi
Comment 1 Andrea Diamantini 2013-02-12 15:23:58 UTC

*** This bug has been marked as a duplicate of bug 312990 ***