Bug 314460

Summary: Copy/Move to collection picks up wrong destination path and fails silently
Product: amarok Reporter: Thierry Göckel <thierry>
Component: Collections/Organize Files DialogAssignee: Amarok Developers <amarok-bugs-dist>
Status: RESOLVED FIXED    
Severity: major CC: ralf-engels
Priority: NOR    
Version: 2.7-git   
Target Milestone: 2.8   
Platform: Debian unstable   
OS: Linux   
Latest Commit: Version Fixed In: 2.8

Description Thierry Göckel 2013-02-05 15:25:48 UTC
From IRC:
the copy to collection thing seems broken.. it doesn't get the right destination folder (ums), it just cuts off the first chars of the source path and has that as dest path: /mnt/music/some/file.mp3 -> /nt/music/some/file/mp3

By "silently", I mean the user not getting any indication what failed. I had to check -d console output.

Let me know if you need more info.
Cheers!

Reproducible: Always

Steps to Reproduce:
1. Choose some albums from collection
2. Choose 'copy to collection' from context menu
3.
Actual Results:  
Nothing.

Expected Results:  
Transcode or just copy dialog.
Comment 1 Ralf Engels 2013-02-12 11:33:10 UTC
Git commit acecf407c89dcfd118976b42254efe5e1c37611a by Ralf Engels.
Committed on 11/02/2013 at 20:28.
Pushed by rengels into branch 'master'.

Fix: Copy/Move to collection picks up wrong destination path and fails silently
FIXED-IN: 2.8

M  +1    -1    src/core-impl/collections/umscollection/UmsCollection.cpp
M  +3    -0    src/core-impl/collections/umscollection/UmsCollectionLocation.cpp

http://commits.kde.org/amarok/acecf407c89dcfd118976b42254efe5e1c37611a