Bug 314015

Summary: rekonq crash when closing it when it was still in process of loading the webpage
Product: rekonq Reporter: Simon Andric <simonandric5>
Component: generalAssignee: Andrea Diamantini <adjam7>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: 2.0   
Target Milestone: 2.0   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description Simon Andric 2013-01-28 02:59:12 UTC
Application: rekonq (2.0)
KDE Platform Version: 4.9.98
Qt Version: 4.8.4
Operating System: Linux 3.8.0-2-generic i686
Distribution: Ubuntu Raring Ringtail (development branch)

-- Information about the crash:
- What I was doing when the application crashed:

rekonq crash when closing it when it was still in process of loading the webpage. it seems if you close rekonq (this time it opened by acidentally clicked in some link in rssnow widget) before internet page loads completely it will bring up dr. konqi. my system is kde newest studd, i have also project neon installed although i didnt boot into it at this time, and also i use the newest rekonq.

nice day :)


Simon

The crash can be reproduced some of the time.

-- Backtrace:
Application: Rekonq (kdeinit4), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb561e740 (LWP 20175))]

Thread 4 (Thread 0xb0582b40 (LWP 20176)):
#0  0xb7717424 in __kernel_vsyscall ()
#1  0xb5a0a975 in __pthread_cond_wait (cond=0xb3b7f470 <WTF::pageheap_memory+20720>, mutex=0xb3b7f458 <WTF::pageheap_memory+20696>) at pthread_cond_wait.c:155
#2  0xb5f6556c in __pthread_cond_wait (cond=0xb3b7f470 <WTF::pageheap_memory+20720>, mutex=0xb3b7f458 <WTF::pageheap_memory+20696>) at forward.c:149
#3  0xb34280e9 in WTF::TCMalloc_PageHeap::scavengerThread (this=this@entry=0xb3b7a380 <WTF::pageheap_memory>) at wtf/FastMalloc.cpp:2499
#4  0xb34281df in WTF::TCMalloc_PageHeap::runScavengerThread (context=0xb3b7a380 <WTF::pageheap_memory>) at wtf/FastMalloc.cpp:1622
#5  0xb5a06d78 in start_thread (arg=0xb0582b40) at pthread_create.c:311
#6  0xb5f57bbe in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:132

Thread 3 (Thread 0xafc61b40 (LWP 20177)):
#0  0xb7717424 in __kernel_vsyscall ()
#1  0xb5f496bb in poll () at ../sysdeps/unix/syscall-template.S:81
#2  0xb594713b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb59385f0 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb5938751 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb6d7cc3f in QEventDispatcherGlib::processEvents (this=0xaf300468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0xb6d492cc in QEventLoop::processEvents (this=this@entry=0xafc61258, flags=...) at kernel/qeventloop.cpp:149
#7  0xb6d495c1 in QEventLoop::exec (this=0xafc61258, flags=...) at kernel/qeventloop.cpp:204
#8  0xb6c3470c in QThread::exec (this=this@entry=0x9b99d00) at thread/qthread.cpp:542
#9  0xb6c3486b in QThread::run (this=0x9b99d00) at thread/qthread.cpp:609
#10 0xb6c37af8 in QThreadPrivate::start (arg=0x9b99d00) at thread/qthread_unix.cpp:338
#11 0xb5a06d78 in start_thread (arg=0xafc61b40) at pthread_create.c:311
#12 0xb5f57bbe in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:132

Thread 2 (Thread 0xae9e3b40 (LWP 20179)):
#0  0xb59356f0 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb5937bcd in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb59384ef in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb5938751 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb6d7cc3f in QEventDispatcherGlib::processEvents (this=0xae000468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0xb6d492cc in QEventLoop::processEvents (this=this@entry=0xae9e3228, flags=...) at kernel/qeventloop.cpp:149
#6  0xb6d495c1 in QEventLoop::exec (this=0xae9e3228, flags=...) at kernel/qeventloop.cpp:204
#7  0xb6c3470c in QThread::exec (this=0xcfa1078) at thread/qthread.cpp:542
#8  0xb6d278cd in QInotifyFileSystemWatcherEngine::run (this=0xcfa1078) at io/qfilesystemwatcher_inotify.cpp:256
#9  0xb6c37af8 in QThreadPrivate::start (arg=0xcfa1078) at thread/qthread_unix.cpp:338
#10 0xb5a06d78 in start_thread (arg=0xae9e3b40) at pthread_create.c:311
#11 0xb5f57bbe in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:132

Thread 1 (Thread 0xb561e740 (LWP 20175)):
[KCrash Handler]
#7  data (this=0x610062) at /usr/include/qt4/QtCore/qsharedpointer_impl.h:587
#8  Application::eventFilter (this=0xbfd767a8, watched=0x9b67eb0, event=0xbfd7607c) at /build/buildd/rekonq-2.0/src/application.cpp:471
#9  0xb6d4a95e in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x9a396e8, receiver=0x9b67eb0, event=0xbfd7607c) at kernel/qcoreapplication.cpp:1056
#10 0xb623a43d in QApplicationPrivate::notify_helper (this=0x9a396e8, receiver=0x9b67eb0, e=0xbfd7607c) at kernel/qapplication.cpp:4563
#11 0xb623ef05 in QApplication::notify (this=0x9a396e8, receiver=0x9b67eb0, e=0xbfd7607c) at kernel/qapplication.cpp:4428
#12 0xb74995b1 in KApplication::notify (this=0xbfd767a8, receiver=0x9b67eb0, event=0xbfd7607c) at ../../kdeui/kernel/kapplication.cpp:311
#13 0xb6d4a7ee in QCoreApplication::notifyInternal (this=0xbfd767a8, receiver=0x9b67eb0, event=0xbfd7607c) at kernel/qcoreapplication.cpp:946
#14 0xb623e98c in sendSpontaneousEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:234
#15 QApplication::setActiveWindow (act=0x9b736e0) at kernel/qapplication.cpp:2646
#16 0xb62c6561 in QApplication::x11ProcessEvent (this=0xbfd767a8, event=0xbfd763dc) at kernel/qapplication_x11.cpp:3725
#17 0xb62f0f54 in x11EventSourceDispatch (s=0x99d7300, callback=0x0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#18 0xb59382d3 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#19 0xb5938670 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#20 0xb5938751 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#21 0xb6d7cc21 in QEventDispatcherGlib::processEvents (this=0x9a31c98, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#22 0xb62f0b3a in QGuiEventDispatcherGlib::processEvents (this=0x9a31c98, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#23 0xb6d492cc in QEventLoop::processEvents (this=this@entry=0xbfd766d8, flags=...) at kernel/qeventloop.cpp:149
#24 0xb6d495c1 in QEventLoop::exec (this=0xbfd766d8, flags=...) at kernel/qeventloop.cpp:204
#25 0xb6d4ed1a in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#26 0xb6238094 in QApplication::exec () at kernel/qapplication.cpp:3828
#27 0xb3c80008 in kdemain (argc=2, argv=0x9a165f0) at /build/buildd/rekonq-2.0/src/main.cpp:232
#28 0x0804f6df in launch (argc=argc@entry=2, _name=_name@entry=0x9a15494 "rekonq", args=<optimized out>, args@entry=0x9a1549b "http://24ur.com/ekskluziv/domaca-scena/helena-blagne-nastopila-na-gejevski-zabavi.html", cwd=cwd@entry=0x0, envc=envc@entry=1, envs=<optimized out>, envs@entry=0x9a154f6 "DISPLAY=:0", reset_env=false, tty=tty@entry=0x0, avoid_loops=false, startup_id_str=startup_id_str@entry=0x80520ea "0") at ../../kinit/kinit.cpp:738
#29 0x080507bc in handle_launcher_request (sock=sock@entry=7, who=<optimized out>) at ../../kinit/kinit.cpp:1230
#30 0x08050e1f in handle_requests (waitForPid=waitForPid@entry=0) at ../../kinit/kinit.cpp:1423
#31 0x0804c230 in main (argc=2, argv=0xbfd77154, envp=0xbfd77160) at ../../kinit/kinit.cpp:1911

This bug may be a duplicate of or related to bug 313898, bug 312990.

Possible duplicates by query: bug 313898, bug 312990.

Reported using DrKonqi
Comment 1 Andrea Diamantini 2013-02-12 15:16:54 UTC

*** This bug has been marked as a duplicate of bug 312990 ***