Bug 313898

Summary: reKonq crashed when I closed it while I was viewing a PDF on Internet
Product: rekonq Reporter: Joan <joanjerezt>
Component: generalAssignee: Andrea Diamantini <adjam7>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: 2.0   
Target Milestone: 2.0   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description Joan 2013-01-25 19:21:45 UTC
Application: rekonq (2.0)
KDE Platform Version: 4.9.5
Qt Version: 4.8.2
Operating System: Linux 3.2.0-36-generic i686
Distribution: Ubuntu 12.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed:
I was reading PDF document, scrolling it to seach information, etc.
When I finished, I closed it, and reKonq crashed.
- Custom settings of the application:
It happened on URL: http://www.fehr.es/documentos/publicaciones/descargas/des-70.pdf

The crash does not seem to be reproducible.

-- Backtrace:
Application: rekonq (rekonq), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb772b740 (LWP 3369))]

Thread 7 (Thread 0xb54d3b40 (LWP 3371)):
#0  0x00707416 in __kernel_vsyscall ()
#1  0x09f7896b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x0020c64c in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0x0201f263 in WTF::TCMalloc_PageHeap::scavengerThread (this=0x274b940) at wtf/FastMalloc.cpp:2495
#4  0x0201f37f in WTF::TCMalloc_PageHeap::runScavengerThread (context=0x274b940) at wtf/FastMalloc.cpp:1618
#5  0x09f74d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#6  0x001fed3e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 6 (Thread 0xb4baab40 (LWP 3372)):
#0  0x00707416 in __kernel_vsyscall ()
#1  0x001ee3eb in read () from /lib/i386-linux-gnu/libc.so.6
#2  0x0860a6ae in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x085cbbd2 in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x085cc042 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x085cc201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0x07875db7 in QEventDispatcherGlib::processEvents (this=0xb4200468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#7  0x0784167d in QEventLoop::processEvents (this=0xb4baa270, flags=...) at kernel/qeventloop.cpp:149
#8  0x07841919 in QEventLoop::exec (this=0xb4baa270, flags=...) at kernel/qeventloop.cpp:204
#9  0x0772a9ec in QThread::exec (this=0xa0f9ea0) at thread/qthread.cpp:501
#10 0x0772aadb in QThread::run (this=0xa0f9ea0) at thread/qthread.cpp:568
#11 0x0772de80 in QThreadPrivate::start (arg=0xa0f9ea0) at thread/qthread_unix.cpp:307
#12 0x09f74d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#13 0x001fed3e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 5 (Thread 0xb3e1cb40 (LWP 3375)):
#0  0x00707416 in __kernel_vsyscall ()
#1  0x001ee3eb in read () from /lib/i386-linux-gnu/libc.so.6
#2  0x0860a6ae in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x085cbbd2 in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x085cc042 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x085cc201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0x07875db7 in QEventDispatcherGlib::processEvents (this=0xb4000468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#7  0x0784167d in QEventLoop::processEvents (this=0xb3e1c240, flags=...) at kernel/qeventloop.cpp:149
#8  0x07841919 in QEventLoop::exec (this=0xb3e1c240, flags=...) at kernel/qeventloop.cpp:204
#9  0x0772a9ec in QThread::exec (this=0xa159fb8) at thread/qthread.cpp:501
#10 0x0781eccd in QInotifyFileSystemWatcherEngine::run (this=0xa159fb8) at io/qfilesystemwatcher_inotify.cpp:248
#11 0x0772de80 in QThreadPrivate::start (arg=0xa159fb8) at thread/qthread_unix.cpp:307
#12 0x09f74d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#13 0x001fed3e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 4 (Thread 0xb3168b40 (LWP 3379)):
#0  0x00707416 in __kernel_vsyscall ()
#1  0x09f7896b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x0020c64c in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0x0505974d in queue_processor(void*) () from /usr/lib/jvm/java-6-openjdk-i386/jre/lib/i386/IcedTeaPlugin.so
#4  0x09f74d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#5  0x001fed3e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 3 (Thread 0xb2967b40 (LWP 3380)):
#0  0x00707416 in __kernel_vsyscall ()
#1  0x09f7896b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x0020c64c in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0x0505974d in queue_processor(void*) () from /usr/lib/jvm/java-6-openjdk-i386/jre/lib/i386/IcedTeaPlugin.so
#4  0x09f74d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#5  0x001fed3e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xb2166b40 (LWP 3381)):
#0  0x00707416 in __kernel_vsyscall ()
#1  0x09f7896b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x0020c64c in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0x0505974d in queue_processor(void*) () from /usr/lib/jvm/java-6-openjdk-i386/jre/lib/i386/IcedTeaPlugin.so
#4  0x09f74d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#5  0x001fed3e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb772b740 (LWP 3369)):
[KCrash Handler]
#7  operator== (value=0, this=0x89000008) at /usr/include/qt4/QtCore/qbasicatomic.h:70
#8  data (this=0x610062) at /usr/include/qt4/QtCore/qsharedpointer_impl.h:587
#9  Application::eventFilter (this=0xbfd63f78, watched=0xa0a6398, event=0xbfd63868) at /build/buildd/rekonq-2.0/src/application.cpp:471
#10 0x07842f76 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x9fc5520, receiver=0xa0a6398, event=0xbfd63868) at kernel/qcoreapplication.cpp:1025
#11 0x0297bdc2 in notify_helper (e=0xbfd63868, receiver=0xa0a6398, this=0x9fc5520) at kernel/qapplication.cpp:4552
#12 QApplicationPrivate::notify_helper (this=0x9fc5520, receiver=0xa0a6398, e=0xbfd63868) at kernel/qapplication.cpp:4528
#13 0x029811f2 in QApplication::notify (this=0x9fc5520, receiver=0xa0a6398, e=0xbfd63868) at kernel/qapplication.cpp:4521
#14 0x004a7591 in KApplication::notify (this=0xbfd63f78, receiver=0xa0a6398, event=0xbfd63868) at ../../kdeui/kernel/kapplication.cpp:311
#15 0x07842dde in QCoreApplication::notifyInternal (this=0xbfd63f78, receiver=0xa0a6398, event=0xbfd63868) at kernel/qcoreapplication.cpp:915
#16 0x0297fbac in sendSpontaneousEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:234
#17 QApplication::setActiveWindow (act=0x89000000) at kernel/qapplication.cpp:2635
#18 0x02a08a1d in QApplication::x11ProcessEvent (this=0xbfd63f78, event=0xbfd63bdc) at kernel/qapplication_x11.cpp:3711
#19 0x02a34e1c in x11EventSourceDispatch (s=0x9fc2640, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#20 0x085cbd86 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#21 0x085cc125 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#22 0x085cc201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#23 0x07875d57 in QEventDispatcherGlib::processEvents (this=0x9f99728, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#24 0x02a34a1a in QGuiEventDispatcherGlib::processEvents (this=0x9f99728, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#25 0x0784167d in QEventLoop::processEvents (this=0xbfd63ed4, flags=...) at kernel/qeventloop.cpp:149
#26 0x07841919 in QEventLoop::exec (this=0xbfd63ed4, flags=...) at kernel/qeventloop.cpp:204
#27 0x0784731a in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#28 0x029799c4 in QApplication::exec () at kernel/qapplication.cpp:3817
#29 0x008669e6 in kdemain (argc=2, argv=0xbfd64274) at /build/buildd/rekonq-2.0/src/main.cpp:232
#30 0x080484fb in main (argc=2, argv=0xbfd64274) at /build/buildd/rekonq-2.0/obj-i686-linux-gnu/src/rekonq_dummy.cpp:3

Reported using DrKonqi
Comment 1 Andrea Diamantini 2013-02-12 15:16:22 UTC

*** This bug has been marked as a duplicate of bug 312990 ***