Bug 313842

Summary: Dolphin does not seem to handle file name with the German character "Ö"
Product: [Applications] dolphin Reporter: monts <montosh.bisht>
Component: panels: foldersAssignee: Dolphin Bug Assignee <dolphin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: normal CC: rdieter
Priority: NOR    
Version: 16.12.2   
Target Milestone: ---   
Platform: Fedora RPMs   
OS: Linux   
Latest Commit: Version Fixed In:
Sentry Crash Report:

Description monts 2013-01-24 18:45:48 UTC
Well looking at another wearied bug .... some time back I downloaded awesome remix and mash-up from http://djschmolli.com/albums/

I am unable to move/delete some of the files .. I am sure this has something to do with the extended character used to name the files/tracks ... the file system is ext4 and my local is set to American English

Here is the list I can't move/delete these files now

vol 4 - track 10
vol 4 - track 14
vol 6 - track 1
vol 8 - track 5
vol 9 - track 1
vol 10 - track 5
Schnipseljagd Vol.10/Artwork/ 05Black Eyed <=== jpeg

When I try to rename the file under Dolphin. I get an error that the file does not exist ... when I right click on one of these files > Proprieties ... Dolphin crashed ... I canceled the bug reporter .. next time Dolphin does not crash but can't delete or move the files.

As a work around I found that the files can be rename under konsole using mv ...

Reproducible: Always

Steps to Reproduce:
1. Download the awesome remixes by djschmolli from http://djschmolli.com/albums/ e.g select volume number 4  ... normally download the zip file.
2. unzip the file using ark 
3. try renaming track no. 10 or 14 .. you will get an error.
4. if you delete the file they are moved to the Trash.. but you cannot empty the Trash bin.   
Actual Results:  
When you try to rename the file .. you get the error the file does not exist. 

Expected Results:  
Dolphin should have allowed the normally rename the file. When does (as can be done by the command line) the file can be moved, copied and deleted 

cross checked the offending character is the German "Ö" ...
Comment 1 Frank Reininghaus 2013-01-24 21:32:36 UTC
Thanks for the detailed bug report!

First of all, let me point out that this is not a Dolphin bug, but rather just a symptom of Qt's/KDE's general inability to open files whose name's encoding is broken. This issue has been reported a couple of years ago: bug 165044. Better don't read the report though, it's full of angry comments, and the bottom line seems to be that the bug is actually in unzip and other tools that create the file names with broken encoding in the first place. People just think that it's KDE fault because there are other applications/file managers which work around the issue (and that might be the reason why the unzip people never fixed it). The best summary is this comment of the original reporter:

https://bugs.kde.org/show_bug.cgi?id=165044#c122

*** This bug has been marked as a duplicate of bug 165044 ***