Bug 312176

Summary: Drop explosion effect
Product: [Plasma] kwin Reporter: Thomas Lübking <thomas.luebking>
Component: effects-variousAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED FIXED    
Severity: normal CC: henryrust89, KaiUweBroulik2, kamikazow, luca76, ry
Priority: NOR Flags: thomas.luebking: Decision-Required+
Version: git master   
Target Milestone: 4.11   
Platform: Compiled Sources   
OS: Linux   
Latest Commit: Version Fixed In: 4.11
Sentry Crash Report:

Description Thomas Lübking 2012-12-24 21:29:01 UTC
No developer cares, no one showed up to fix it, it's claimed to be unusable and buggy (see dupes) in its current state.

Reproducible: Always
Comment 1 Thomas Lübking 2012-12-24 21:29:47 UTC
*** Bug 267954 has been marked as a duplicate of this bug. ***
Comment 2 Thomas Lübking 2012-12-24 21:29:54 UTC
*** Bug 306376 has been marked as a duplicate of this bug. ***
Comment 3 Martin Flöser 2012-12-25 08:31:46 UTC
I'll write a blog to ask whether someone wants to step up to fix it. If nothing 
happens (that's what I would expect), it'll be gone in a month or so.

If we would add shader support to AnimationEffect it would be possible to 
easily reimplement it modulo the broken shader
Comment 4 markuss 2012-12-26 00:31:08 UTC

*** This bug has been marked as a duplicate of bug 267954 ***
Comment 5 Thomas Lübking 2012-12-26 07:23:07 UTC
*** Bug 267954 has been marked as a duplicate of this bug. ***
Comment 6 Luca Manganelli 2012-12-28 08:52:28 UTC
For me, you can remove it. Newer used it because I'm uncomfortable with it.
Comment 7 Henry Rust 2013-01-19 14:55:53 UTC
I saw Martin's blog post and decided to work on this. Because I'm new to KWin and KDE development in general, I may need some time to get into it, but I'm definitely working on this issue.
Comment 8 Martin Flöser 2013-01-30 07:58:57 UTC
Let's give it a last chance till 4.11 :-)
Comment 9 Martin Flöser 2013-05-19 07:55:12 UTC
Git commit 3395c6170b0ee0f806a5658c5e029c4fa64cc613 by Martin Gräßlin.
Committed on 18/05/2013 at 20:35.
Pushed by graesslin into branch 'master'.

Drop explosion effect

It has been unmaintained and mostly broken for years.
FIXED-IN: 4.11
REVIEW: 110513

M  +0    -1    kwin/effects/CMakeLists.txt
D  +0    -19   kwin/effects/explosion/CMakeLists.txt
D  +-    --    kwin/effects/explosion/data/explosion-end.png
D  +-    --    kwin/effects/explosion/data/explosion-start.png
D  +0    -53   kwin/effects/explosion/data/explosion.frag
D  +0    -213  kwin/effects/explosion/explosion.cpp
D  +0    -167  kwin/effects/explosion/explosion.desktop
D  +0    -73   kwin/effects/explosion/explosion.h

http://commits.kde.org/kde-workspace/3395c6170b0ee0f806a5658c5e029c4fa64cc613