Bug 309889

Summary: a lot of kde applications crash at startup
Product: kwin Reporter: Andrew <travneff>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED UPSTREAM    
Severity: crash CC: cfeck, rdieter
Priority: NOR    
Version: 4.9.2   
Target Milestone: ---   
Platform: Fedora RPMs   
OS: Linux   
Latest Commit: Version Fixed In:

Description Andrew 2012-11-11 08:52:29 UTC
Application: kwin (4.9.2)
KDE Platform Version: 4.9.2
Qt Version: 4.8.3
Operating System: Linux 3.6.6-1.fc17.x86_64 x86_64
Distribution: "RFRemix release 17 (Beefy Miracle)"

-- Information about the crash:
Applications segfault just after X start. List of them includes kate, kopete, kwin, plasma-desktop and crash reporter (not always reproducible, fortuntely). It's almost impossible to use KDE.
Reproducible also at clean user account.

Note: I'm using startx from runlevel 3, not sure if matters.

SW versions:
qt-4.8.3-7.fc17.x86_64
kde-workspace-4.9.2-6.fc17.x86_64
kernel-3.6.6-1.fc17.x86_64

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7fafd9352880 (LWP 2954))]

Thread 2 (Thread 0x7fafccd03700 (LWP 2976)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:166
#1  0x0000003c9a186797 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x3c9a494640) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x0000003c9a1867c9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x0000003f31807d14 in start_thread (arg=0x7fafccd03700) at pthread_create.c:309
#4  0x0000003f314f167d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7fafd9352880 (LWP 2954)):
[KCrash Handler]
#5  0x0000003c9a0a30ae in FixedVMPoolAllocator (totalHeapSize=2147483648, commonSize=<optimized out>, this=0x1995310) at ../3rdparty/javascriptcore/JavaScriptCore/jit/ExecutableAllocatorFixedVMPool.cpp:310
#6  QTJSC::ExecutablePool::systemAlloc (size=16384) at ../3rdparty/javascriptcore/JavaScriptCore/jit/ExecutableAllocatorFixedVMPool.cpp:443
#7  0x0000003c9a127d89 in ExecutablePool (n=<optimized out>, this=0x7fafcc40a960) at ../3rdparty/javascriptcore/JavaScriptCore/jit/ExecutableAllocator.h:258
#8  create (n=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/jit/ExecutableAllocator.h:97
#9  ExecutableAllocator (this=0x7fafcc4049c8) at ../3rdparty/javascriptcore/JavaScriptCore/jit/ExecutableAllocator.h:150
#10 QTJSC::JSGlobalData::JSGlobalData (this=0x7fafcc403800, isShared=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/runtime/JSGlobalData.cpp:146
#11 0x0000003c9a12854c in QTJSC::JSGlobalData::create () at ../3rdparty/javascriptcore/JavaScriptCore/runtime/JSGlobalData.cpp:205
#12 0x0000003c9a1c8d00 in QScriptEnginePrivate::QScriptEnginePrivate (this=0x1977f90) at api/qscriptengine.cpp:979
#13 0x0000003c9a1c9cf6 in QScriptEngine::QScriptEngine (this=0x1b52658) at api/qscriptengine.cpp:1964
#14 0x0000003c9f7b281c in QDeclarativeScriptEngine::QDeclarativeScriptEngine (this=0x1b52658, priv=0x1b52550) at qml/qdeclarativeengine.cpp:388
#15 0x0000003c9f7b74ff in QDeclarativeEnginePrivate::QDeclarativeEnginePrivate (this=0x1b52550, e=0x196b970) at qml/qdeclarativeengine.cpp:355
#16 0x0000003c9f7b7801 in QDeclarativeEngine::QDeclarativeEngine (this=0x196b970, parent=0x0) at qml/qdeclarativeengine.cpp:645
#17 0x0000003c9f6b6ba6 in QDeclarativeViewPrivate::init (this=this@entry=0x1b40060) at util/qdeclarativeview.cpp:281
#18 0x0000003c9f6b6dd3 in QDeclarativeView::QDeclarativeView (this=0x1888ab0, parent=0x0) at util/qdeclarativeview.cpp:261
#19 0x00007fafdd5af802 in KWin::DeclarativeScript::DeclarativeScript (this=0x1994b90, id=<optimized out>, scriptName=..., pluginName=..., parent=<optimized out>) at /usr/src/debug/kde-workspace-4.9.2/kwin/scripting/scripting.cpp:421
#20 0x00007fafdd5b1a99 in KWin::Scripting::loadDeclarativeScript (this=this@entry=0x1b1b330, filePath=..., pluginName=...) at /usr/src/debug/kde-workspace-4.9.2/kwin/scripting/scripting.cpp:612
#21 0x00007fafdd5b2ddb in KWin::Scripting::start (this=0x1b1b330) at /usr/src/debug/kde-workspace-4.9.2/kwin/scripting/scripting.cpp:487
#22 0x00007fafdd5b2f25 in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at /usr/src/debug/kde-workspace-4.9.2/x86_64-redhat-linux-gnu/kwin/scripting.moc:339
#23 KWin::Scripting::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=0x7fffd7a6ae40) at /usr/src/debug/kde-workspace-4.9.2/x86_64-redhat-linux-gnu/kwin/scripting.moc:332
#24 0x0000003c9198e71f in QMetaObject::activate (sender=0x1927170, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#25 0x00007fafdd51ab0b in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at /usr/src/debug/kde-workspace-4.9.2/x86_64-redhat-linux-gnu/kwin/workspace.moc:275
#26 KWin::Workspace::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /usr/src/debug/kde-workspace-4.9.2/x86_64-redhat-linux-gnu/kwin/workspace.moc:268
#27 0x0000003c9198c86e in QObject::event (this=0x1927170, e=<optimized out>) at kernel/qobject.cpp:1195
#28 0x0000003c92bca4ac in QApplicationPrivate::notify_helper (this=this@entry=0x175e780, receiver=receiver@entry=0x1927170, e=e@entry=0x1b1d740) at kernel/qapplication.cpp:4557
#29 0x0000003c92bce92a in QApplication::notify (this=0x7fffd7a6bba0, receiver=0x1927170, e=0x1b1d740) at kernel/qapplication.cpp:4418
#30 0x00007fafdc0fa8a6 in KApplication::notify(QObject*, QEvent*) () from /lib64/libkdeui.so.5
#31 0x0000003c91977f6e in QCoreApplication::notifyInternal (this=0x7fffd7a6bba0, receiver=receiver@entry=0x1927170, event=event@entry=0x1b1d740) at kernel/qcoreapplication.cpp:915
#32 0x0000003c9197ba21 in sendEvent (event=0x1b1d740, receiver=0x1927170) at kernel/qcoreapplication.h:231
#33 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x16f4360) at kernel/qcoreapplication.cpp:1539
#34 0x0000003c92c6b10c in sendPostedEvents () at ../../src/corelib/kernel/qcoreapplication.h:236
#35 QEventDispatcherX11::processEvents (this=0x175e400, flags=...) at kernel/qeventdispatcher_x11.cpp:75
#36 0x0000003c91976cbf in QEventLoop::processEvents (this=this@entry=0x7fffd7a6b8b0, flags=...) at kernel/qeventloop.cpp:149
#37 0x0000003c91976f48 in QEventLoop::exec (this=0x7fffd7a6b8b0, flags=...) at kernel/qeventloop.cpp:204
#38 0x0000003c9197bd38 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#39 0x00007fafdd53ad14 in kdemain (argc=3, argv=0x7fffd7a6bce8) at /usr/src/debug/kde-workspace-4.9.2/kwin/main.cpp:545
#40 0x0000003f31421735 in __libc_start_main (main=0x4008a0 <main(int, char**)>, argc=3, ubp_av=0x7fffd7a6bce8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffd7a6bcd8) at libc-start.c:226
#41 0x00000000004008d1 in _start ()

Reported using DrKonqi
Comment 1 Martin Flöser 2012-11-11 08:59:47 UTC
that looks like you have a problem with your setup. If all the backtraces from the various applications look similar it seems to be that your Qt installation has a problem and no application which uses QtScript works correctly.

I highly recommend to consult the support channels by your distribution as there is hardly anything which we can do about it. It's crashing in an upstream component of KDE software.
Comment 2 Andrew 2012-11-11 10:01:13 UTC
I didn't compare backtraces, but the problem seems really common.
However there are no such crashes in Qt applications when launched under LXDE environment.

OK, I'll try to dig more, but tell please if there are any places which might be checked at first.
Comment 3 Christoph Feck 2012-11-11 12:15:40 UTC
Andrew, please try Qt 4.8.2 or Qt 4.8.4, this might be related to 305718.
Comment 4 Andrew 2012-11-11 12:41:42 UTC
(In reply to comment #3)

Christoph, thanks, you saved the world (:  Qt 4.8.4 isn't still packaged for Fedora, but 4.8.2 from koji fixed it.
Thank you one more time.
Comment 5 Rex Dieter 2012-11-11 13:31:40 UTC
fyi, the qt build Andrew used includes the QtScript patch from qt-4.8.4
Comment 6 Andrew 2012-11-17 19:57:54 UTC
Some new details here: https://bugzilla.redhat.com/show_bug.cgi?id=853587

In short, crashes present with vm.overcommit_memory = 2 and absent with value 0 or 1. There is a lot of free RAM at this time (1-2GB). Some other (non-Qt) applications seem affected too.