Bug 309477

Summary: weird looking tooltips in gtk apps with activated composition
Product: Oxygen Reporter: Jan Killius <jkillius>
Component: gtk2-engineAssignee: Hugo Pereira Da Costa <hugo.pereira.da.costa>
Status: RESOLVED NOT A BUG    
Severity: normal CC: b7.10110111, hugo.pereira.da.costa, kwin-bugs-null, loop.rw, web
Priority: NOR    
Version: 4.9   
Target Milestone: ---   
Platform: Gentoo Packages   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: tooltip
glitch as appears on menu in gimp
glitches in gimp with oxygen-gtk

Description Jan Killius 2012-11-03 14:01:12 UTC
If composition is enabled tooltips looking strange in chromium/chrome and firefox. I get the actual tooltip and around some kind of buffer artifacts.
If I disable composition everything renders fine.
In KDE 4.9.x it's looking fine with activated composition.

Reproducible: Always

Steps to Reproduce:
1. enable composition
2. trigger a tooltip
Actual Results:  
weird looking tooltip.

Expected Results:  
normal tooltip.

I'm using the proprietary Nvidia drivers version 310.14 and Xorg server 1.13.0
QT version is 4.8.3
Comment 1 Martin Flöser 2012-11-03 14:08:58 UTC
screenshot please
Comment 2 Jan Killius 2012-11-03 14:21:51 UTC
Created attachment 74963 [details]
tooltip
Comment 3 Martin Flöser 2012-11-03 14:33:47 UTC
I assume you use oxygen-gtk?

Could you please provide the output of qdbus org.kde.kwin /KWin supportInformation
Comment 4 Thomas Lübking 2012-11-03 15:24:21 UTC
might be related to bug #309171 and friends?

Are the shadows also garbled for gtk+ popup menus and/or Qt application popups/tooltiups?

If you run "kwin --replace &" from konsole, do you get X11 errors on showing the broken popup/tooltip?

If you happen to have a "recent" version of bespin (style or window decoration) installed: what do the shadows on Qt applications look like for it?
Comment 5 Jan Killius 2012-11-03 15:34:26 UTC
I'm not using oxygen-gtk... At the moment I'm using qtcurve If I switch to oxygen-gtk everything is normal and the tooltips are shown correctly.

Here are my kwin debug information:
http://paste.kde.org/589316/
Comment 6 Thomas Lübking 2012-11-03 15:42:45 UTC
Likely not a kwin bug, the provided pixmaps are probably junk.
-> Assigning to Craig, leaving at kwin (there's no QtCurve component)

@Craig
there seems to be aan issue with shadow pixmaps at least for Gtk+, please have a look at the attached image.

@Jan
- does it also happen with the xrender compositing backend?
- what about QtCurve on Qt applications (kwrite etc.)
Comment 7 Jan Killius 2012-11-03 16:24:25 UTC
yes it's also happening with the xrender backend.
No Qt applications are fine.
Comment 8 loop.rw 2012-11-28 22:51:50 UTC
Same issue here, since kde 4.9 all gtk applications trigger tooltip and menu glitches when compositing is active, with both opengl and xrender, qtcurve or not.
Qt applications are not affected.
Video card is integrated sandy bridge (on mobile) and ivy-bridge (on desk) and same bug applies to both.

Attaching gimp menu glitch screenshot
Comment 9 loop.rw 2012-11-28 22:52:36 UTC
Created attachment 75524 [details]
glitch as appears on menu in gimp
Comment 10 Thomas Lübking 2012-11-28 23:02:18 UTC
That screenshot is from qtcurve, isn't?
Before moving to oxygen/gtk i'd like too see that with an oxygen-gtk(3?) theme (because of comment #5)
Comment 11 loop.rw 2012-11-30 23:27:33 UTC
Created attachment 75555 [details]
glitches in gimp with oxygen-gtk

while less abundant, glitches still happenin oxygen-gtk. Without oxygen-gtk or qtcurve-gtk i'm currently unable to reproduce the bug.
Comment 12 Thomas Lübking 2012-11-30 23:48:04 UTC
Forwarding to oxygen since KWin just takes the pixmap and uses it.

@Hugo:
any chance gtk creates the pixmap in a "wrong" format (8bit etc)?
Comment 13 Ruslan Kabatsayev 2012-11-30 23:59:41 UTC
> any chance gtk creates the pixmap in a "wrong" format (8bit etc)?
This doesn't look like a wrong format at least because it works for me with KWin 4.9.1, GIMP 2.6.12 and oxygen-gtk2 v1.3.0-27-gc9dcda0 and nvidia driver 304.51.
Also, this is with both oxygen-gtk and QtCurve, so shouldn't be because of theme.
Might be a driver bug...

@reporters
What if you use nouveau video driver instead of nvidia? Also, does this problem reproduce with oxygen-gtk-demo?
Comment 14 Hugo Pereira Da Costa 2013-04-22 14:32:08 UTC
Closing, since it is not an oxygen (or oxygen-gtk) specific issue, and there have been no response on last question for the last 4 month.