Bug 308019

Summary: Crash after using Batch Border images
Product: [Applications] digikam Reporter: Maarten <cmwieland>
Component: Plugin-Bqm-BorderAssignee: Digikam Developers <digikam-bugs-null>
Status: RESOLVED FIXED    
Severity: crash CC: caulier.gilles, sitter
Priority: NOR    
Version: 2.6.0   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In: 5.0.0

Description Maarten 2012-10-07 12:12:13 UTC
Application: gwenview (2.9.1)
KDE Platform Version: 4.9.2
Qt Version: 4.8.2
Operating System: Linux 3.2.0-31-generic x86_64
Distribution: Ubuntu 12.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed:
Tried to add a border to png image. Tried a second time and it didn't crash.

-- Backtrace:
Application: Gwenview (gwenview), signal: Aborted
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fc00096f780 (LWP 8944))]

Thread 3 (Thread 0x7fbfeb5ce700 (LWP 8945)):
#0  0x00007fffe70a08de in ?? ()
#1  0x00007fbff9d8815d in __GI_clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:116
#2  0x00007fbfff6dec64 in do_gettime (frac=0x7fbfeb5cdb98, sec=0x7fbfeb5cdb90) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007fbfff7b706d in QTimerInfoList::updateCurrentTime (this=0x7fbfe4002860) at kernel/qeventdispatcher_unix.cpp:343
#5  0x00007fbfff7b73a3 in QTimerInfoList::timerWait (this=0x7fbfe4002860, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#6  0x00007fbfff7b5e5c in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7fbfeb5cdc6c) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007fbfff7b5f05 in timerSourcePrepare (source=<optimized out>, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#8  0x00007fbff9ad6846 in g_main_context_prepare (context=0x7fbfe40009a0, priority=0x7fbfeb5cdcb8) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:2836
#9  0x00007fbff9ad6f5b in g_main_context_iterate (dispatch=1, block=1, context=0x7fbfe40009a0, self=<optimized out>) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3126
#10 g_main_context_iterate (context=0x7fbfe40009a0, block=1, dispatch=1, self=<optimized out>) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3083
#11 0x00007fbff9ad7164 in g_main_context_iteration (context=0x7fbfe40009a0, may_block=1) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3207
#12 0x00007fbfff7b6906 in QEventDispatcherGlib::processEvents (this=0x7fbfe40008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#13 0x00007fbfff785e42 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#14 0x00007fbfff786097 in QEventLoop::exec (this=0x7fbfeb5cddd0, flags=...) at kernel/qeventloop.cpp:204
#15 0x00007fbfff685057 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#16 0x00007fbfff765b4f in QInotifyFileSystemWatcherEngine::run (this=0x17a8ef0) at io/qfilesystemwatcher_inotify.cpp:248
#17 0x00007fbfff68807b in QThreadPrivate::start (arg=0x17a8ef0) at thread/qthread_unix.cpp:307
#18 0x00007fbffa197e9a in start_thread (arg=0x7fbfeb5ce700) at pthread_create.c:308
#19 0x00007fbffd337dbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#20 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fbfea53c700 (LWP 8946)):
#0  0x00007fffe70a08de in ?? ()
#1  0x00007fbff9d8815d in __GI_clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:116
#2  0x00007fbfff6dec64 in do_gettime (frac=0x7fbfea53bb98, sec=0x7fbfea53bb90) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007fbfff7b706d in QTimerInfoList::updateCurrentTime (this=0x7fbfdc002660) at kernel/qeventdispatcher_unix.cpp:343
#5  0x00007fbfff7b73a3 in QTimerInfoList::timerWait (this=0x7fbfdc002660, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#6  0x00007fbfff7b5e5c in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7fbfea53bc6c) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007fbfff7b5f05 in timerSourcePrepare (source=<optimized out>, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#8  0x00007fbff9ad6846 in g_main_context_prepare (context=0x7fbfdc0009a0, priority=0x7fbfea53bcb8) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:2836
#9  0x00007fbff9ad6f5b in g_main_context_iterate (dispatch=1, block=1, context=0x7fbfdc0009a0, self=<optimized out>) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3126
#10 g_main_context_iterate (context=0x7fbfdc0009a0, block=1, dispatch=1, self=<optimized out>) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3083
#11 0x00007fbff9ad7164 in g_main_context_iteration (context=0x7fbfdc0009a0, may_block=1) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3207
#12 0x00007fbfff7b6906 in QEventDispatcherGlib::processEvents (this=0x7fbfdc0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#13 0x00007fbfff785e42 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#14 0x00007fbfff786097 in QEventLoop::exec (this=0x7fbfea53bdd0, flags=...) at kernel/qeventloop.cpp:204
#15 0x00007fbfff685057 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#16 0x00007fbfff765b4f in QInotifyFileSystemWatcherEngine::run (this=0x1adea70) at io/qfilesystemwatcher_inotify.cpp:248
#17 0x00007fbfff68807b in QThreadPrivate::start (arg=0x1adea70) at thread/qthread_unix.cpp:307
#18 0x00007fbffa197e9a in start_thread (arg=0x7fbfea53c700) at pthread_create.c:308
#19 0x00007fbffd337dbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#20 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fc00096f780 (LWP 8944)):
[KCrash Handler]
#6  0x00007fbffd27a445 in __GI_raise (sig=<optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#7  0x00007fbffd27dbab in __GI_abort () at abort.c:91
#8  0x00007fbffd2b849e in __libc_message (do_abort=2, fmt=0x7fbffd3c2108 "*** glibc detected *** %s: %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:201
#9  0x00007fbffd2c2c96 in malloc_printerr (action=3, str=0x7fbffd3bea13 "free(): invalid pointer", ptr=<optimized out>) at malloc.c:5007
#10 0x00007fbfff7aaf38 in clear (d=0x7fffe7053c50) at kernel/qvariant.cpp:287
#11 0x00007fbfdb5f6762 in setting (name=..., this=<optimized out>) at /build/buildd/digikam-2.6.0/extra/kipi-plugins/common/libkipiplugins/tools/kphostsettings.cpp:68
#12 KIPIPlugins::KPHostSettings::imageExtensions (this=0x7fffe7053ca0) at /build/buildd/digikam-2.6.0/extra/kipi-plugins/common/libkipiplugins/tools/kphostsettings.cpp:109
#13 0x00007fbfcad4c330 in KIPIBatchProcessImagesPlugin::BatchProcessImagesDialog::BatchProcessImagesDialog (this=0x20f9810, urlList=..., caption=..., parent=<optimized out>) at /build/buildd/digikam-2.6.0/extra/kipi-plugins/batchprocessimages/common/batchprocessimagesdialog.cpp:138
#14 0x00007fbfcad546fa in KIPIBatchProcessImagesPlugin::BorderImagesDialog::BorderImagesDialog (this=0x20f9810, urlList=..., parent=0x17367b0) at /build/buildd/digikam-2.6.0/extra/kipi-plugins/batchprocessimages/tools/borderimagesdialog.cpp:57
#15 0x00007fbfcad46e0b in KIPIBatchProcessImagesPlugin::Plugin_BatchProcessImages::slotActivate (this=0x208f990) at /build/buildd/digikam-2.6.0/extra/kipi-plugins/batchprocessimages/plugin/plugin_batchprocessimages.cpp:223
#16 0x00007fbfff79b761 in QMetaObject::activate (sender=0x1f160a0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffe70542f0) at kernel/qobject.cpp:3547
#17 0x00007fbffdf9f072 in QAction::triggered (this=<optimized out>, _t1=false) at .moc/release-shared/moc_qaction.cpp:277
#18 0x00007fbffdf9f25f in QAction::activate (this=0x1f160a0, event=<optimized out>) at kernel/qaction.cpp:1257
#19 0x00007fbffe3f15e9 in QMenuPrivate::activateCausedStack (this=0x1ff59e0, causedStack=..., action=0x1f160a0, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:1028
#20 0x00007fbffe3f7742 in QMenuPrivate::activateAction (this=0x1ff59e0, action=0x1f160a0, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:1120
#21 0x00007fbffdff5fb4 in QWidget::event (this=0x1ff70b0, event=0x7fffe7054d10) at kernel/qwidget.cpp:8371
#22 0x00007fbffe3f8cdb in QMenu::event (this=0x1ff70b0, e=0x7fffe7054d10) at widgets/qmenu.cpp:2469
#23 0x00007fbffdfa57b4 in notify_helper (e=0x7fffe7054d10, receiver=0x1ff70b0, this=0x15d8e00) at kernel/qapplication.cpp:4556
#24 QApplicationPrivate::notify_helper (this=0x15d8e00, receiver=0x1ff70b0, e=0x7fffe7054d10) at kernel/qapplication.cpp:4528
#25 0x00007fbffdfaaf2f in QApplication::notify (this=<optimized out>, receiver=0x1ff70b0, e=0x7fffe7054d10) at kernel/qapplication.cpp:4099
#26 0x00007fbffece0756 in KApplication::notify (this=0x7fffe7055a20, receiver=0x1ff70b0, event=0x7fffe7054d10) at ../../kdeui/kernel/kapplication.cpp:311
#27 0x00007fbfff78730c in QCoreApplication::notifyInternal (this=0x7fffe7055a20, receiver=0x1ff70b0, event=0x7fffe7054d10) at kernel/qcoreapplication.cpp:915
#28 0x00007fbffdfa6782 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#29 QApplicationPrivate::sendMouseEvent (receiver=0x1ff70b0, event=0x7fffe7054d10, alienWidget=0x0, nativeWidget=0x1ff70b0, buttonDown=0x0, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3167
#30 0x00007fbffe0261e1 in QETWidget::translateMouseEvent (this=0x1ff70b0, event=<optimized out>) at kernel/qapplication_x11.cpp:4551
#31 0x00007fbffe024ace in QApplication::x11ProcessEvent (this=0x7fffe7055a20, event=0x7fffe70555e0) at kernel/qapplication_x11.cpp:3732
#32 0x00007fbffe04e052 in x11EventSourceDispatch (s=0x15db700, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#33 0x00007fbff9ad6d53 in g_main_dispatch (context=0x15d9680) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:2539
#34 g_main_context_dispatch (context=0x15d9680) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3075
#35 0x00007fbff9ad70a0 in g_main_context_iterate (dispatch=1, block=<optimized out>, context=0x15d9680, self=<optimized out>) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3146
#36 g_main_context_iterate (context=0x15d9680, block=<optimized out>, dispatch=1, self=<optimized out>) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3083
#37 0x00007fbff9ad7164 in g_main_context_iteration (context=0x15d9680, may_block=1) at /build/buildd/glib2.0-2.32.3/./glib/gmain.c:3207
#38 0x00007fbfff7b689f in QEventDispatcherGlib::processEvents (this=0x15ae770, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#39 0x00007fbffe04dcde in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#40 0x00007fbfff785e42 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#41 0x00007fbfff786097 in QEventLoop::exec (this=0x7fffe7055980, flags=...) at kernel/qeventloop.cpp:204
#42 0x00007fbfff78b3e7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#43 0x0000000000427395 in main (argc=2, argv=0x7fffe7055d48) at ../../app/main.cpp:142

Possible duplicates by query: bug 307561, bug 307124, bug 306284, bug 306240, bug 305575.

Reported using DrKonqi
Comment 1 caulier.gilles 2012-10-07 12:50:24 UTC
It certainly due to a broken libkipi binary compatibility. Check libkipi package on your system...

Gilles Caulier
Comment 2 Harald Sitter 2012-11-13 11:53:36 UTC
Is that not like... eh... a defect in the library?
Comment 3 caulier.gilles 2015-06-26 13:46:20 UTC
New Kipi-plugins 4.11.0 is available :

https://www.digikam.org/node/740

Can you reproduce the problem with this release ?

Gilles Caulier
Comment 4 caulier.gilles 2015-07-04 10:10:50 UTC
BatchProcessImage is not maintained since a while and is obsolete now. It will
be removed with 5.0.0.

Use digiKam BQM instead...