Bug 307673

Summary: Akonadi/IMAP crashed when aborting the fetch job
Product: [Frameworks and Libraries] Akonadi Reporter: Dennis Schridde <devurandom>
Component: IMAP resourceAssignee: Kevin Ottens <ervin>
Status: RESOLVED DUPLICATE    
Severity: crash CC: kdepim-bugs, vkrause
Priority: NOR    
Version: 4.9   
Target Milestone: ---   
Platform: Gentoo Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description Dennis Schridde 2012-10-01 13:50:35 UTC
Application: akonadi_imap_resource (4.9)
KDE Platform Version: 4.9.1
Qt Version: 4.8.3
Operating System: Linux 3.5.4-gentoo x86_64
Distribution: "Gentoo Base System release 2.2"

-- Information about the crash:
- What I was doing when the application crashed:
Fetching of emails via IMAP seemed to hang, so I aborted the job using the red "stop-circle" symbol in Kontact (lower right corner, when extending the task list).

-- Backtrace:
Application: Kynes vom Typ IMAP-E-Mail-Server (akonadi_imap_resource), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f47f12d8780 (LWP 3577))]

Thread 2 (Thread 0x7f47ecd2d700 (LWP 10342)):
#0  0x00007fff499ff81f in clock_gettime ()
#1  0x00007f47f42f7f0d in clock_gettime () from /lib64/librt.so.1
#2  0x00007f47f87a9584 in qt_gettime() () from /usr/lib64/qt4/libQtCore.so.4
#3  0x00007f47f887abad in QTimerInfoList::updateCurrentTime() () from /usr/lib64/qt4/libQtCore.so.4
#4  0x00007f47f887aef3 in QTimerInfoList::timerWait(timeval&) () from /usr/lib64/qt4/libQtCore.so.4
#5  0x00007f47f8879a7c in timerSourcePrepareHelper(GTimerSource*, int*) () from /usr/lib64/qt4/libQtCore.so.4
#6  0x00007f47f8879b1d in timerSourcePrepare(_GSource*, int*) () from /usr/lib64/qt4/libQtCore.so.4
#7  0x00007f47f401d6e6 in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#8  0x00007f47f401ddcb in ?? () from /usr/lib64/libglib-2.0.so.0
#9  0x00007f47f401dfc4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#10 0x00007f47f887a3ae in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#11 0x00007f47f884bb3f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#12 0x00007f47f884bdc0 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#13 0x00007f47f8752340 in QThread::exec() () from /usr/lib64/qt4/libQtCore.so.4
#14 0x00007f47f74fa379 in KIMAP::SessionThread::run (this=0xc49cd0) at /var/tmp/portage/kde-base/kdepimlibs-4.9.1-r1/work/kdepimlibs-4.9.1/kimap/sessionthread.cpp:181
#15 0x00007f47f875523c in QThreadPrivate::start(void*) () from /usr/lib64/qt4/libQtCore.so.4
#16 0x00007f47f4980e0e in start_thread () from /lib64/libpthread.so.0
#17 0x00007f47f4eb46bd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f47f12d8780 (LWP 3577)):
[KCrash Handler]
#6  0x00007f47f88643eb in QObject::disconnect(QObject const*, char const*, QObject const*, char const*) () from /usr/lib64/qt4/libQtCore.so.4
#7  0x0000000000453075 in SessionPool::killSession (this=this@entry=0xb24730, session=0xfeb9e0, termination=termination@entry=SessionPool::CloseSession) at /var/tmp/portage/kde-base/kdepim-runtime-4.9.1/work/kdepim-runtime-4.9.1/resources/imap/sessionpool.cpp:176
#8  0x000000000045342d in SessionPool::disconnect (this=0xb24730, termination=SessionPool::CloseSession) at /var/tmp/portage/kde-base/kdepim-runtime-4.9.1/work/kdepim-runtime-4.9.1/resources/imap/sessionpool.cpp:117
#9  0x00000000004176be in ImapResource::abortActivity (this=0xaf9600) at /var/tmp/portage/kde-base/kdepim-runtime-4.9.1/work/kdepim-runtime-4.9.1/resources/imap/imapresource.cpp:616
#10 0x000000000041acd5 in ImapResource::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /var/tmp/portage/kde-base/kdepim-runtime-4.9.1/work/kdepim-runtime-4.9.1_build/resources/imap/imapresource.moc:105
#11 0x00007f47f88549d3 in QMetaMethod::invoke(QObject*, Qt::ConnectionType, QGenericReturnArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument) const () from /usr/lib64/qt4/libQtCore.so.4
#12 0x00007f47f8856d34 in QMetaObject::invokeMethod(QObject*, char const*, Qt::ConnectionType, QGenericReturnArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument) () from /usr/lib64/qt4/libQtCore.so.4
#13 0x00007f47f8f6ff5d in invokeMethod (val9=..., val8=..., val7=..., val6=..., val5=..., val4=..., val3=..., val2=..., val1=..., val0=..., member=0x7f47f8ff6e59 "abortActivity", obj=0xaf9600) at /usr/include/qt4/QtCore/qobjectdefs.h:434
#14 Akonadi::ResourceBasePrivate::slotAbortRequested (this=<optimized out>) at /var/tmp/portage/kde-base/kdepimlibs-4.9.1-r1/work/kdepimlibs-4.9.1/akonadi/resourcebase.cpp:461
#15 0x00007f47f8f75257 in Akonadi::ResourceBase::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /var/tmp/portage/kde-base/kdepimlibs-4.9.1-r1/work/kdepimlibs-4.9.1_build/akonadi/moc_resourcebase.cpp:124
#16 0x00007f47f8861ccf in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/qt4/libQtCore.so.4
#17 0x00007f47f8fe536b in Akonadi__ControlAdaptor::qt_metacall (this=0xb0c010, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff49969c30) at /var/tmp/portage/kde-base/kdepimlibs-4.9.1-r1/work/kdepimlibs-4.9.1_build/akonadi/controladaptor.moc:120
#18 0x00007f47f8bc5b63 in ?? () from /usr/lib64/qt4/libQtDBus.so.4
#19 0x00007f47f8bc6b4e in ?? () from /usr/lib64/qt4/libQtDBus.so.4
#20 0x00007f47f8bc7585 in ?? () from /usr/lib64/qt4/libQtDBus.so.4
#21 0x00007f47f8bc767b in ?? () from /usr/lib64/qt4/libQtDBus.so.4
#22 0x00007f47f88611e6 in QObject::event(QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#23 0x00007f47f7c3028c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#24 0x00007f47f7c3464a in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#25 0x00007f47f5d97406 in KApplication::notify (this=0x7fff4996a840, receiver=0xaf9600, event=0xdf8f80) at /var/tmp/portage/kde-base/kdelibs-4.9.1/work/kdelibs-4.9.1/kdeui/kernel/kapplication.cpp:311
#26 0x00007f47f884cdad in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#27 0x00007f47f8850640 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/qt4/libQtCore.so.4
#28 0x00007f47f887a213 in postEventSourceDispatch(_GSource*, int (*)(void*), void*) () from /usr/lib64/qt4/libQtCore.so.4
#29 0x00007f47f401dbbc in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#30 0x00007f47f401df14 in ?? () from /usr/lib64/libglib-2.0.so.0
#31 0x00007f47f401dfc4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#32 0x00007f47f887a394 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#33 0x00007f47f7ccdfce in QGuiEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtGui.so.4
#34 0x00007f47f884bb3f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#35 0x00007f47f884bdc0 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#36 0x00007f47f8850928 in QCoreApplication::exec() () from /usr/lib64/qt4/libQtCore.so.4
#37 0x00007f47f8f6fe33 in Akonadi::ResourceBase::init (r=0xaf9600) at /var/tmp/portage/kde-base/kdepimlibs-4.9.1-r1/work/kdepimlibs-4.9.1/akonadi/resourcebase.cpp:451
#38 0x000000000041b213 in Akonadi::ResourceBase::init<ImapResource> (argc=<optimized out>, argv=<optimized out>) at /usr/include/akonadi/resourcebase.h:188
#39 0x00007f47f4df3425 in __libc_start_main () from /lib64/libc.so.6
#40 0x00000000004159f5 in _start ()

This bug may be a duplicate of or related to bug 288268.

Possible duplicates by query: bug 306819, bug 306040, bug 306024, bug 305936, bug 303381.

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2012-10-03 22:43:33 UTC

*** This bug has been marked as a duplicate of bug 288268 ***