Bug 307147

Summary: Build failed against libkipi 2.0.0
Product: kamoso Reporter: nucleo <nucleo>
Component: generalAssignee: Alex Fiestas <afiestas>
Status: RESOLVED FIXED    
Severity: normal CC: caulier.gilles, creffett, dodonvictor, hrvoje.senjan, kde, manisandro, rdieter
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: Patch

Description nucleo 2012-09-21 10:31:18 UTC
Build kamoso-2.0.2 failed against libkipi 2.0.0 (released with digikam-3.0.0-beta1)

[  2%] Generating kamoso.gmo
cd /builddir/build/BUILD/kamoso-2.0.2/po/nds && /usr/bin/msgfmt -o /builddir/build/BUILD/kamoso-2.0.2/x86_64-redhat-linux-gnu/po/nds/kamoso.gmo /builddir/build/BUILD/kamoso-2.0.2/po/nds/kamoso.po
make[2]: Leaving directory `/builddir/build/BUILD/kamoso-2.0.2/x86_64-redhat-linux-gnu'
/usr/bin/cmake -E cmake_progress_report /builddir/build/BUILD/kamoso-2.0.2/x86_64-redhat-linux-gnu/CMakeFiles  62
/builddir/build/BUILD/kamoso-2.0.2/src/plugins/youtube/kipiplugin_youtube.h:31: Error: Undefined interface
automoc4: process for /builddir/build/BUILD/kamoso-2.0.2/x86_64-redhat-linux-gnu/src/plugins/youtube/moc_kipiplugin_youtube.cpp failed: Unknown error
pid to wait for: 0

Reproducible: Always
Comment 2 Sandro Mani 2012-09-30 12:40:52 UTC
Created attachment 74244 [details]
Patch

Probably not the most elegant of patches, but works
Comment 3 Christoph Feck 2012-11-24 20:24:05 UTC
*** Bug 310618 has been marked as a duplicate of this bug. ***
Comment 4 Rex Dieter 2012-12-21 16:43:35 UTC
Git commit a0aec903b36b52bda1a9a5d2e875af1063747a86 by Rex Dieter.
Committed on 21/12/2012 at 17:39.
Pushed by rdieter into branch 'master'.

initial port to libkipi-2.x

Initial libkipi-2.x support courtesy of Sando Mani

M  +4    -1    src/kamoso.cpp
M  +1    -0    src/kamoso.h
M  +2    -2    src/kipiaction.cpp
M  +2    -2    src/pluginTester/fakekipiaction.cpp
M  +3    -1    src/pluginTester/pluginTester.cpp
M  +1    -1    src/plugins/CMakeLists.txt
A  +15   -0    src/plugins/exportinterface.h     [License: UNKNOWN]  *
M  +2    -3    src/plugins/youtube/kipiplugin_youtube.h

The files marked with a * at the end have a non valid license. Please read: http://techbase.kde.org/Policies/Licensing_Policy and use the headers which are listed at that page.


http://commits.kde.org/kamoso/a0aec903b36b52bda1a9a5d2e875af1063747a86
Comment 5 Rex Dieter 2012-12-21 17:12:56 UTC
hrm, I *thought* I'd tested things with older libkipi, but apparently not.  now fails to build against kde-4.9.x's libkipi :(

I'll see if I can make it buildable again.
Comment 6 Rex Dieter 2012-12-21 18:04:14 UTC
Git commit 9f32257a1e930b16e64508e6fbfa9390fc0322ee by Rex Dieter.
Committed on 21/12/2012 at 18:55.
Pushed by rdieter into branch 'master'.

fix build for < libkipi-2

M  +5    -0    src/kamoso.cpp
M  +6    -1    src/pluginTester/pluginTester.cpp

http://commits.kde.org/kamoso/9f32257a1e930b16e64508e6fbfa9390fc0322ee
Comment 7 Rex Dieter 2012-12-21 22:06:21 UTC
So some bad news, after getting home and having my webcam available, seems the libkipi-2 support doesn't work :( .  right clicking on images doesn't show any available kipi plugins.   I'd still consider the buildfix to be worth something... I'll keep working on this over the holidays.
Comment 8 Sandro Mani 2012-12-21 23:03:33 UTC
Uh, I must admit that the objective of my patch was just to get it building again. Odd though, all the patch does is restore the interface, no methods are altered.
Comment 9 Rex Dieter 2012-12-21 23:38:47 UTC
In fairness, prior to this patch it didn't seem to work 100% as expected either, kamoso only lists 4 (of a large number) available "export" kipi-plugins for me.  I'm guessing it's simply exposing or tickling other issue(s)