Bug 306597

Summary: Kwin crashes disabling desktop effects
Product: [Plasma] kwin Reporter: Vadym Krevs <vkrevs>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: openSUSE   
OS: Linux   
Latest Commit: Version Fixed In:

Description Vadym Krevs 2012-09-11 10:45:11 UTC
Application: kwin (4.9.1 "release 561")
KDE Platform Version: 4.9.1 "release 561"
Qt Version: 4.8.2
Operating System: Linux 3.4.6-2.10-desktop x86_64
Distribution: "openSUSE 12.2 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

Decided to disable desktop effects. Went into System Setting->Desktop Effects and unchecked the "Enable deskop effects at startup" checkbox. Kwin crashed.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f124c3077c0 (LWP 4993))]

Thread 2 (Thread 0x7f123702c700 (LWP 5059)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f125e418217 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f125e725640 <QTWTF::pageheap_memory>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f125e418249 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f125dbec734 in ?? () from /usr/X11R6/lib64/libGL.so.1
#4  0x00007f125cd13e0e in start_thread (arg=0x7f123702c700) at pthread_create.c:305
#5  0x00007f126151e2bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f124c3077c0 (LWP 4993)):
[KCrash Handler]
#6  isSignalConnected (signal_index=8, this=0x0) at kernel/qobject_p.h:232
#7  QMetaObject::activate (sender=0x3263f90, m=<optimized out>, local_signal_index=6, argv=0x7fffee8567b0) at kernel/qobject.cpp:3465
#8  0x00007f126188eebf in KWin::Toplevel::windowClosed (this=<optimized out>, _t1=0x3263f90, _t2=0x0) at /usr/src/debug/kde-workspace-4.9.1/build/kwin/toplevel.moc:354
#9  0x00007f126188fb83 in KWin::Unmanaged::release (this=0x3263f90, on_shutdown=true) at /usr/src/debug/kde-workspace-4.9.1/kwin/unmanaged.cpp:89
#10 0x00007f1261826a62 in KWin::Workspace::~Workspace (this=0x26dd850, __in_chrg=<optimized out>) at /usr/src/debug/kde-workspace-4.9.1/kwin/workspace.cpp:537
#11 0x00007f1261827139 in KWin::Workspace::~Workspace (this=0x26dd850, __in_chrg=<optimized out>) at /usr/src/debug/kde-workspace-4.9.1/kwin/workspace.cpp:564
#12 0x00007f1261843c27 in KWin::Application::lostSelection (this=0x7fffee857540) at /usr/src/debug/kde-workspace-4.9.1/kwin/main.cpp:354
#13 0x00007f125d0ba9ff in QMetaObject::activate (sender=0x7fffee857558, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3556
#14 0x00007f126107e873 in KSelectionOwner::filterEvent (this=0x7fffee857558, ev_P=<optimized out>) at /usr/src/debug/kdelibs-4.9.1/kdeui/util/kmanagerselection.cpp:224
#15 0x00007f126101de1e in publicx11Event (e=<optimized out>, this=<optimized out>) at /usr/src/debug/kdelibs-4.9.1/kdeui/kernel/kapplication.cpp:918
#16 KApplication::x11EventFilter (this=0x4, _event=0x7fffee856fe0) at /usr/src/debug/kdelibs-4.9.1/kdeui/kernel/kapplication.cpp:930
#17 0x00007f125c29f86c in qt_x11EventFilter (ev=0x7fffee856fe0) at kernel/qapplication_x11.cpp:435
#18 qt_x11EventFilter (ev=0x7fffee856fe0) at kernel/qapplication_x11.cpp:423
#19 0x00007f125c2ace2b in QApplication::x11ProcessEvent (this=0x7fffee857540, event=0x7fffee856fe0) at kernel/qapplication_x11.cpp:3348
#20 0x00007f125c2d4569 in QEventDispatcherX11::processEvents (this=0x2550a70, flags=...) at kernel/qeventdispatcher_x11.cpp:132
#21 0x00007f125d0a2ebf in QEventLoop::processEvents (this=this@entry=0x7fffee857250, flags=...) at kernel/qeventloop.cpp:149
#22 0x00007f125d0a3148 in QEventLoop::exec (this=0x7fffee857250, flags=...) at kernel/qeventloop.cpp:204
#23 0x00007f125d0a7de8 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#24 0x00007f1261844d74 in kdemain (argc=3, argv=0x7fffee857688) at /usr/src/debug/kde-workspace-4.9.1/kwin/main.cpp:545
#25 0x00007f126145b455 in __libc_start_main (main=0x4006f0 <main(int, char**)>, argc=3, ubp_av=0x7fffee857688, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffee857678) at libc-start.c:226
#26 0x0000000000400721 in _start () at ../sysdeps/x86_64/elf/start.S:113

Possible duplicates by query: bug 305944, bug 303244.

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2012-09-11 11:14:18 UTC

*** This bug has been marked as a duplicate of bug 303244 ***