Bug 306387

Summary: Plasma-desktop crash on login or restart
Product: [Plasma] plasma4 Reporter: groot
Component: widget-microbloggingAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: 4.9.1   
Target Milestone: ---   
Platform: openSUSE   
OS: Linux   
Latest Commit: Version Fixed In:

Description groot 2012-09-07 08:48:21 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.9.1 "release 561"
Qt Version: 4.8.2
Operating System: Linux 3.4.6-2.10-desktop i686
Distribution: "openSUSE 12.2 (i586)"

-- Information about the crash:
plasma-desktop crashed on login (OpenSUSE 12.2, KDE49 repository added). Black screen results. From text console, launch an xterm in that session and try to restart plasma-desktop, same crash. 

Qt: 4.8.2
KDE Development Platform: 4.9.1 "release 561"
Plasma Desktop Shell: 0.4

When running plasma-desktop from xterm, there are several lines plasma-desktop(5582)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability  (*which* plugin, it doesn't say -- and I don't think I have any third-party plugins installed).

Last bit of output is

X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 20 (X_GetProperty)
  Resource id:  0x5800012
link XMLID_34_ hasn't been detected!
link XMLID_34_ hasn't been detected!
link XMLID_36_ hasn't been detected!
QGraphicsLinearLayout::insertItem: cannot insert null item
QGraphicsLinearLayout::insertItem: cannot insert null item
KCrash: Attempting to start /usr/bin/plasma-desktop from kdeinit

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0xb1b63980 (LWP 5554))]

Thread 3 (Thread 0xaade9b40 (LWP 5557)):
#0  0xb2ad8e3d in clock_gettime () from /lib/librt.so.1
#1  0xb5f7f695 in do_gettime (frac=0xaade8fa0, sec=0xaade8f98) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb606407e in QTimerInfoList::updateCurrentTime (this=0xaa402074) at kernel/qeventdispatcher_unix.cpp:343
#4  0xaa4004e0 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 2 (Thread 0xaa2d2b40 (LWP 5558)):
#0  0xb774b424 in __kernel_vsyscall ()
#1  0xb5ea2a4c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb760421c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libc.so.6
#3  0xb396f1dd in QTWTF::TCMalloc_PageHeap::scavengerThread (this=this@entry=0xb3a7d560 <QTWTF::pageheap_memory>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#4  0xb396f20f in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0xb3a7d560 <QTWTF::pageheap_memory>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#5  0xb5e9ee32 in start_thread () from /lib/libpthread.so.0
#6  0xb75f68ee in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb1b63980 (LWP 5554)):
[KCrash Handler]
#7  0xb60384a6 in QMetaObject::cast (this=0xb7501d00 <Plasma::Extender::staticMetaObject>, obj=0x8e52a78) at kernel/qmetaobject.cpp:274
#8  0xb73300dd in qobject_cast<Plasma::Extender*> (object=<optimized out>) at /usr/include/QtCore/qobject.h:380
#9  Plasma::PopupAppletPrivate::checkExtenderAppearance (this=this@entry=0x87ca878, f=f@entry=Plasma::Planar) at /usr/src/debug/kdelibs-4.9.1/plasma/popupapplet.cpp:190
#10 0xb7332384 in Plasma::PopupAppletPrivate::popupConstraintsEvent (this=0x87ca878, constraints=...) at /usr/src/debug/kdelibs-4.9.1/plasma/popupapplet.cpp:211
#11 0xb72d570e in flushPendingConstraintsEvents (this=0x8876830) at /usr/src/debug/kdelibs-4.9.1/plasma/applet.cpp:1361
#12 Plasma::Applet::flushPendingConstraintsEvents (this=0x8876830) at /usr/src/debug/kdelibs-4.9.1/plasma/applet.cpp:1204
#13 0xb72e5f50 in Plasma::ContainmentPrivate::initApplets (this=0x879aa60) at /usr/src/debug/kdelibs-4.9.1/plasma/containment.cpp:482
#14 0xb72faed2 in Plasma::CoronaPrivate::importLayout (this=0x8670c90, conf=..., mergeConfig=mergeConfig@entry=false) at /usr/src/debug/kdelibs-4.9.1/plasma/corona.cpp:1067
#15 0xb72fbc45 in Plasma::Corona::loadLayout (this=0x8670e90, configName=...) at /usr/src/debug/kdelibs-4.9.1/plasma/corona.cpp:278
#16 0x08680288 in ?? ()
#17 0xb6ede92c in ?? () from /usr/lib/libplasmagenericshell.so.4
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

This bug may be a duplicate of or related to bug 301947.

Possible duplicates by query: bug 301947.

Reported using DrKonqi
Comment 1 groot 2012-09-07 09:44:03 UTC
A completely fresh user gets a proper login, so it's apparently something in the .kde for my regular login (upgraded from OpenSUSE 12.1 / KDE 4.7)
Comment 2 Jekyll Wu 2012-09-07 13:44:16 UTC
Please check whether the microblogging plasmoid is the culprit.
Comment 3 groot 2012-09-07 15:46:39 UTC
How would I do that? Short of adding the microblog plasmoid to the desktop of the new, fresh user, that is. I know I had that one enabled in the desktop config for the user that now crashes, so how do I remove the microblog plasmoid there?
Comment 4 groot 2012-09-07 18:54:49 UTC
In a fresh user, if I add the microblog plasmoid to the desktop, plasma-desktop instantly crashes (and the configuration is not saved, so I can log in again with that user, no problem). I can't figure out how to clear up the plasma configuration so as to remove the microblog plasmoid once it's there, though.
Comment 5 groot 2012-09-07 19:34:18 UTC
.. and confirmed that hand-editing plasma-desktop-appletsrc and removing the [Applets][n] and [Applets][n][Configuration] sections which refer to the *twitter* plugin and identica allows plasma-desktop to start normally, albeit without the microblog thing.
Comment 6 Jekyll Wu 2012-09-08 04:08:35 UTC

*** This bug has been marked as a duplicate of bug 301947 ***