Bug 305445

Summary: In KDE 4.9, make changes to the title window font in Systemsettings has no effect. The windows title font never changes.
Product: [Plasma] kwin Reporter: VaryHeavy <anvariom>
Component: decorationsAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: normal CC: cfeck
Priority: NOR    
Version: 4.9.0   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:

Description VaryHeavy 2012-08-19 16:44:40 UTC
Since I updated KDE to version 4.9, I noticed that the title windows font had changed from I was put. I tried to change the title window font in Systemsettings but the changes has no effect.

This problem is present in all distributions I've tried, so I don't put any particular distribution in "Hardware Platform".

Reproducible: Always

Steps to Reproduce:
1. Update KDE to version 4.9.
2. Open Systemsettings > Application appearance > Fonts.
3. Try to change the title window font.
4. Look that title window font never changes.
Actual Results:  
The title window font never changes. Make changes in Systemsettings has no effect.

Expected Results:  
Make changes in Systemsettings should make that title window font changes.
Comment 1 Christoph Feck 2012-08-20 01:24:55 UTC
Does it happen with all types of window decorations, or only with the Oxygen window decoration?
Comment 2 VaryHeavy 2012-08-20 02:21:41 UTC
(In reply to comment #1)
I checked that it happens using the Radial (thin borders) decoration, not in other decorations. But... I am using this decoration for a long time and this doesn't happen never before. Why now?
Comment 3 Thomas L├╝bking 2012-08-20 10:21:45 UTC
because the Aurorae engine was rewritten to use QML

*** This bug has been marked as a duplicate of bug 304791 ***
Comment 4 VaryHeavy 2012-08-20 15:21:21 UTC
I have to add today I checked that this happens not only in the Radial (thin borders) decoration, this happens in all decorations different of default installed. I mean that it doesn't happen in Oxygen or Plastique decoration, but yes in Radial, Air-Black, Ghost-Deco, or UniQ decorations... all decorations you installed after the default installation.
Comment 5 Christoph Feck 2012-08-20 15:25:00 UTC
Please do not reopen.

The duplication notice says it's fixed in KDE 4.9.1, so you will either have to wait, or compile from source yourself.

*** This bug has been marked as a duplicate of bug 304791 ***