Bug 304579

Summary: xskat and kwin
Product: kwin Reporter: Bernd Schmidt <bernd_schmidt_sh>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: openSUSE RPMs   
OS: Linux   
Latest Commit: Version Fixed In:

Description Bernd Schmidt 2012-08-04 22:57:55 UTC
Application: kwin (4.8.97 "release 549")
KDE Platform Version: 4.8.97 "release 549"
Qt Version: 4.8.2
Operating System: Linux 3.5.0-8-desktop x86_64
Distribution: "openSUSE 12.3 Milestone 0 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

I have played xskat, and when I am closing xskat, kwin crashed.
I repeated that many times and always kwin crashed. I don't know
if it's the fault of kwin or of xskat.

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fc246245780 (LWP 11417))]

Thread 2 (Thread 0x7fc23bfff700 (LWP 11423)):
#0  0x00007fc2551178f4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fc25675c217 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7fc256a69640 <QTWTF::pageheap_memory>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007fc25675c249 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007fc255113e0e in start_thread () from /lib64/libpthread.so.0
#4  0x00007fc2598642cd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fc246245780 (LWP 11417)):
[KCrash Handler]
#5  0x00007fc254be3a54 in QGraphicsItem::acceptHoverEvents (this=0x21d9c60) at graphicsview/qgraphicsitem.cpp:2990
#6  0x00007fc2587cd855 in QDeclarativeMouseArea::mouseReleaseEvent (this=0x21d9c50, event=<optimized out>) at graphicsitems/qdeclarativemousearea.cpp:591
#7  0x00007fc254bee479 in QGraphicsItem::sceneEvent (this=0x21d9c60, event=0x7fffe3f08c50) at graphicsview/qgraphicsitem.cpp:6741
#8  0x00007fc2587c00a2 in QDeclarativeItem::sceneEvent (this=0x21d9c50, event=0x7fffe3f08c50) at graphicsitems/qdeclarativeitem.cpp:3013
#9  0x00007fc2587cc189 in QDeclarativeMouseArea::sceneEvent (this=0x21d9c50, event=0x7fffe3f08c50) at graphicsitems/qdeclarativemousearea.cpp:682
#10 0x00007fc254c177c0 in sendMouseEvent (mouseEvent=0x7fffe3f08c50, this=0x1edf230) at graphicsview/qgraphicsscene.cpp:1295
#11 QGraphicsScenePrivate::sendMouseEvent (this=0x1edf230, mouseEvent=0x7fffe3f08c50) at graphicsview/qgraphicsscene.cpp:1274
#12 0x00007fc254c181b5 in QGraphicsScene::mouseReleaseEvent (this=<optimized out>, mouseEvent=0x7fffe3f08c50) at graphicsview/qgraphicsscene.cpp:4128
#13 0x00007fc254c2af0c in QGraphicsScene::event (this=0x28bf180, event=0x7fffe3f08c50) at graphicsview/qgraphicsscene.cpp:3458
#14 0x00007fc25463264c in QApplicationPrivate::notify_helper (this=this@entry=0xbbb1d0, receiver=receiver@entry=0x28bf180, e=e@entry=0x7fffe3f08c50) at kernel/qapplication.cpp:4551
#15 0x00007fc254636aca in QApplication::notify (this=0x7fffe3f0a260, receiver=0x28bf180, e=0x7fffe3f08c50) at kernel/qapplication.cpp:4412
#16 0x00007fc259361086 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#17 0x00007fc2554a416e in QCoreApplication::notifyInternal (this=0x7fffe3f0a260, receiver=0x28bf180, event=0x7fffe3f08c50) at kernel/qcoreapplication.cpp:915
#18 0x00007fc254c41211 in QGraphicsView::mouseReleaseEvent (this=0x2835060, event=0x7fffe3f09580) at graphicsview/qgraphicsview.cpp:3338
#19 0x00007fc254681cb0 in QWidget::event (this=0x2835060, event=0x7fffe3f09580) at kernel/qwidget.cpp:8371
#20 0x00007fc254a2be86 in QFrame::event (this=0x2835060, e=0x7fffe3f09580) at widgets/qframe.cpp:557
#21 0x00007fc254c4468b in QGraphicsView::viewportEvent (this=0x2835060, event=0x7fffe3f09580) at graphicsview/qgraphicsview.cpp:2866
#22 0x00007fc2554a42d6 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<optimized out>, receiver=0x11d3190, event=0x7fffe3f09580) at kernel/qcoreapplication.cpp:1025
#23 0x00007fc25463261c in QApplicationPrivate::notify_helper (this=this@entry=0xbbb1d0, receiver=receiver@entry=0x11d3190, e=e@entry=0x7fffe3f09580) at kernel/qapplication.cpp:4547
#24 0x00007fc25463732b in QApplication::notify (this=<optimized out>, receiver=0x11d3190, e=0x7fffe3f09580) at kernel/qapplication.cpp:4094
#25 0x00007fc259361086 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#26 0x00007fc2554a416e in QCoreApplication::notifyInternal (this=0x7fffe3f0a260, receiver=0x11d3190, event=0x7fffe3f09580) at kernel/qcoreapplication.cpp:915
#27 0x00007fc25463348b in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:231
#28 QApplicationPrivate::sendMouseEvent (receiver=0x11d3190, event=0x7fffe3f09580, alienWidget=0x0, nativeWidget=0x11d3190, buttonDown=0x7fc255107248 <qt_button_down>, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3162
#29 0x00007fc2546adad4 in QETWidget::translateMouseEvent (this=this@entry=0x11d3190, event=event@entry=0x7fffe3f09d00) at kernel/qapplication_x11.cpp:4513
#30 0x00007fc2546ac861 in QApplication::x11ProcessEvent (this=0x7fffe3f0a260, event=0x7fffe3f09d00) at kernel/qapplication_x11.cpp:3636
#31 0x00007fc2546d3569 in QEventDispatcherX11::processEvents (this=0xb70a70, flags=...) at kernel/qeventdispatcher_x11.cpp:132
#32 0x00007fc2554a2ebf in QEventLoop::processEvents (this=this@entry=0x7fffe3f09f70, flags=...) at kernel/qeventloop.cpp:149
#33 0x00007fc2554a3148 in QEventLoop::exec (this=0x7fffe3f09f70, flags=...) at kernel/qeventloop.cpp:204
#34 0x00007fc2554a7de8 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#35 0x00007fc259b8a524 in kdemain () from /usr/lib64/libkdeinit4_kwin.so
#36 0x00007fc2597a1455 in __libc_start_main () from /lib64/libc.so.6
#37 0x0000000000400721 in _start ()

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2012-08-05 02:42:15 UTC

*** This bug has been marked as a duplicate of bug 303450 ***