Bug 304538

Summary: Kwin crashing on reboot
Product: [Plasma] kwin Reporter: l.mierzwa
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: 4.9.0   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:

Description l.mierzwa 2012-08-04 10:03:19 UTC
Application: kwin (4.9.00)
KDE Platform Version: 4.9.00
Qt Version: 4.8.1
Operating System: Linux 3.2.0-29-generic x86_64
Distribution: Ubuntu 12.04.1 LTS

-- Information about the crash:
This happens sometimes on logout/shutdown/reboot, I had such issue since I've upgraded to 4.9 beta1 from kubuntu beta ppa, with final 4.9 the issue remains

The crash can be reproduced some of the time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[KCrash Handler]
#6  data (this=0xb9) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:135
#7  qGetPtrHelper<QScopedPointer<QObjectData> > (p=...) at ../../include/QtCore/../../src/corelib/global/qglobal.h:2430
#8  d_func (this=0xb1) at ../../include/QtCore/../../src/corelib/kernel/qobject.h:115
#9  QMetaObject::activate (sender=0x207f4f0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff30468e20) at kernel/qobject.cpp:3501
#10 0x00007fa19ad5791f in KWin::Toplevel::windowClosed (this=<optimized out>, _t1=0x207f4f0, _t2=0x0) at ./toplevel.moc:350
#11 0x00007fa19ad585d3 in KWin::Unmanaged::release (this=0x207f4f0, on_shutdown=true) at ../../kwin/unmanaged.cpp:89
#12 0x00007fa19ace9902 in KWin::Workspace::~Workspace (this=0x1483140, __in_chrg=<optimized out>) at ../../kwin/workspace.cpp:537
#13 0x00007fa19acea149 in KWin::Workspace::~Workspace (this=0x1483140, __in_chrg=<optimized out>) at ../../kwin/workspace.cpp:564
#14 0x00007fa19ad05735 in KWin::Application::~Application (this=0x7fff30468fa0, __in_chrg=<optimized out>) at ../../kwin/main.cpp:343
#15 0x00007fa19ad07fe4 in kdemain (argc=<optimized out>, argv=<optimized out>) at ../../kwin/main.cpp:545
#16 0x00007fa19a90876d in __libc_start_main (main=0x400630 <main(int, char**)>, argc=3, ubp_av=0x7fff30469698, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff30469688) at libc-start.c:226
#17 0x0000000000400661 in _start ()

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2012-08-04 11:24:53 UTC
Ubuntu 12.04 / x86_64 pattern holds.

*** This bug has been marked as a duplicate of bug 303244 ***