Bug 303961

Summary: Kwin crash-flash related
Product: [Plasma] kwin Reporter: Jannis Liapis <ahepas1999>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash Flags: mgraesslin: Intel+
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:

Description Jannis Liapis 2012-07-23 14:27:34 UTC
Application: kwin (4.8.4 (4.8.4))
KDE Platform Version: 4.8.4 (4.8.4)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-27-generic-pae i686
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed: Hi there. I was trying to view flash content in fullscreen when kwin crashed

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb1ae4740 (LWP 4343))]

Thread 3 (Thread 0xacc6ab40 (LWP 4350)):
#0  0xb77a3424 in __kernel_vsyscall ()
#1  0xb7570af1 in select () from /lib/i386-linux-gnu/libc.so.6
#2  0xb5fe542a in qt_safe_select (nfds=22, fdread=0xac30058c, fdwrite=0xac3007a0, fdexcept=0xac3009b4, orig_timeout=0x0) at kernel/qcore_unix.cpp:83
#3  0xb5fe9a1b in QEventDispatcherUNIX::select (this=0xac300488, nfds=22, readfds=0xac30058c, writefds=0xac3007a0, exceptfds=0xac3009b4, timeout=0x0) at kernel/qeventdispatcher_unix.cpp:639
#4  0xb5fead2f in QEventDispatcherUNIXPrivate::doSelect (this=0xac300498, flags=..., timeout=0x0) at kernel/qeventdispatcher_unix.cpp:223
#5  0xb5feb1f4 in QEventDispatcherUNIX::processEvents (this=0xac300488, flags=...) at kernel/qeventdispatcher_unix.cpp:926
#6  0xb5fb450d in QEventLoop::processEvents (this=0xacc6a240, flags=...) at kernel/qeventloop.cpp:149
#7  0xb5fb47a9 in QEventLoop::exec (this=0xacc6a240, flags=...) at kernel/qeventloop.cpp:204
#8  0xb5e9d94c in QThread::exec (this=0x99fee00) at thread/qthread.cpp:501
#9  0xb5f91b5d in QInotifyFileSystemWatcherEngine::run (this=0x99fee00) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb5ea0de0 in QThreadPrivate::start (arg=0x99fee00) at thread/qthread_unix.cpp:298
#11 0xb2a81d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0xb7577ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xac2ffb40 (LWP 4353)):
#0  0xb77a3424 in __kernel_vsyscall ()
#1  0xb2a8596b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb75853dc in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb6693029 in ?? () from /usr/lib/i386-linux-gnu/libQtScript.so.4
#4  0xb669306f in ?? () from /usr/lib/i386-linux-gnu/libQtScript.so.4
#5  0xb2a81d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#6  0xb7577ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb1ae4740 (LWP 4343)):
[KCrash Handler]
#7  brw_update_renderbuffer_surface (brw=0x96d8850, rb=0x971f5b0, unit=0) at brw_wm_surface_state.c:959
#8  0xaeb88583 in brw_update_renderbuffer_surfaces (brw=0x96d8850) at brw_wm_surface_state.c:1052
#9  0xaeb7142f in brw_upload_state (brw=0x96d8850) at brw_state_upload.c:503
#10 0xaeb5c6f7 in brw_try_draw_prims (max_index=3, min_index=0, ib=0x0, nr_prims=1, prim=0xbfa0c338, arrays=0x973b398, ctx=0x96d8850) at brw_draw.c:482
#11 brw_draw_prims (ctx=0x96d8850, arrays=0x973b398, prim=0xbfa0c338, nr_prims=1, ib=0x0, index_bounds_valid=1 '\001', min_index=0, max_index=3, tfb_vertcount=0x0) at brw_draw.c:566
#12 0xae9ba69e in vbo_draw_arrays (ctx=0x96d8850, mode=6, start=0, count=4, numInstances=1) at vbo/vbo_exec_array.c:600
#13 0xaea6d277 in _mesa_meta_glsl_Clear (ctx=0x96d8850, buffers=2) at drivers/common/meta.c:1913
#14 0xaeb3d484 in intelClear (ctx=0x96d8850, mask=2) at intel_clear.c:192
#15 0xae8e1189 in _mesa_Clear (mask=<optimized out>) at main/clear.c:242
#16 0xb770d438 in KWin::SceneOpenGL::paintBackground (this=0x971ed20, region=...) at ../../kwin/scene_opengl.cpp:180
#17 0xb76f9fdb in KWin::Scene::paintGenericScreen (this=0x971ed20, orig_mask=544) at ../../kwin/scene.cpp:206
#18 0xb7708824 in KWin::SceneOpenGL::paintGenericScreen (this=0x971ed20, mask=544, data=...) at ../../kwin/scene_opengl.cpp:167
#19 0xb76f68d0 in KWin::Scene::finalPaintScreen (this=0x971ed20, mask=544, region=..., data=...) at ../../kwin/scene.cpp:196
#20 0xb771e9c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x9988d08, mask=544, region=..., data=...) at ../../kwin/effects.cpp:222
#21 0xb693953a in KWin::Effect::paintScreen (this=0x9a45420, mask=544, region=..., data=...) at ../../../kwin/libkwineffects/kwineffects.cpp:142
#22 0xb771e970 in KWin::EffectsHandlerImpl::paintScreen (this=0x9988d08, mask=544, region=..., data=...) at ../../kwin/effects.cpp:219
#23 0xad01ffe8 in KWin::PresentWindowsEffect::paintScreen (this=0x9a80a70, mask=544, region=..., data=...) at ../../../kwin/effects/presentwindows/presentwindows.cpp:216
#24 0xb771e970 in KWin::EffectsHandlerImpl::paintScreen (this=0x9988d08, mask=544, region=..., data=...) at ../../kwin/effects.cpp:219
#25 0xb693953a in KWin::Effect::paintScreen (this=0x9a28d90, mask=544, region=..., data=...) at ../../../kwin/libkwineffects/kwineffects.cpp:142
#26 0xb771e970 in KWin::EffectsHandlerImpl::paintScreen (this=0x9988d08, mask=544, region=..., data=...) at ../../kwin/effects.cpp:219
#27 0xb693953a in KWin::Effect::paintScreen (this=0x9bace88, mask=544, region=..., data=...) at ../../../kwin/libkwineffects/kwineffects.cpp:142
#28 0xb771e970 in KWin::EffectsHandlerImpl::paintScreen (this=0x9988d08, mask=544, region=..., data=...) at ../../kwin/effects.cpp:219
#29 0xb693953a in KWin::Effect::paintScreen (this=0x9a29148, mask=544, region=..., data=...) at ../../../kwin/libkwineffects/kwineffects.cpp:142
#30 0xb771e970 in KWin::EffectsHandlerImpl::paintScreen (this=0x9988d08, mask=544, region=..., data=...) at ../../kwin/effects.cpp:219
#31 0xb76f93cf in KWin::Scene::paintScreen (this=0x971ed20, mask=0xbfa0cd04, region=0xbfa0cd90) at ../../kwin/scene.cpp:156
#32 0xb7711b69 in KWin::SceneOpenGL::paint (this=0x971ed20, damage=..., toplevels=...) at ../../kwin/scene_opengl_glx.cpp:459
#33 0xb76f29db in KWin::Workspace::performCompositing (this=0x96bca60) at ../../kwin/composite.cpp:412
#34 0xb5fd0ac4 in QObject::event (this=0x96bca60, e=0xbfa0d27c) at kernel/qobject.cpp:1157
#35 0xb549fed4 in notify_helper (e=0xbfa0d27c, receiver=0x96bca60, this=0x959eda0) at kernel/qapplication.cpp:4559
#36 QApplicationPrivate::notify_helper (this=0x959eda0, receiver=0x96bca60, e=0xbfa0d27c) at kernel/qapplication.cpp:4531
#37 0xb54a530d in QApplication::notify (this=0xbfa0d27c, receiver=0x96bca60, e=0xbfa0d27c) at kernel/qapplication.cpp:4288
#38 0xb7235401 in KApplication::notify (this=0xbfa0d588, receiver=0x96bca60, event=0xbfa0d27c) at ../../kdeui/kernel/kapplication.cpp:311
#39 0xb769b7ff in notify (e=0xbfa0d27c, o=0x96bca60, this=0xbfa0d588) at ../../kwin/main.cpp:368
#40 KWin::Application::notify (this=0xbfa0d588, o=0x96bca60, e=0xbfa0d27c) at ../../kwin/main.cpp:364
#41 0xb5fb597e in QCoreApplication::notifyInternal (this=0xbfa0d588, receiver=0x96bca60, event=0xbfa0d27c) at kernel/qcoreapplication.cpp:876
#42 0xb5fea990 in sendEvent (event=0xbfa0d27c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#43 QTimerInfoList::activateTimers (this=0x959f684) at kernel/qeventdispatcher_unix.cpp:611
#44 0xb5feb207 in QEventDispatcherUNIX::processEvents (this=0x9554ea0, flags=...) at kernel/qeventdispatcher_unix.cpp:930
#45 0xb5559b6e in QEventDispatcherX11::processEvents (this=0x9554ea0, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#46 0xb5fb450d in QEventLoop::processEvents (this=0xbfa0d4c4, flags=...) at kernel/qeventloop.cpp:149
#47 0xb5fb47a9 in QEventLoop::exec (this=0xbfa0d4c4, flags=...) at kernel/qeventloop.cpp:204
#48 0xb5fb9eba in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#49 0xb549da74 in QApplication::exec () at kernel/qapplication.cpp:3820
#50 0xb769e7c5 in kdemain (argc=3, argv=0xbfa0d834) at ../../kwin/main.cpp:541
#51 0x0804850b in main (argc=3, argv=0xbfa0d834) at kwin_dummy.cpp:3

Possible duplicates by query: bug 303041, bug 302764, bug 302169, bug 301529, bug 301403.

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2012-07-23 14:40:31 UTC
driver bug

run "kcmshell4 kwincompositing", enter the third tab ("advanced") and uncheck "suspend compositing for fullscreen windows"

*** This bug has been marked as a duplicate of bug 252817 ***