Bug 303697

Summary: Crash when trying to see e-mail (old one).
Product: [Applications] kontact Reporter: pmanousis <pmanousis>
Component: mailAssignee: kdepim bugs <kdepim-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: OpenSUSE   
OS: Linux   
Latest Commit: Version Fixed In:

Description pmanousis 2012-07-17 18:11:10 UTC
While trying to see an e-mail I sent using another computer earlier, kmail segfaulted and kontact stoped.

Reproducible: Didn't try




Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f842d2b0760 (LWP 3814))]

Thread 3 (Thread 0x7f84143cb700 (LWP 3845)):
#0  0x00007f8425142e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f8429ad7c12 in WTF::TCMalloc_PageHeap::scavengerThread (this=0x7f842a4761a0) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:2495
#2  0x00007f8429ad7c49 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:1618
#3  0x00007f842513ef05 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f842a7c910d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f8413aca700 (LWP 3848)):
#0  0x00007fffc0f7298f in clock_gettime ()
#1  0x00007f8422c1ad9a in clock_gettime () from /lib64/librt.so.1
#2  0x00007f842ae61014 in do_gettime (frac=0x7f8413ac9bf8, sec=0x7f8413ac9bf0) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007f842af3859d in QTimerInfoList::updateCurrentTime (this=0x7f840c0020d0) at kernel/qeventdispatcher_unix.cpp:343
#5  0x00007f842af38251 in timerSourceCheckHelper (src=<optimized out>) at kernel/qeventdispatcher_glib.cpp:150
#6  timerSourceCheckHelper (src=<optimized out>) at kernel/qeventdispatcher_glib.cpp:144
#7  0x00007f8424c2f264 in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#8  0x00007f8424c2fab2 in ?? () from /usr/lib64/libglib-2.0.so.0
#9  0x00007f8424c2ff59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#10 0x00007f842af37e36 in QEventDispatcherGlib::processEvents (this=0x7f840c0008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#11 0x00007f842af07842 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#12 0x00007f842af07a97 in QEventLoop::exec (this=0x7f8413ac9e20, flags=...) at kernel/qeventloop.cpp:204
#13 0x00007f842ae075f7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#14 0x00007f842ae0a61b in QThreadPrivate::start (arg=0x7c6550) at thread/qthread_unix.cpp:307
#15 0x00007f842513ef05 in start_thread () from /lib64/libpthread.so.0
#16 0x00007f842a7c910d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f842d2b0760 (LWP 3814)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x3735880, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:828
#7  0x00007f842610b509 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x3735880, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007f842af21e06 in QObject::event (this=0x3735880, e=<optimized out>) at kernel/qobject.cpp:1204
#9  0x00007f842b921fe4 in notify_helper (e=0x7f83a8007240, receiver=0x3735880, this=0x63bc10) at kernel/qapplication.cpp:4551
#10 QApplicationPrivate::notify_helper (this=0x63bc10, receiver=0x3735880, e=0x7f83a8007240) at kernel/qapplication.cpp:4523
#11 0x00007f842b926db3 in QApplication::notify (this=0x7fffc0f3cb20, receiver=0x3735880, e=0x7f83a8007240) at kernel/qapplication.cpp:4412
#12 0x00007f842c668746 in KApplication::notify (this=0x7fffc0f3cb20, receiver=0x3735880, event=0x7f83a8007240) at /usr/src/debug/kdelibs-4.8.4/kdeui/kernel/kapplication.cpp:311
#13 0x00007f842af08d0c in QCoreApplication::notifyInternal (this=0x7fffc0f3cb20, receiver=0x3735880, event=0x7f83a8007240) at kernel/qcoreapplication.cpp:915
#14 0x00007f842af0c5ba in sendEvent (event=0x7f83a8007240, receiver=0x3735880) at kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x60dc00) at kernel/qcoreapplication.cpp:1539
#16 0x00007f842af379a3 in sendPostedEvents () at kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=0x640cf0) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00007f8424c2f58d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#19 0x00007f8424c2fd88 in ?? () from /usr/lib64/libglib-2.0.so.0
#20 0x00007f8424c2ff59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#21 0x00007f842af37dcf in QEventDispatcherGlib::processEvents (this=0x60d4c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#22 0x00007f842b9c569e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007f842af07842 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007f842af07a97 in QEventLoop::exec (this=0x7fffc0f3cab0, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007f842af0c8b5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#26 0x0000000000403919 in ?? ()
#27 0x00007f842a70f23d in __libc_start_main () from /lib64/libc.so.6
#28 0x0000000000403e51 in _start ()
Comment 1 Jekyll Wu 2012-07-17 19:32:20 UTC

*** This bug has been marked as a duplicate of bug 286307 ***