Bug 299731

Summary: crash on selecting a mail (attempt to view the mail)
Product: [Applications] kmail2 Reporter: Foli Ayivoh <101551.753>
Component: commands and actionsAssignee: kdepim bugs <kdepim-bugs>
Status: RESOLVED DUPLICATE    
Severity: major CC: montel
Priority: NOR    
Version: 4.8.3   
Target Milestone: ---   
Platform: OpenSUSE   
OS: Linux   
Latest Commit: Version Fixed In:

Description Foli Ayivoh 2012-05-10 10:19:30 UTC
-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f4296800780 (LWP 10278))]

Thread 3 (Thread 0x7f4278250700 (LWP 10283)):
#0  0x00007f429194ae6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f4287ff9c12 in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x00007f4287ff9c49 in ?? () from /usr/lib64/libQtWebKit.so.4
#3  0x00007f4291946f05 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f4293b3a10d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f4277947700 (LWP 10284)):
#0  0x00007fffc09ff8de in ?? ()
#1  0x00007f428bfc8d9a in clock_gettime () from /lib64/librt.so.1
#2  0x00007f42950c0f64 in do_gettime (frac=0x7f4277946bd8, sec=0x7f4277946bd0) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007f4295197a4d in QTimerInfoList::updateCurrentTime (this=0x7f42700020d0) at kernel/qeventdispatcher_unix.cpp:343
#5  0x00007f4295197701 in timerSourceCheckHelper (src=<optimized out>) at kernel/qeventdispatcher_glib.cpp:150
#6  timerSourceCheckHelper (src=<optimized out>) at kernel/qeventdispatcher_glib.cpp:144
#7  0x00007f428bd14264 in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#8  0x00007f428bd14ab2 in ?? () from /usr/lib64/libglib-2.0.so.0
#9  0x00007f428bd14f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#10 0x00007f42951972e6 in QEventDispatcherGlib::processEvents (this=0x7f42700008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#11 0x00007f4295167012 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#12 0x00007f4295167267 in QEventLoop::exec (this=0x7f4277946e00, flags=...) at kernel/qeventloop.cpp:204
#13 0x00007f4295067547 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#14 0x00007f429506a56b in QThreadPrivate::start (arg=0xc27210) at thread/qthread_unix.cpp:298
#15 0x00007f4291946f05 in start_thread () from /lib64/libpthread.so.0
#16 0x00007f4293b3a10d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f4296800780 (LWP 10278)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x23bd8d0, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007f4292b8f909 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x23bd8d0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007f42951812b6 in QObject::event (this=0x23bd8d0, e=<optimized out>) at kernel/qobject.cpp:1204
#9  0x00007f42944ed0d4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#10 0x00007f42944f1f53 in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#11 0x00007f42962178f6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#12 0x00007f429516822c in QCoreApplication::notifyInternal (this=0x7fffc0923280, receiver=0x23bd8d0, event=0x7f421c00c610) at kernel/qcoreapplication.cpp:876
#13 0x00007f429516baca in sendEvent (event=0x7f421c00c610, receiver=0x23bd8d0) at kernel/qcoreapplication.h:231
#14 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x60b720) at kernel/qcoreapplication.cpp:1500
#15 0x00007f4295196e53 in sendPostedEvents () at kernel/qcoreapplication.h:236
#16 postEventSourceDispatch (s=0x65ba30) at kernel/qeventdispatcher_glib.cpp:279
#17 0x00007f428bd1458d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#18 0x00007f428bd14d88 in ?? () from /usr/lib64/libglib-2.0.so.0
#19 0x00007f428bd14f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#20 0x00007f429519727f in QEventDispatcherGlib::processEvents (this=0x60b000, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#21 0x00007f429459076e in ?? () from /usr/lib64/libQtGui.so.4
#22 0x00007f4295167012 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#23 0x00007f4295167267 in QEventLoop::exec (this=0x7fffc0923160, flags=...) at kernel/qeventloop.cpp:204
#24 0x00007f429516bdc5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#25 0x0000000000402df3 in main (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/kdepim-4.8.3/kmail/main.cpp:145

Reproducible: Sometimes

Steps to Reproduce:
1. selecting a mail in the inbox-folder
2. selecting another mail in another inbox-subfolder
3.then crash when selecting the same mail in the inbox-folder again



Application: kmail (4.8.3)
KDE Platform Version: 4.8.3 (4.8.3) "release 503"
Qt Version: 4.8.1
Operating System: Linux 3.1.10-1.9-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
<Erklären Sie bitte ganz genau, was Sie machten, als das Programm abstürzte.>

The crash can be reproduced some of the time.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f4296800780 (LWP 10278))]

Thread 3 (Thread 0x7f4278250700 (LWP 10283)):
#0  0x00007f429194ae6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f4287ff9c12 in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x00007f4287ff9c49 in ?? () from /usr/lib64/libQtWebKit.so.4
#3  0x00007f4291946f05 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f4293b3a10d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f4277947700 (LWP 10284)):
#0  0x00007fffc09ff8de in ?? ()
#1  0x00007f428bfc8d9a in clock_gettime () from /lib64/librt.so.1
#2  0x00007f42950c0f64 in do_gettime (frac=0x7f4277946bd8, sec=0x7f4277946bd0) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007f4295197a4d in QTimerInfoList::updateCurrentTime (this=0x7f42700020d0) at kernel/qeventdispatcher_unix.cpp:343
#5  0x00007f4295197701 in timerSourceCheckHelper (src=<optimized out>) at kernel/qeventdispatcher_glib.cpp:150
#6  timerSourceCheckHelper (src=<optimized out>) at kernel/qeventdispatcher_glib.cpp:144
#7  0x00007f428bd14264 in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#8  0x00007f428bd14ab2 in ?? () from /usr/lib64/libglib-2.0.so.0
#9  0x00007f428bd14f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#10 0x00007f42951972e6 in QEventDispatcherGlib::processEvents (this=0x7f42700008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#11 0x00007f4295167012 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#12 0x00007f4295167267 in QEventLoop::exec (this=0x7f4277946e00, flags=...) at kernel/qeventloop.cpp:204
#13 0x00007f4295067547 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#14 0x00007f429506a56b in QThreadPrivate::start (arg=0xc27210) at thread/qthread_unix.cpp:298
#15 0x00007f4291946f05 in start_thread () from /lib64/libpthread.so.0
#16 0x00007f4293b3a10d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f4296800780 (LWP 10278)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x23bd8d0, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007f4292b8f909 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x23bd8d0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007f42951812b6 in QObject::event (this=0x23bd8d0, e=<optimized out>) at kernel/qobject.cpp:1204
#9  0x00007f42944ed0d4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#10 0x00007f42944f1f53 in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#11 0x00007f42962178f6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#12 0x00007f429516822c in QCoreApplication::notifyInternal (this=0x7fffc0923280, receiver=0x23bd8d0, event=0x7f421c00c610) at kernel/qcoreapplication.cpp:876
#13 0x00007f429516baca in sendEvent (event=0x7f421c00c610, receiver=0x23bd8d0) at kernel/qcoreapplication.h:231
#14 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x60b720) at kernel/qcoreapplication.cpp:1500
#15 0x00007f4295196e53 in sendPostedEvents () at kernel/qcoreapplication.h:236
#16 postEventSourceDispatch (s=0x65ba30) at kernel/qeventdispatcher_glib.cpp:279
#17 0x00007f428bd1458d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#18 0x00007f428bd14d88 in ?? () from /usr/lib64/libglib-2.0.so.0
#19 0x00007f428bd14f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#20 0x00007f429519727f in QEventDispatcherGlib::processEvents (this=0x60b000, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#21 0x00007f429459076e in ?? () from /usr/lib64/libQtGui.so.4
#22 0x00007f4295167012 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#23 0x00007f4295167267 in QEventLoop::exec (this=0x7fffc0923160, flags=...) at kernel/qeventloop.cpp:204
#24 0x00007f429516bdc5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#25 0x0000000000402df3 in main (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/kdepim-4.8.3/kmail/main.cpp:145
Comment 1 Laurent Montel 2012-05-10 15:52:50 UTC

*** This bug has been marked as a duplicate of bug 286307 ***