Bug 298556

Summary: entering a directory causes a click blocking
Product: [Applications] dolphin Reporter: Ted <ted->
Component: view-engine: generalAssignee: Dolphin Bug Assignee <dolphin-bugs-null>
Status: RESOLVED WORKSFORME    
Severity: normal CC: nate, teod0r
Priority: NOR Keywords: usability
Version: 2.0   
Target Milestone: ---   
Platform: Fedora RPMs   
OS: Linux   
Latest Commit: Version Fixed In:

Description Ted 2012-04-21 15:31:32 UTC
when you enter a directory with mouse click (I use single-click mode), clicking on any file under the cursor does nothing diring a couple of seconds. To reproduce this,  second file you click (file or folder which you see under the cursor after entering a folder) must be in the same position from top as the folder you've just entered (for example you enter a directory wich is first in list and you want to enter another directory that is in the first line in the curent directory)  and don't move your mouse - just click second time on a file!

Reproducible: Always

Steps to Reproduce:
1.open a directory with mouse-click (directory must contain a file in the same coordinates with the place you've just clicked)
2.click on that file under the cursor without shifting the cursor
Actual Results:  
the file wouldnt be clicked!

Expected Results:  
file must be opened immediately

happens in 4.8.2 and in erlier versions (4.4.5)
Comment 1 Peter Penz 2012-04-21 17:12:07 UTC
Thanks for the report, but I cannot reproduce the issue with the 2 steps mentioned above. Do you probably have further information how to reproduce this issue?
Comment 2 Ted 2012-04-21 19:33:40 UTC
don't move the mouse after the first click and then quiqly make the second click
Comment 3 Ted 2012-04-21 19:43:30 UTC
also there is another bug: a blind spot (1 pixel width) between file's icon and file's name (4.8.2) but on another machine (4.4.5) there is no such bug
Comment 4 Peter Penz 2012-04-21 19:50:42 UTC
Thanks for the hint - the next click must be inside the double-click timeout. If you speak from several seconds it might be that you use an extremely long duration for the double-click. But of course this should be fixed...
Comment 5 Ted 2012-04-25 19:30:42 UTC
could it be somthing not just only in dolphin? working in my old 4.4.5 I sometimes have a feeling  that there is some kind of a same thing in othe applicatiions: when starting gtk version of firefox - firefox changes it's position from maximizet to minimized; clicking on "application launcher" on default_bar always waits for some period to second click; "show desktop" widjet in the corner of a screen shizoidly repeats always [ in 4.8.2 TOO!!!!!  (  ]. maybe it something with kwin? render or somrthing?
Comment 6 Jeroen van Meeuwen (Kolab Systems) 2012-08-24 16:19:57 UTC
Resetting assignee to default as per bug #305719
Comment 7 Frank Reininghaus 2013-10-02 23:51:06 UTC
@Ted: can you confirm Peter's assumption that the cause of the problem is that you have configured an extremely long double-click delay in the System Settings?
Comment 8 Teodor 2013-10-03 08:14:58 UTC
(In reply to comment #7)
> @Ted: can you confirm Peter's assumption that the cause of the problem is
> that you have configured an extremely long double-click delay in the System
> Settings?

Most likely yes, but not an extremely long, I've set zero seconds
Comment 9 Nate Graham 2017-09-04 01:37:51 UTC
I can reproduce, but when I set the double-click interval to 100ms, the issue disappears; it's practically impossible to click faster than that when the content is changing and your eye needs to scan what it is.