Bug 295446

Summary: rekonq doesn't scale flash on zooming websites with embedded video
Product: rekonq Reporter: piedro <piedro.kulman>
Component: generalAssignee: Andrea Diamantini <adjam7>
Status: RESOLVED UPSTREAM    
Severity: normal CC: benoit.leffray.kde, piedro.kulman
Priority: NOR Keywords: investigated, triaged
Version: unspecified   
Target Milestone: 0.10   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:

Description piedro 2012-03-07 02:13:35 UTC
When using rekonq (any version up till now) on sites like youtube that use embeded flash videos flash doen't scale with the rest of the content when using the zoom function. I am a bit handicapped with my eyex so I always press "CTRL +" two or three times to zoom or scale a site to the right font size so my eyes can handle it. This works fine with rekonq but the flash video doesn't scale at all. The area it is placed scales but the video stays small clinging to the top left corner to that area. 

It works correctly in midori (obviously in firefox and chromium). 

thx for reading, piedro
Comment 1 Andrea Diamantini 2012-03-07 23:08:41 UTC
Targetting 0.10. Let see if we can fix this for one of the 0.9.x stable releases...
Comment 2 piedro 2012-04-03 15:19:51 UTC
That would be so much appreciated! 

Maybe I am the only one, but I don't like the firefox integration into KDE too much and Chromium doesn't care (for about 5 years) now to fix the fonts of the UI (those are hardcoded). I have a lot of hope for Rekonq as I am visually impaired and look for optimal integration into KDE with it's high degree of individual customization of UI qualities ... 

great works so far devs! thx and thumbs up! 

piedro
Comment 3 Andrea Diamantini 2012-06-19 15:47:24 UTC
Git commit 85205e6368da2ee46cfe46b64f71a5c6beecab80 by Andrea Diamantini.
Committed on 19/06/2012 at 17:37.
Pushed by adjam into branch 'master'.

Fix and improve save zoom feature, loading it on start

This seems to work also with problem described in bug #295446
Related: bug 277599, bug 296447

M  +9    -8    src/webpage.cpp

http://commits.kde.org/rekonq/85205e6368da2ee46cfe46b64f71a5c6beecab80
Comment 4 piedro 2012-07-25 10:20:52 UTC
Now I use version 0.9.2 and it still doesn't scale correctly. The viideo scales up but when scaling the page down the area for the video scales down but the video doesn't. Resulting in a cropped video. 

thx for reading, 
piedro
Comment 5 Andrea Diamantini 2012-07-25 14:36:32 UTC
hi Piedro,
the related fix is in 1.0 branch. You should try it and post here again your results, please.
Comment 6 Andrea Diamantini 2012-09-18 19:30:47 UTC
Needs testing from the reporter against rekonq 1.x
Comment 7 piedro 2012-09-18 22:26:57 UTC
how? I don't get the 1.0 branch yet ... or is it in the kubuntu beta for 12.10 ... then I could give it a shot, but I am afraid to break things here - this is my everyday work and production machine. 

Do you have a ppa or deb-file somewhere so I could go for testing? 

thx, piedro
Comment 8 piedro 2013-01-22 00:42:57 UTC
I am using Rekonq 2.0 now - it's still the same, when I hit CTRL++ the movie on youtube doesn't scale, the black area reserved for the video does scale but not the video itself ... 

BTW: Now I also have the problem that the colors blue and red are swapped! 

For me rekonq is still unusable ... 

thx for reading, 
piedro
Comment 9 piedro 2013-01-31 18:08:59 UTC
I treid again with the brandnew version 2.1 on KDE 4.9.98: 

Still the same behaviour. This seems to be a basic feature - what use is a browser that doesn't work correctly on youtube (it's like a car that can't be used in the city ....) 

Disappointed, 
piedro
Comment 10 Andrea Diamantini 2013-01-31 18:26:30 UTC
Hi Piedro, I understand your disappointment. Unfortunately my previous attempt is the best I can do from rekonq side. This problem is 100% (qt)webkit related. Please, try reporting this here: http://webkit.org/new-qtwebkit-bug.

PS: in my town, not all the cars can go inside the city centre. But this limitation does not depend on the car, but on the engine they have.
Comment 11 piedro 2013-02-07 19:00:04 UTC
Hi Andreas! 

When I use Midori (which is also webkit based) I have to change "zoom pictures and text" in the settings and any Youtube video scales correctly. the blue tint though is still present. 

I will check in to the webkit bugs but Idon'T gete why it works on some webkit browsers and not in Rekonq ... btw in a forum post here http://forum.kde.org/viewtopic.php?f=18&t=97437 someone said that this behaviour disappeared in KDE 4.10. Unfortunately I cannot confirm this. 

thx for your efforts, 
piedro
Comment 12 Andrea Diamantini 2013-02-12 15:11:58 UTC
Git commit 40a4a3a90d6fdd8c0805d3491b8437c6b8e9d2f7 by Andrea Diamantini.
Committed on 12/02/2013 at 16:09.
Pushed by adjam into branch 'master'.

Add zoom text only webkit feature settings

Piedro, because of your comment about Midori, I tried applying this.
I don't think this fixes your problem, but it surely "hides" the
bug ;)

M  +1    -0    src/application.cpp
M  +3    -0    src/rekonq.kcfg
M  +7    -0    src/settings/settings_webkit.ui

http://commits.kde.org/rekonq/40a4a3a90d6fdd8c0805d3491b8437c6b8e9d2f7
Comment 13 piedro 2013-04-05 18:09:31 UTC
thx, 
sry for not commenting back, somehow the subscription failed ... 

As of now I am testing 2.2.1 and still have the same issues ... 
(sry Andrea) 

thx for your efforts, 
piedro
Comment 14 piedro 2013-04-05 18:14:44 UTC
though I can (as you mentioned) now set the Webkit engine to "only scale text" ... 

thx, p.
Comment 15 Benoit Leffray 2013-11-06 21:34:57 UTC
Hi guys, I've been seing this problem for a very long time. I do reproduce this issue every time I want to watch a video on the CNN site.

My system : Kubuntu 13.10 + KDE 4.11.2 on AMD64 processor.

You can try the following link and reproduce the problem systematically:
http://edition.cnn.com/video/data/2.0/video/world/2013/11/04/vo-animation-17th-century-london.cnn.html

Regards,

BenoƮt
Comment 16 piedro 2016-10-24 17:53:22 UTC
I think rekonq is a dead project. 

So maybe another browser has to be the solution, 
p.
Comment 17 Andrew Crouthamel 2018-09-19 14:32:13 UTC
This bug has had its resolution changed, but accidentally has been left in NEEDSINFO status. I am thus closing this bug and setting the status as RESOLVED to reflect the resolution change.