Bug 294227

Summary: Screen preferences
Product: systemsettings Reporter: cristof1913
Component: generalAssignee: System Settings Bugs <sourtooth+ssbugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: adaptee
Priority: NOR    
Version: 1.0   
Target Milestone: ---   
Platform: openSUSE RPMs   
OS: Linux   
Latest Commit: Version Fixed In:

Description cristof1913 2012-02-16 11:47:11 UTC
Application: systemsettings (1.0)
KDE Platform Version: 4.7.2 (4.7.2) "release 5"
Qt Version: 4.7.4
Operating System: Linux 3.1.9-1.4-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

When I change in Screen preferences to any category the application fails

The crash can be reproduced every time.

-- Backtrace:
Application: Preferencias del sistema (systemsettings), signal: Segmentation fault
[KCrash Handler]
#6  0x00007f92b5ac3a94 in QAbstractButton::isChecked (this=0xaa2d40) at widgets/qabstractbutton.cpp:772
#7  0x00007f92a357a93d in ?? () from /usr/lib64/kde4/kcm_kgamma.so
#8  0x00007f92b64bacf1 in KCModule::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib64/libkdeui.so.5
#9  0x00007f92a357d770 in ?? () from /usr/lib64/kde4/kcm_kgamma.so
#10 0x00007f92b4ad115a in QObject::event (this=0xaf30e0, e=<optimized out>) at kernel/qobject.cpp:1226
#11 0x00007f92b5760d4b in QWidget::event (this=0xaf30e0, event=0x98b060) at kernel/qwidget.cpp:8754
#12 0x00007f92b5710c34 in notify_helper (e=0x98b060, receiver=0xaf30e0, this=0x64b360) at kernel/qapplication.cpp:4481
#13 QApplicationPrivate::notify_helper (this=0x64b360, receiver=0xaf30e0, e=0x98b060) at kernel/qapplication.cpp:4453
#14 0x00007f92b5715ac1 in QApplication::notify (this=0x7fffe6b7f070, receiver=0xaf30e0, e=0x98b060) at kernel/qapplication.cpp:4360
#15 0x00007f92b6423e36 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#16 0x00007f92b4aba82c in QCoreApplication::notifyInternal (this=0x7fffe6b7f070, receiver=0xaf30e0, event=0x98b060) at kernel/qcoreapplication.cpp:787
#17 0x00007f92b4abdc08 in sendEvent (event=0x98b060, receiver=0xaf30e0) at kernel/qcoreapplication.h:215
#18 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x61ec80) at kernel/qcoreapplication.cpp:1428
#19 0x00007f92b4ae50c3 in sendPostedEvents () at kernel/qcoreapplication.h:220
#20 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#21 0x00007f92b1a6858d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#22 0x00007f92b1a68d88 in ?? () from /usr/lib64/libglib-2.0.so.0
#23 0x00007f92b1a68f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#24 0x00007f92b4ae551f in QEventDispatcherGlib::processEvents (this=0x61e490, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#25 0x00007f92b57b3f9e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#26 0x00007f92b4ab9a32 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#27 0x00007f92b4ab9c2f in QEventLoop::exec (this=0x7fffe6b7f000, flags=...) at kernel/qeventloop.cpp:201
#28 0x00007f92b4abddf7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#29 0x000000000040b235 in ?? ()
#30 0x00007f92b42e123d in __libc_start_main () from /lib64/libc.so.6
#31 0x000000000040b289 in _start ()

Possible duplicates by query: bug 292335.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-16 11:49:18 UTC

*** This bug has been marked as a duplicate of bug 292335 ***