Bug 292944

Summary: KWin crashes while switching desktop
Product: [Plasma] kwin Reporter: Leonardo Giordani <giordani.leonardo>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:

Description Leonardo Giordani 2012-01-31 10:19:53 UTC
Application: kwin (4.8.00 (4.8.0)
KDE Platform Version: 4.8.00 (4.8.0
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic-pae i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
KWin keeps crashing when I switch desktop; I switch dektop with mouse wheel on the background.

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0xb1ee9720 (LWP 1872))]

Thread 3 (Thread 0xaf202b70 (LWP 1876)):
#0  0xb2df4d10 in __GI_clock_gettime (clock_id=1, tp=0xaf202138) at ../sysdeps/unix/clock_gettime.c:116
#1  0xb5f9d7d5 in do_gettime (frac=0xaf202130, sec=0xaf202128) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb60704b6 in QTimerInfoList::updateCurrentTime (this=0x8fd99f8) at kernel/qeventdispatcher_unix.cpp:339
#4  0xb607080a in QTimerInfoList::timerWait (this=0x8fd99f8, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb60724de in QEventDispatcherUNIX::processEvents (this=0x8f9d898, flags=...) at kernel/qeventdispatcher_unix.cpp:905
#6  0xb60401dd in QEventLoop::processEvents (this=0xaf2022a0, flags=...) at kernel/qeventloop.cpp:149
#7  0xb6040421 in QEventLoop::exec (this=0xaf2022a0, flags=...) at kernel/qeventloop.cpp:201
#8  0xb5f4390b in QThread::exec (this=0x8fd6ee8) at thread/qthread.cpp:498
#9  0xb6020e2d in QInotifyFileSystemWatcherEngine::run (this=0x8fd6ee8) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb5f467b3 in QThreadPrivate::start (arg=0x8fd6ee8) at thread/qthread_unix.cpp:331
#11 0xb2dadd31 in start_thread (arg=0xaf202b70) at pthread_create.c:304
#12 0xb758c0ce in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 2 (Thread 0xaea01b70 (LWP 1891)):
#0  0xb77a7424 in __kernel_vsyscall ()
#1  0xb2db1a5c in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:169
#2  0xb7599cfc in __pthread_cond_wait (cond=0xb67eba50, mutex=0xb67eba38) at forward.c:139
#3  0xb66e69a9 in ?? () from /usr/lib/i386-linux-gnu/libQtScript.so.4
#4  0xb66e69ef in ?? () from /usr/lib/i386-linux-gnu/libQtScript.so.4
#5  0xb2dadd31 in start_thread (arg=0xaea01b70) at pthread_create.c:304
#6  0xb758c0ce in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb1ee9720 (LWP 1872)):
[KCrash Handler]
#7  0xb56561f5 in QPixmap::paintEngine (this=0xbfead89c) at image/qpixmap.cpp:1925
#8  0xb774f817 in KWin::TabBox::ImageProvider::requestPixmap (this=0x91d0480, id=..., size=0xbfead9f8, requestedSize=...) at ../../kwin/tabbox/declarative.cpp:79
#9  0xb6b9b0d3 in QDeclarativeEnginePrivate::getPixmapFromProvider (this=0x91a4ad0, url=..., size=0xbfead9f8, req_size=...) at qml/qdeclarativeengine.cpp:837
#10 0xb6ad6e10 in createPixmapDataSync (ok=<optimized out>, requestSize=<optimized out>, url=<optimized out>, engine=<optimized out>) at util/qdeclarativepixmapcache.cpp:802
#11 QDeclarativePixmap::load (this=0x92836a8, engine=0x9180128, url=..., requestSize=..., options=...) at util/qdeclarativepixmapcache.cpp:1003
#12 0xb6b23b06 in QDeclarativeImageBase::load (this=0x92834e0) at graphicsitems/qdeclarativeimagebase.cpp:205
#13 0xb6b236e0 in QDeclarativeImageBase::setSource (this=0x92834e0, url=...) at graphicsitems/qdeclarativeimagebase.cpp:111
#14 0xb6c98a46 in QDeclarativeImageBase::qt_metacall (this=0x92834e0, _c=QMetaObject::WriteProperty, _id=1, _a=0xbfeadc34) at .moc/release-shared/moc_qdeclarativeimagebase_p.cpp:170
#15 0xb6c983f2 in QDeclarativeImage::qt_metacall (this=0x92834e0, _c=QMetaObject::WriteProperty, _id=44, _a=0xbfeadc34) at .moc/release-shared/moc_qdeclarativeimage_p.cpp:94
#16 0xb6047b7d in metacall (argv=0xbfeadc34, idx=44, cl=QMetaObject::WriteProperty, object=0x92834e0) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x92834e0, cl=QMetaObject::WriteProperty, idx=44, argv=0xbfeadc34) at kernel/qmetaobject.cpp:232
#18 0xb6babc7c in QDeclarativePropertyPrivate::write (object=0x92834e0, property=..., value=..., context=0x92021e0, flags=...) at qml/qdeclarativeproperty.cpp:1139
#19 0xb6bac513 in QDeclarativePropertyPrivate::writeValueProperty (this=0x9283760, value=..., flags=...) at qml/qdeclarativeproperty.cpp:1085
#20 0xb6bac621 in QDeclarativePropertyPrivate::write (that=..., value=..., flags=...) at qml/qdeclarativeproperty.cpp:1340
#21 0xb6ba59bb in QDeclarativeBinding::update (this=0x92837b8, flags=...) at qml/qdeclarativebinding.cpp:422
#22 0xb6ba4674 in update (this=<optimized out>) at ../../include/QtDeclarative/private/../../../src/declarative/qml/qdeclarativebinding_p.h:177
#23 QDeclarativeBindingPrivate::emitValueChanged (this=0x92837e8) at qml/qdeclarativebinding.cpp:464
#24 0xb6ba3604 in _q_notify (this=<optimized out>) at qml/qdeclarativeexpression.cpp:800
#25 QDeclarativeExpression::qt_metacall (this=0x92837b8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfeadff4) at .moc/release-shared/moc_qdeclarativeexpression.cpp:77
#26 0xb6ca8b2e in QDeclarativeBinding::qt_metacall (this=0x92837b8, _c=QMetaObject::InvokeMetaMethod, _id=5, _a=0xbfeadff4) at .moc/release-shared/moc_qdeclarativebinding_p.cpp:69
#27 0xb6047b7d in metacall (argv=0xbfeadff4, idx=5, cl=QMetaObject::InvokeMetaMethod, object=0x92837b8) at kernel/qmetaobject.cpp:237
#28 QMetaObject::metacall (object=0x92837b8, cl=QMetaObject::InvokeMetaMethod, idx=5, argv=0xbfeadff4) at kernel/qmetaobject.cpp:232
#29 0xb6056a6a in QMetaObject::activate (sender=0x91fff48, m=0xb6d7ae68, local_signal_index=4, argv=0x0) at kernel/qobject.cpp:3278
#30 0xb6ca5dc5 in QDeclarativeListView::currentIndexChanged (this=0x91fff48) at .moc/release-shared/moc_qdeclarativelistview_p.cpp:599
#31 0xb6b764fb in QDeclarativeListViewPrivate::updateCurrent (this=0x91fe410, modelIndex=0) at graphicsitems/qdeclarativelistview.cpp:1181
#32 0xb6ca6a71 in QDeclarativeListView::qt_metacall (this=0x91fff48, _c=QMetaObject::WriteProperty, _id=2, _a=0xbfeae23c) at .moc/release-shared/moc_qdeclarativelistview_p.cpp:531
#33 0xb6b8dd21 in QDeclarativeVMEMetaObject::metaCall (this=0x9282ec8, c=QMetaObject::WriteProperty, _id=69, a=0xbfeae23c) at qml/qdeclarativevmemetaobject.cpp:673
#34 0xb6047b7d in metacall (argv=0xbfeae23c, idx=69, cl=QMetaObject::WriteProperty, object=0x91fff48) at kernel/qmetaobject.cpp:237
#35 QMetaObject::metacall (object=0x91fff48, cl=QMetaObject::WriteProperty, idx=69, argv=0xbfeae23c) at kernel/qmetaobject.cpp:232
#36 0xb604af03 in QMetaProperty::write (this=0x2, object=0x91fff48, value=...) at kernel/qmetaobject.cpp:2312
#37 0xb605a6fa in QObject::setProperty (this=0x91fff48, name=0xb7779b8d "currentIndex", value=...) at kernel/qobject.cpp:3434
#38 0xb774e556 in KWin::TabBox::DeclarativeView::setCurrentIndex (this=0x8fe44d0, index=...) at ../../kwin/tabbox/declarative.cpp:180
#39 0xb775617e in KWin::TabBox::TabBoxHandler::setCurrentIndex (this=0x8fab718, index=...) at ../../kwin/tabbox/tabboxhandler.cpp:544
#40 0xb7746ffa in setCurrentIndex (notifyEffects=false, index=..., this=0x8faf728) at ../../kwin/tabbox/tabbox.cpp:496
#41 KWin::TabBox::TabBox::setCurrentIndex (this=0x8faf728, index=..., notifyEffects=false) at ../../kwin/tabbox/tabbox.cpp:492
#42 0xb7747151 in KWin::TabBox::TabBox::nextPrev (this=0x8faf728, next=true) at ../../kwin/tabbox/tabbox.cpp:418
#43 0xb7747199 in KWin::TabBox::TabBox::walkThroughDesktops (this=0x8faf728, forward=true) at ../../kwin/tabbox/tabbox.cpp:956
#44 0xb7749b7c in KWin::TabBox::TabBox::slotWalkThroughDesktopList (this=0x8faf728) at ../../kwin/tabbox/tabbox.cpp:835
#45 0xb774a001 in KWin::TabBox::TabBox::qt_metacall (this=0x8faf728, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfeae558) at ./tabbox.moc:126
#46 0xb6047b7d in metacall (argv=0xbfeae558, idx=11, cl=QMetaObject::InvokeMetaMethod, object=0x8faf728) at kernel/qmetaobject.cpp:237
#47 QMetaObject::metacall (object=0x8faf728, cl=QMetaObject::InvokeMetaMethod, idx=11, argv=0xbfeae558) at kernel/qmetaobject.cpp:232
#48 0xb6056a6a in QMetaObject::activate (sender=0x9053e18, m=0xb5eb4458, local_signal_index=1, argv=0xbfeae558) at kernel/qobject.cpp:3278
#49 0xb556486d in QAction::triggered (this=0x9053e18, _t1=false) at .moc/release-shared/moc_qaction.cpp:263
#50 0xb5564b0b in QAction::activate (this=0x9053e18, event=QAction::Trigger) at kernel/qaction.cpp:1257
#51 0xb72b6b1f in trigger (this=0x9053e18) at /usr/include/qt4/QtGui/qaction.h:218
#52 KGlobalAccelPrivate::_k_invokeAction (this=0x9013948, componentUnique=..., actionUnique=..., timestamp=1361058) at ../../kdeui/shortcuts/kglobalaccel.cpp:449
#53 0xb72b974f in KGlobalAccel::qt_metacall (this=0x8faaec8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfeae740) at ./kglobalaccel.moc:77
#54 0xb6047b7d in metacall (argv=0xbfeae740, idx=4, cl=QMetaObject::InvokeMetaMethod, object=0x8faaec8) at kernel/qmetaobject.cpp:237
#55 QMetaObject::metacall (object=0x8faaec8, cl=QMetaObject::InvokeMetaMethod, idx=4, argv=0xbfeae740) at kernel/qmetaobject.cpp:232
#56 0xb6056a6a in QMetaObject::activate (sender=0x8fed168, m=0xb74b35d8, local_signal_index=0, argv=0xbfeae740) at kernel/qobject.cpp:3278
#57 0xb73f1955 in OrgKdeKglobalaccelComponentInterface::globalShortcutPressed (this=0x8fed168, _t1=..., _t2=..., _t3=1361058) at kglobalaccel_component_interface.moc:150
#58 0xb73f1e4e in OrgKdeKglobalaccelComponentInterface::qt_metacall (this=0x8fed168, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfeae92c) at kglobalaccel_component_interface.moc:98
#59 0xb619ad87 in QDBusConnectionPrivate::deliverCall (this=0x8ea0e48, object=0x8fed168, msg=..., metaTypes=..., slotIdx=1503576961) at qdbusintegrator.cpp:942
#60 0xb61a4c26 in QDBusCallDeliveryEvent::placeMetaCall (this=0x94dc000, object=0x8fed168) at qdbusintegrator_p.h:103
#61 0xb6059b52 in QObject::event (this=0x8fed168, e=0x94dc000) at kernel/qobject.cpp:1217
#62 0xb556bd84 in notify_helper (e=0x94dc000, receiver=0x8fed168, this=0x8eb50d8) at kernel/qapplication.cpp:4486
#63 QApplicationPrivate::notify_helper (this=0x8eb50d8, receiver=0x8fed168, e=0x94dc000) at kernel/qapplication.cpp:4458
#64 0xb5571133 in QApplication::notify (this=0x94dc000, receiver=0x8fed168, e=0x94dc000) at kernel/qapplication.cpp:3886
#65 0xb7267011 in KApplication::notify (this=0xbfeaf028, receiver=0x8fed168, event=0x94dc000) at ../../kdeui/kernel/kapplication.cpp:311
#66 0xb76a6f5f in notify (e=0x94dc000, o=0x8fed168, this=0xbfeaf028) at ../../kwin/main.cpp:368
#67 KWin::Application::notify (this=0xbfeaf028, o=0x8fed168, e=0x94dc000) at ../../kwin/main.cpp:364
#68 0xb604119e in QCoreApplication::notifyInternal (this=0xbfeaf028, receiver=0x8fed168, event=0x94dc000) at kernel/qcoreapplication.cpp:787
#69 0xb6044f93 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#70 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8e762e0) at kernel/qcoreapplication.cpp:1428
#71 0xb60450ec in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1321
#72 0xb5624d2d in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#73 QEventDispatcherX11::processEvents (this=0x8e77230, flags=...) at kernel/qeventdispatcher_x11.cpp:75
#74 0xb60401dd in QEventLoop::processEvents (this=0xbfeaef64, flags=...) at kernel/qeventloop.cpp:149
#75 0xb6040421 in QEventLoop::exec (this=0xbfeaef64, flags=...) at kernel/qeventloop.cpp:201
#76 0xb604519d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#77 0xb5569924 in QApplication::exec () at kernel/qapplication.cpp:3760
#78 0xb76a9ef5 in kdemain (argc=1, argv=0xbfeaf2d4) at ../../kwin/main.cpp:541
#79 0x0804850b in main (argc=1, argv=0xbfeaf2d4) at kwin_dummy.cpp:3

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2012-01-31 13:21:08 UTC

*** This bug has been marked as a duplicate of bug 285747 ***