Bug 292223

Summary: export to picasa don't save my gmail account password
Product: [Applications] digikam Reporter: Pavel Nedrigailov <pavel.nedr>
Component: Plugin-WebService-GoogleAssignee: Digikam Developers <digikam-bugs-null>
Severity: normal CC: caulier.gilles, czernitko, dvdmerwe, lukas.zachy, o.boudet
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Fedora RPMs   
OS: Linux   
Latest Commit: Version Fixed In: 2.8.0

Description Pavel Nedrigailov 2012-01-22 20:59:55 UTC
Version:           2.5.0 (using KDE 4.7.4) 
OS:                Linux

It's not usefull, but when you use 2-step verification in google account, you must every time when you want to upload some photos go to https://www.google.com/settings/ then to edit Authorizing applications & sites, delete old application (digikam) password, generate new, paste it in to password dialog in digiKam.

Reproducible: Always

Steps to Reproduce:
1. open digikam, select some fotos and go to export - export to picasaWeb;
2. fill login data (account, password), select album, click "begin upload"
3. when done, reboot pc.
4. open digikam, select some fotos and go to export - export to picasaWeb. Program will ask password again.

Actual Results:  
digikam asks me about password

Expected Results:  
digikam must store picasaweb password in kwallet, for example

OS: Linux (i686) release 3.1.9-1.fc16.i686
Compiler: gcc
Fedora 16 x86
Comment 1 caulier.gilles 2012-03-26 10:06:58 UTC
*** Bug 292226 has been marked as a duplicate of this bug. ***
Comment 2 silviu vulcan 2012-03-26 10:11:55 UTC
I just wanted to note that I observe the same bug.
Digikam 2.5.0, compiled from source on Slackware64 Again using 2-step verification requires regenerating the password on each upload. Basically it makes using this export plugin cumbersome and annoying.
Comment 3 Joachim Wilke 2012-05-15 10:50:19 UTC
Digikam and Kipi-Plugins 2.5.0 here, using Google-2-Step-Auth, Password is not saved. If you need any more information to fix it, please ask.
Comment 4 Petr Černý 2012-05-17 18:00:29 UTC
*** This bug has been confirmed by popular vote. ***
Comment 5 Danie 2012-06-11 17:57:30 UTC
I have the same bug.... it needs to be confirmed.
Comment 6 Petr Černý 2012-06-11 18:03:17 UTC
Danie: the bug is already confirmed. This got so annoying that I started using darktable not only for RAW processing but also for picasa uploads. Darktable uses kwallet to store the credentials and does not rely on temporary tokens as (I guess)  digikam does. The only but big con is that darktable needs a huge amount of time to process and upload the images if exporting directly from RAW.
Comment 7 lukas 2012-07-24 18:35:03 UTC
Is this issue still present in the Digikam/kipi-plugins 2.7.0?
I am not able to reproduce it any more on {digikam,kipi-plugins,kipi-plugins-libs}-2.7.0-1.fc17.x86_64.
Comment 8 Petr Černý 2012-07-24 19:08:05 UTC
Hi, I'm currently using DigiKam 2.7.0 and the issue is still there. Do you use two-phase authentication with your Google Account? If you don't then you will never have this problem.
Comment 9 lukas 2012-07-24 19:27:52 UTC
Hm, I use two-phase authentication. 

Maybe I somehow messed up my installation, as I compiled newest version from git and overwrote /usr/lib64/kde4/kipiplugin_picasawebexport.so and /usr/lib64/libkipiplugins.so.2 . But that version fixed numeric username, which is shown again after I reverted changes (reinstalled package and checked via rpm -V). 

Just in case: 
I used commit 07515782cb3c7ce8c53e1d77e4654f9f719a1b37 (Jul 20) on git://anongit.kde.org/kipi-plugins

Other difference to previous state, in which  I run into this issue, is that I run KDE instead of Gnome Shell. But I don't think that is the case.
Comment 10 Petr Černý 2012-07-24 19:34:48 UTC
Is it possible that you tried picasa export less than one day after the succesfull upload? The token could be still valid and you wouldn't see the login window with numeric string.
Comment 11 Danie 2012-07-24 19:39:51 UTC
Yes just tested 2.7.0 and aftr restarting it does keep authentication so looks like it is working fine now.
Comment 12 caulier.gilles 2012-07-25 07:05:31 UTC
This file can be closed  now ?
Comment 13 Danie 2012-07-25 16:40:21 UTC
From my side yes it can be closed.