Bug 291344

Summary: KDE Daemon crashes after suspend and resume
Product: [Frameworks and Libraries] kdelibs Reporter: Andreas Kuhl <mail>
Component: kdedAssignee: Unassigned bugs mailing-list <unassigned-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: lamarque
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: OpenSUSE   
OS: Linux   
Latest Commit: Version Fixed In:

Description Andreas Kuhl 2012-01-12 08:55:03 UTC
Application: kded4 ($Id$)
KDE Platform Version: 4.7.97 (4.8 RC2 (4.7.97) "release 1"
Qt Version: 4.8.0
Operating System: Linux 3.1.0-1.2-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

When I suspend my notebook and resume it a couple of hours later, the KDE daemon crashes every time. I do not notice any issue related to the crash, the deskop seems to resume normal operations.

The crash can be reproduced every time.

-- Backtrace:
Application: KDE-Dienst (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7effd5775760 (LWP 3590))]

Thread 3 (Thread 0x7effbba52700 (LWP 3597)):
#0  0x00007effd2d5f423 in poll () from /lib64/libc.so.6
#1  0x00007effcfb3ca98 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007effcfb3cf59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007effd43cc956 in QEventDispatcherGlib::processEvents (this=0x7effb40008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007effd439c682 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007effd439c8d7 in QEventLoop::exec (this=0x7effbba51df0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007effd429d537 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007effd437c48f in QInotifyFileSystemWatcherEngine::run (this=0x7af940) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007effd42a055b in QThreadPrivate::start (arg=0x7af940) at thread/qthread_unix.cpp:298
#9  0x00007effd4008f05 in start_thread () from /lib64/libpthread.so.0
#10 0x00007effd2d6853d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7effb3aa4700 (LWP 3610)):
#0  0x00007effd2d5f423 in poll () from /lib64/libc.so.6
#1  0x00007effcfb3ca98 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007effcfb3d2c2 in g_main_loop_run () from /usr/lib64/libglib-2.0.so.0
#3  0x00007effb3d7e946 in ?? () from /usr/lib64/libgio-2.0.so.0
#4  0x00007effcfb61db6 in ?? () from /usr/lib64/libglib-2.0.so.0
#5  0x00007effd4008f05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007effd2d6853d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7effd5775760 (LWP 3590)):
[KCrash Handler]
#6  0x00007effd43afc90 in QObject::property (this=0x83d0f0, name=0x7effd112d510 "_qdbus_slotCache") at kernel/qobject.cpp:3750
#7  0x00007effd10edd19 in QDBusConnectionPrivate::activateCall (this=0x83f480, object=0x83d0f0, flags=273, msg=...) at qdbusintegrator.cpp:807
#8  0x00007effd10eea9b in QDBusConnectionPrivate::activateObject (this=0x83f480, node=..., msg=..., pathStartPos=<optimized out>) at qdbusintegrator.cpp:1423
#9  0x00007effd10eeb8b in QDBusActivateObjectEvent::placeMetaCall (this=0x972ba0) at qdbusintegrator.cpp:1537
#10 0x00007effd43b6926 in QObject::event (this=0x87b610, e=<optimized out>) at kernel/qobject.cpp:1204
#11 0x00007effd3505e84 in notify_helper (e=0x972ba0, receiver=0x87b610, this=0x6a09f0) at kernel/qapplication.cpp:4550
#12 QApplicationPrivate::notify_helper (this=0x6a09f0, receiver=0x87b610, e=0x972ba0) at kernel/qapplication.cpp:4522
#13 0x00007effd350ad03 in QApplication::notify (this=0x7fffe12d9ee0, receiver=0x87b610, e=0x972ba0) at kernel/qapplication.cpp:4411
#14 0x00007effd515c786 in KApplication::notify (this=0x7fffe12d9ee0, receiver=0x87b610, event=0x972ba0) at /usr/src/debug/kdelibs-4.7.97/kdeui/kernel/kapplication.cpp:311
#15 0x00007effd439d89c in QCoreApplication::notifyInternal (this=0x7fffe12d9ee0, receiver=0x87b610, event=0x972ba0) at kernel/qcoreapplication.cpp:876
#16 0x00007effd43a113a in sendEvent (event=0x972ba0, receiver=0x87b610) at kernel/qcoreapplication.h:231
#17 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x6153d0) at kernel/qcoreapplication.cpp:1500
#18 0x00007effd43cc4c3 in sendPostedEvents () at kernel/qcoreapplication.h:236
#19 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#20 0x00007effcfb3c58d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#21 0x00007effcfb3cd88 in ?? () from /usr/lib64/libglib-2.0.so.0
#22 0x00007effcfb3cf59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#23 0x00007effd43cc8ef in QEventDispatcherGlib::processEvents (this=0x616770, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#24 0x00007effd35a92de in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#25 0x00007effd439c682 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#26 0x00007effd439c8d7 in QEventLoop::exec (this=0x7fffe12d9e70, flags=...) at kernel/qeventloop.cpp:204
#27 0x00007effd43a1435 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#28 0x00007effc2c5b495 in kdemain (argc=1, argv=0x654ab0) at /usr/src/debug/kdelibs-4.7.97/kded/kded.cpp:924
#29 0x00000000004088e4 in launch (argc=1, _name=0x40b421 "kded4", args=<optimized out>, cwd=0x0, envc=<optimized out>, envs=<optimized out>, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x40b2b6 "0") at /usr/src/debug/kdelibs-4.7.97/kinit/kinit.cpp:734
#30 0x0000000000405ec9 in main (argc=4, argv=0x7fff00000001, envp=0x7fffe12dafd0) at /usr/src/debug/kdelibs-4.7.97/kinit/kinit.cpp:1849

This bug may be a duplicate of or related to bug 284052.

Possible duplicates by query: bug 284052.

Reported using DrKonqi
Comment 1 Lamarque V. Souza 2012-01-12 11:07:20 UTC

*** This bug has been marked as a duplicate of bug 284052 ***