Bug 290528

Summary: [wish] support of the "open raster" *.ora files
Product: kdelibs Reporter: David REVOY <info>
Component: kimgioAssignee: Halla Rempt <halla>
Status: RESOLVED FIXED    
Severity: wishlist CC: cfeck, halla, jononor, kapillamba4, rafael.linux.user
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description David REVOY 2012-01-03 20:44:43 UTC
Version:           0.8.0 (using KDE 4.7.4) 
OS:                Linux

Hi, 
Open raster files (*.ora ) are layered images produced by Krita / Gimp and Mypaint and other image manipulation softwares. I would really like to use Gwenview as a Ora viewer, as I tend to use them a lot in my work and even if the system support the thumbnails, it's annoying to have to launch a full editor like Gimp/Krita/Mypaint to showcase them. 

specifications : 
http://create.freedesktop.org/wiki/OpenRaster

Reproducible: Always


Actual Results:  
 

Expected Results:
Comment 1 Christoph Feck 2012-01-05 19:52:12 UTC
Would it be acceptable to have the OpenRaster loader be part of the Calligra/Krita installation, in other words, Gwenview could load OpenRaster files, if (and only if) Krita is installed? This is the case for the thumbnailer currently.
Comment 2 David REVOY 2012-01-05 20:55:17 UTC
Very acceptable, as most of user in this case are poeple who have Krita / Mypaint installed at least on their operating system. 
It can use 
calligraconverter --batch "input.ora" "output-temp.png" to read. For the thumbnail, the ones already inside the *.ora files are fines. 

While I'm at it ; could it be done for *.kra files ? ( krita files ) they have exactly the same structure ( zip with thumbnail folder for thumb ) and can also be converted with calligraconverter

Thanks
Comment 3 Halla Rempt 2013-12-19 13:51:42 UTC
Git commit 86abb9fb182509dbb553d7c940d91fcf9d6c046b by Boudewijn Rempt.
Committed on 19/12/2013 at 13:50.
Pushed by rempt into branch 'master'.

Add qimageio plugins for kra and ora files

M  +1    -0    krita/plugins/CMakeLists.txt
M  +0    -2    krita/plugins/formats/ora/CMakeLists.txt
M  +1    -0    krita/plugins/formats/ora/ora_converter.cc
A  +17   -0    krita/plugins/kimgio/CMakeLists.txt
A  +104  -0    krita/plugins/kimgio/kra.cpp     [License: Public Domain LGPL (v2+)]
A  +7    -0    krita/plugins/kimgio/kra.desktop
A  +30   -0    krita/plugins/kimgio/kra.h     [License: LGPL (v2+)]
A  +120  -0    krita/plugins/kimgio/ora.cpp     [License: Public Domain LGPL (v2+)]
A  +7    -0    krita/plugins/kimgio/ora.desktop
A  +30   -0    krita/plugins/kimgio/ora.h     [License: LGPL (v2+)]
M  +2    -0    krita/ui/CMakeLists.txt
M  +31   -0    krita/ui/kis_doc2.cc
M  +3    -0    krita/ui/kis_doc2.h
R  +0    -0    krita/ui/ora/ora_load_context.cc [from: krita/plugins/formats/ora/ora_load_context.cc - 100% similarity]
R  +2    -1    krita/ui/ora/ora_load_context.h [from: krita/plugins/formats/ora/ora_load_context.h - 092% similarity]
R  +0    -0    krita/ui/ora/ora_save_context.cc [from: krita/plugins/formats/ora/ora_save_context.cc - 100% similarity]
R  +2    -1    krita/ui/ora/ora_save_context.h [from: krita/plugins/formats/ora/ora_save_context.h - 092% similarity]
M  +2    -2    libs/main/KoDocument.h

http://commits.kde.org/calligra/86abb9fb182509dbb553d7c940d91fcf9d6c046b
Comment 4 Halla Rempt 2013-12-19 13:52:04 UTC
Git commit 35dfa7d318e0c6906497463c7c95cdf59b5ce1ea by Boudewijn Rempt.
Committed on 19/12/2013 at 13:50.
Pushed by rempt into branch 'calligra/2.8'.

Add qimageio plugins for kra and ora files

M  +1    -0    krita/plugins/CMakeLists.txt
M  +0    -2    krita/plugins/formats/ora/CMakeLists.txt
M  +1    -0    krita/plugins/formats/ora/ora_converter.cc
A  +17   -0    krita/plugins/kimgio/CMakeLists.txt
A  +104  -0    krita/plugins/kimgio/kra.cpp     [License: Public Domain LGPL (v2+)]
A  +7    -0    krita/plugins/kimgio/kra.desktop
A  +30   -0    krita/plugins/kimgio/kra.h     [License: LGPL (v2+)]
A  +120  -0    krita/plugins/kimgio/ora.cpp     [License: Public Domain LGPL (v2+)]
A  +7    -0    krita/plugins/kimgio/ora.desktop
A  +30   -0    krita/plugins/kimgio/ora.h     [License: LGPL (v2+)]
M  +2    -0    krita/ui/CMakeLists.txt
M  +31   -0    krita/ui/kis_doc2.cc
M  +3    -0    krita/ui/kis_doc2.h
R  +0    -0    krita/ui/ora/ora_load_context.cc [from: krita/plugins/formats/ora/ora_load_context.cc - 100% similarity]
R  +2    -1    krita/ui/ora/ora_load_context.h [from: krita/plugins/formats/ora/ora_load_context.h - 092% similarity]
R  +0    -0    krita/ui/ora/ora_save_context.cc [from: krita/plugins/formats/ora/ora_save_context.cc - 100% similarity]
R  +2    -1    krita/ui/ora/ora_save_context.h [from: krita/plugins/formats/ora/ora_save_context.h - 092% similarity]
M  +2    -2    libs/main/KoDocument.h

http://commits.kde.org/calligra/35dfa7d318e0c6906497463c7c95cdf59b5ce1ea
Comment 5 Christoph Feck 2014-01-14 01:15:39 UTC
Boudewijn, thanks for this.

Could you please check if this also fixes bug 220335 (being able to view .ora thumbnails)?

If not, maybe it just need to be added to kde-runtime/kioslave/thumbnail/imagethumbnail.desktop
Comment 6 Christoph Feck 2014-07-10 00:41:58 UTC
*** Bug 337271 has been marked as a duplicate of this bug. ***
Comment 7 Nate Graham 2017-11-10 18:13:41 UTC
*** Bug 220335 has been marked as a duplicate of this bug. ***