Bug 289179

Summary: Kmail crash after deleting large number of local (pop3) mails
Product: [Applications] kmail2 Reporter: Hrvoje Senjan <hrvoje.senjan>
Component: generalAssignee: kdepim bugs <kdepim-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: OpenSUSE   
OS: Linux   
Latest Commit: Version Fixed In:

Description Hrvoje Senjan 2011-12-17 09:50:35 UTC
Application: kmail (4.8 beta2)
KDE Platform Version: 4.7.90 (4.8 Beta2 (4.7.90) "release 7"
Qt Version: 4.8.0
Operating System: Linux 3.1.5-1-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
Using KDE 4.8 beta2 + kdepim (libs , runtime) master. Kmail whas started in razorqt session. I tried to delete large number of mails which have been filtered by keyword , and after a minute or two kmail crashed.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fe1b76e8780 (LWP 16764))]

Thread 9 (Thread 0x7fe193fff700 (LWP 16792)):
#0  0x00007fe1b2802e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fe1a8e0b2ac in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x00007fe1a8e0b3d9 in ?? () from /usr/lib64/libQtWebKit.so.4
#3  0x00007fe1b27fef05 in start_thread () from /lib64/libpthread.so.0
#4  0x00007fe1b4a2553d in clone () from /lib64/libc.so.6

Thread 8 (Thread 0x7fe1936fe700 (LWP 16793)):
#0  0x00007fe1b4a1c423 in poll () from /lib64/libc.so.6
#1  0x00007fe1ace51a98 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fe1ace51f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fe1b6080526 in QEventDispatcherGlib::processEvents (this=0x7fe18c0008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fe1b6050272 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fe1b60504c7 in QEventLoop::exec (this=0x7fe1936fde00, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fe1b5f51137 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fe1b5f5415b in QThreadPrivate::start (arg=0x1762a80) at thread/qthread_unix.cpp:298
#8  0x00007fe1b27fef05 in start_thread () from /lib64/libpthread.so.0
#9  0x00007fe1b4a2553d in clone () from /lib64/libc.so.6

Thread 7 (Thread 0x7fe14b754700 (LWP 16941)):
#0  0x00007fe1b28031eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fe1b5f545cf in wait (time=30000, this=0x18a90e0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x18a9058, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fe1b5f479df in QThreadPoolThread::run (this=0x1d763f0) at concurrent/qthreadpool.cpp:141
#4  0x00007fe1b5f5415b in QThreadPrivate::start (arg=0x1d763f0) at thread/qthread_unix.cpp:298
#5  0x00007fe1b27fef05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007fe1b4a2553d in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7fe14a3fb700 (LWP 16963)):
#0  0x00007fe1b28031eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fe1b5f545cf in wait (time=30000, this=0x7fe138005ed0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7fe138005e78, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fe1b5f479df in QThreadPoolThread::run (this=0x7fe138006120) at concurrent/qthreadpool.cpp:141
#4  0x00007fe1b5f5415b in QThreadPrivate::start (arg=0x7fe138006120) at thread/qthread_unix.cpp:298
#5  0x00007fe1b27fef05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007fe1b4a2553d in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7fe149bfa700 (LWP 16965)):
#0  0x00007fe1b28031eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fe1b5f545cf in wait (time=30000, this=0x7fe138005ed0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7fe138005e78, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fe1b5f479df in QThreadPoolThread::run (this=0x7fe13800a100) at concurrent/qthreadpool.cpp:141
#4  0x00007fe1b5f5415b in QThreadPrivate::start (arg=0x7fe13800a100) at thread/qthread_unix.cpp:298
#5  0x00007fe1b27fef05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007fe1b4a2553d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7fe1493f9700 (LWP 16967)):
#0  0x00007fe1b28031eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fe1b5f545cf in wait (time=30000, this=0x7fe138005ed0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7fe138005e78, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fe1b5f479df in QThreadPoolThread::run (this=0x7fe13800e0d0) at concurrent/qthreadpool.cpp:141
#4  0x00007fe1b5f5415b in QThreadPrivate::start (arg=0x7fe13800e0d0) at thread/qthread_unix.cpp:298
#5  0x00007fe1b27fef05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007fe1b4a2553d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7fe148bf8700 (LWP 16969)):
#0  0x00007fe1b28031eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fe1b5f545cf in wait (time=30000, this=0x7fe138005ed0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7fe138005e78, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fe1b5f479df in QThreadPoolThread::run (this=0x7fe1380120b0) at concurrent/qthreadpool.cpp:141
#4  0x00007fe1b5f5415b in QThreadPrivate::start (arg=0x7fe1380120b0) at thread/qthread_unix.cpp:298
#5  0x00007fe1b27fef05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007fe1b4a2553d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7fe12ffff700 (LWP 16971)):
#0  0x00007fe1b28031eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fe1b5f545cf in wait (time=30000, this=0x7fe138005ed0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7fe138005e78, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fe1b5f479df in QThreadPoolThread::run (this=0x7fe138016080) at concurrent/qthreadpool.cpp:141
#4  0x00007fe1b5f5415b in QThreadPrivate::start (arg=0x7fe138016080) at thread/qthread_unix.cpp:298
#5  0x00007fe1b27fef05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007fe1b4a2553d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fe1b76e8780 (LWP 16764)):
[KCrash Handler]
#6  QList (l=..., this=0x7fffa02503d0) at ../../src/corelib/tools/qlist.h:122
#7  QNetworkCacheMetaData::rawHeaders (this=0x7fffa02506e0) at access/qabstractnetworkcache.cpp:240
#8  0x00007fe1b39ba32c in QNetworkAccessHttpBackend::fetchCacheMetaData (this=0x2e52e20, oldMetaData=...) at access/qnetworkaccesshttpbackend.cpp:1019
#9  0x00007fe1b39bba84 in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x2e52e20, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:828
#10 0x00007fe1b3a470d9 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x2e52e20, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#11 0x00007fe1b606a4f6 in QObject::event (this=0x2e52e20, e=<optimized out>) at kernel/qobject.cpp:1195
#12 0x00007fe1b53d7d84 in notify_helper (e=0x7fe13802d480, receiver=0x2e52e20, this=0x66bea0) at kernel/qapplication.cpp:4550
#13 QApplicationPrivate::notify_helper (this=0x66bea0, receiver=0x2e52e20, e=0x7fe13802d480) at kernel/qapplication.cpp:4522
#14 0x00007fe1b53dcc03 in QApplication::notify (this=0x7fffa0251210, receiver=0x2e52e20, e=0x7fe13802d480) at kernel/qapplication.cpp:4411
#15 0x00007fe1b70f90f6 in KApplication::notify (this=0x7fffa0251210, receiver=0x2e52e20, event=0x7fe13802d480) at /usr/src/debug/kdelibs-4.7.90/kdeui/kernel/kapplication.cpp:311
#16 0x00007fe1b605148c in QCoreApplication::notifyInternal (this=0x7fffa0251210, receiver=0x2e52e20, event=0x7fe13802d480) at kernel/qcoreapplication.cpp:876
#17 0x00007fe1b6054d2a in sendEvent (event=0x7fe13802d480, receiver=0x2e52e20) at kernel/qcoreapplication.h:231
#18 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x60b740) at kernel/qcoreapplication.cpp:1500
#19 0x00007fe1b6080093 in sendPostedEvents () at kernel/qcoreapplication.h:236
#20 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#21 0x00007fe1ace5158d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#22 0x00007fe1ace51d88 in ?? () from /usr/lib64/libglib-2.0.so.0
#23 0x00007fe1ace51f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#24 0x00007fe1b60804bf in QEventDispatcherGlib::processEvents (this=0x60b000, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#25 0x00007fe1b547adee in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#26 0x00007fe1b6050272 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#27 0x00007fe1b60504c7 in QEventLoop::exec (this=0x7fffa02510f0, flags=...) at kernel/qeventloop.cpp:204
#28 0x00007fe1b6055025 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#29 0x0000000000402df3 in ?? ()
#30 0x00007fe1b496d23d in __libc_start_main () from /lib64/libc.so.6
#31 0x00000000004032d5 in _start ()

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2012-01-02 19:44:30 UTC

*** This bug has been marked as a duplicate of bug 286307 ***