Bug 289102

Summary: cc
Product: [Plasma] kwin Reporter: David Graham <davidtgraham>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:

Description David Graham 2011-12-16 09:23:10 UTC
Application: kwin (4.6.5 (4.6.5))
KDE Platform Version: 4.6.5 (4.6.5)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-13-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:
Most times when I resume the laptop from a hibernation state I get this problem - sometimes the screen remains grey, and I am not able to log in.

The crash can be reproduced some of the time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fe7049597a0 (LWP 2027))]

Thread 4 (Thread 0x7fe6ec8ae700 (LWP 2028)):
#0  0x00007fe7041a0f03 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fe6f8fdb104 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fe6f8fdb9f2 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe6f158cc44 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007fe6f90023e4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fe6fab61d8c in start_thread (arg=0x7fe6ec8ae700) at pthread_create.c:304
#6  0x00007fe7041ae04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fe6dd03c700 (LWP 2040)):
#0  0x00007fe7041a6143 in select () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007fe70058332c in qt_safe_select (nfds=35, fdread=0x3c02d50, fdwrite=0x3c02fe8, fdexcept=0x3c03280, orig_timeout=<value optimized out>) at kernel/qcore_unix.cpp:82
#2  0x00007fe7005883d0 in QEventDispatcherUNIXPrivate::doSelect (this=0x3c02b90, flags=..., timeout=0x0) at kernel/qeventdispatcher_unix.cpp:219
#3  0x00007fe70058904a in QEventDispatcherUNIX::processEvents (this=0x3a47f30, flags=...) at kernel/qeventdispatcher_unix.cpp:919
#4  0x00007fe70055a882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fe70055aabc in QEventLoop::exec (this=0x7fe6dd03bdb0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fe700471924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007fe70053cc2f in QInotifyFileSystemWatcherEngine::run (this=0x3c01cd0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fe700474175 in QThreadPrivate::start (arg=0x3c01cd0) at thread/qthread_unix.cpp:320
#9  0x00007fe6fab61d8c in start_thread (arg=0x7fe6dd03c700) at pthread_create.c:304
#10 0x00007fe7041ae04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fe6dc83b700 (LWP 2041)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fe70300c2a2 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7fe703325180) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007fe70300c2d9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7fe703333254) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007fe6fab61d8c in start_thread (arg=0x7fe6dc83b700) at pthread_create.c:304
#4  0x00007fe7041ae04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fe7049597a0 (LWP 2027)):
[KCrash Handler]
#6  intel_region_buffer (intel=0x27add10, region=0x0, flag=2) at intel_regions.c:514
#7  0x00007fe6dff9f6c2 in intelClearWithBlit (ctx=0x27add10, mask=2) at intel_blit.c:262
#8  0x00007fe6dffa1d2a in intelClear (ctx=0x27add10, mask=2) at intel_clear.c:177
#9  0x00007fe704524c47 in KWin::SceneOpenGL::paintBackground (this=<value optimized out>, region=<value optimized out>) at ../../kwin/scene_opengl.cpp:921
#10 0x00007fe70451c7ef in KWin::Scene::paintGenericScreen (this=0x27925e0, orig_mask=552) at ../../kwin/scene.cpp:188
#11 0x00007fe704519bda in KWin::Scene::finalPaintScreen (this=0x27925e0, mask=552, region=<value optimized out>, data=<value optimized out>) at ../../kwin/scene.cpp:178
#12 0x00007fe704535293 in KWin::EffectsHandlerImpl::paintScreen (this=0x38d8520, mask=552, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:173
#13 0x00007fe6dee0d626 in KWin::StartupFeedbackEffect::paintScreen (this=0x3ae3090, mask=552, region=<value optimized out>, data=...) at ../../../kwin/effects/startupfeedback/startupfeedback.cpp:166
#14 0x00007fe7045352f6 in KWin::EffectsHandlerImpl::paintScreen (this=0x38d8520, mask=552, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#15 0x00007fe7025f6a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=552, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#16 0x00007fe7045352f6 in KWin::EffectsHandlerImpl::paintScreen (this=0x38d8520, mask=552, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#17 0x00007fe6dedb449d in KWin::LogoutEffect::paintScreen (this=0x3945b10, mask=552, region=..., data=...) at ../../../kwin/effects/logout/logout.cpp:207
#18 0x00007fe7045352f6 in KWin::EffectsHandlerImpl::paintScreen (this=0x38d8520, mask=552, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#19 0x00007fe6dedcf5cb in KWin::ShadowEffect::paintScreen (this=0x39f0d00, mask=552, region=..., data=...) at ../../../kwin/effects/shadow/shadow.cpp:189
#20 0x00007fe7045352f6 in KWin::EffectsHandlerImpl::paintScreen (this=0x38d8520, mask=552, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#21 0x00007fe6dede1eb8 in KWin::BlurEffect::paintScreen (this=<value optimized out>, mask=552, region=..., data=...) at ../../../kwin/effects/blur/blur.cpp:230
#22 0x00007fe7045352f6 in KWin::EffectsHandlerImpl::paintScreen (this=0x38d8520, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#23 0x00007fe6dedb900d in KWin::PresentWindowsEffect::paintScreen (this=0x3d01170, mask=520, region=..., data=...) at ../../../kwin/effects/presentwindows/presentwindows.cpp:205
#24 0x00007fe7045352f6 in KWin::EffectsHandlerImpl::paintScreen (this=0x38d8520, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#25 0x00007fe7025f6a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=520, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#26 0x00007fe7045352f6 in KWin::EffectsHandlerImpl::paintScreen (this=0x38d8520, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#27 0x00007fe7025f6a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=520, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#28 0x00007fe7045352f6 in KWin::EffectsHandlerImpl::paintScreen (this=0x38d8520, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#29 0x00007fe7025f6a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=520, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#30 0x00007fe7045352f6 in KWin::EffectsHandlerImpl::paintScreen (this=0x38d8520, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#31 0x00007fe7025f6a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=520, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#32 0x00007fe7045352f6 in KWin::EffectsHandlerImpl::paintScreen (this=0x38d8520, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#33 0x00007fe6deda0385 in KWin::DesktopGridEffect::paintScreen (this=<value optimized out>, mask=520, region=..., data=...) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:156
#34 0x00007fe7045352f6 in KWin::EffectsHandlerImpl::paintScreen (this=0x38d8520, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#35 0x00007fe6dedd5bdf in KWin::SlideEffect::paintScreen (this=<value optimized out>, mask=520, region=..., data=...) at ../../../kwin/effects/slide/slide.cpp:86
#36 0x00007fe7045352f6 in KWin::EffectsHandlerImpl::paintScreen (this=0x38d8520, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#37 0x00007fe6ded99bad in KWin::BoxSwitchEffect::paintScreen (this=0x3b6e680, mask=520, region=..., data=...) at ../../../kwin/effects/boxswitch/boxswitch.cpp:143
#38 0x00007fe7045352f6 in KWin::EffectsHandlerImpl::paintScreen (this=0x38d8520, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#39 0x00007fe6dedf02c6 in KWin::CubeEffect::paintScreen (this=<value optimized out>, mask=520, region=..., data=...) at ../../../kwin/effects/cube/cube.cpp:698
#40 0x00007fe7045352f6 in KWin::EffectsHandlerImpl::paintScreen (this=0x38d8520, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#41 0x00007fe7025f6a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=520, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#42 0x00007fe7045352f6 in KWin::EffectsHandlerImpl::paintScreen (this=0x38d8520, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#43 0x00007fe7025f6a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=520, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#44 0x00007fe7045352f6 in KWin::EffectsHandlerImpl::paintScreen (this=0x38d8520, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#45 0x00007fe7025f6a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=520, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#46 0x00007fe7045352f6 in KWin::EffectsHandlerImpl::paintScreen (this=0x38d8520, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#47 0x00007fe6dede8df6 in KWin::CoverSwitchEffect::paintScreen (this=0x3acd650, mask=520, region=..., data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:126
#48 0x00007fe7045352f6 in KWin::EffectsHandlerImpl::paintScreen (this=0x38d8520, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#49 0x00007fe7025f6a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=520, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#50 0x00007fe7045352f6 in KWin::EffectsHandlerImpl::paintScreen (this=0x38d8520, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#51 0x00007fe7025f6a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=520, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#52 0x00007fe7045352f6 in KWin::EffectsHandlerImpl::paintScreen (this=0x38d8520, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#53 0x00007fe6dee0faad in KWin::TrackMouseEffect::paintScreen (this=0x3db2d60, mask=520, region=..., data=...) at ../../../kwin/effects/trackmouse/trackmouse.cpp:112
#54 0x00007fe7045352f6 in KWin::EffectsHandlerImpl::paintScreen (this=0x38d8520, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#55 0x00007fe6deddf3eb in KWin::ZoomEffect::paintScreen (this=0x3b0b750, mask=520, region=..., data=...) at ../../../kwin/effects/zoom/zoom.cpp:341
#56 0x00007fe7045352f6 in KWin::EffectsHandlerImpl::paintScreen (this=0x38d8520, mask=520, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#57 0x00007fe70451c00f in KWin::Scene::paintScreen (this=0x27925e0, mask=0x7fffda75729c, region=0x7fffda757360) at ../../kwin/scene.cpp:137
#58 0x00007fe70452fe53 in KWin::SceneOpenGL::paint (this=0x27925e0, damage=..., toplevels=<value optimized out>) at ../../kwin/scene_opengl.cpp:772
#59 0x00007fe7045172f6 in KWin::Workspace::performCompositing (this=0x2ac4f10) at ../../kwin/composite.cpp:448
#60 0x00007fe70056f1c9 in QObject::event (this=0x2ac4f10, e=<value optimized out>) at kernel/qobject.cpp:1190
#61 0x00007fe6ff9189f4 in QApplicationPrivate::notify_helper (this=0x24c7bf0, receiver=0x2ac4f10, e=0x7fffda757af0) at kernel/qapplication.cpp:4462
#62 0x00007fe6ff91d3ba in QApplication::notify (this=<value optimized out>, receiver=0x2ac4f10, e=0x7fffda757af0) at kernel/qapplication.cpp:4341
#63 0x00007fe703ca96c6 in KApplication::notify (this=0x7fffda757ef0, receiver=0x2ac4f10, event=0x7fffda757af0) at ../../kdeui/kernel/kapplication.cpp:311
#64 0x00007fe70055b49c in QCoreApplication::notifyInternal (this=0x7fffda757ef0, receiver=0x2ac4f10, event=0x7fffda757af0) at kernel/qcoreapplication.cpp:731
#65 0x00007fe700588f12 in sendEvent (this=0x24c87b0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#66 QTimerInfoList::activateTimers (this=0x24c87b0) at kernel/qeventdispatcher_unix.cpp:604
#67 0x00007fe70058905b in QEventDispatcherUNIX::processEvents (this=0x246c340, flags=...) at kernel/qeventdispatcher_unix.cpp:923
#68 0x00007fe6ff9c32ec in QEventDispatcherX11::processEvents (this=0x246c340, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#69 0x00007fe70055a882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#70 0x00007fe70055aabc in QEventLoop::exec (this=0x7fffda757e30, flags=...) at kernel/qeventloop.cpp:201
#71 0x00007fe70055eecb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#72 0x00007fe7044b514c in kdemain (argc=<value optimized out>, argv=0x7fffda758588) at ../../kwin/main.cpp:542
#73 0x00007fe7040e6eff in __libc_start_main (main=0x400740 <main(int, char**)>, argc=3, ubp_av=0x7fffda758588, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fffda758578) at libc-start.c:226
#74 0x0000000000400669 in _start ()

Possible duplicates by query: bug 285432, bug 283561, bug 283498, bug 283096, bug 282981.

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2011-12-16 10:45:47 UTC
crash is a driver bug, uncheck "suspend compositing for fullscreen windows" in "kcmshell4 kwincompositing as workaround"

grey (or rather "white"?) screen after resume from STR means that the framebuffer is not reposted and is a driver bug as well.

Try to update mesa & xf86-video-intel and to workaround, suspend compositing altogether (shift+alt+f12) before going STR.

please do not post to the duplicate, it's completely flooded. thanks.

*** This bug has been marked as a duplicate of bug 252817 ***