Bug 288464

Summary: title bar corrupted on windows not maximized
Product: kwin Reporter: Fred Jackson <fredrick.o.jackson>
Component: compositingAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: NOR    
Version: git master   
Target Milestone: ---   
Platform: Debian unstable   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: snapshot of corrupted window decorations

Description Fred Jackson 2011-12-08 10:09:32 UTC
Created attachment 66496 [details]
snapshot of corrupted window decorations

Version:           git master (using Devel) 
OS:                Linux

I'm getting title bars that don't display buttons and title bars that are longer than the window when the window is not maximized. The bottom of the window is also wrong. see attached image. Different window decorations settings cause different types of problems affecting the size of the title bar, whether buttons are displayed in the title bar when the window is not maximized, or whether the buttons are the correct size (or possible they are positioned wrong). Even the position of the titlebar appears wrong in some cases.

Reproducible: Always

Steps to Reproduce:
launch any application in a window not maximized.

Actual Results:  
see attachment

Expected Results:  
window decorations that are not corrupted

I am new to running KDE from source. I used kdesrc-build to compile my KDE and experienced only minor problems getting KDE to compile. I use Debian unstable on my machines and have one machine that I compile KDE on. The other machines I run KDE from the Debian distribution. After getting KDE to compile and run the first time and getting these problems, I deleted the entire build directory and rebuilt KDE in order to try to make sure I didn't miss a dependency. Problem still occurs.
Comment 1 Thomas L├╝bking 2011-12-08 10:27:44 UTC
ati chip? (see dupe)
check "glxinfo | grep -i npot"

*** This bug has been marked as a duplicate of bug 282882 ***