Bug 286804

Summary: rekonq crashes after browsing a couple of webpages in private browsing
Product: [Applications] rekonq Reporter: keithluxeus
Component: generalAssignee: Andrea Diamantini <adjam7>
Status: RESOLVED DUPLICATE    
Severity: crash CC: yoann.laissus
Priority: NOR    
Version: 0.8.0   
Target Milestone: ---   
Platform: Unlisted Binaries   
OS: Linux   
Latest Commit: Version Fixed In:

Description keithluxeus 2011-11-16 21:28:31 UTC
Version:           0.8.0 (using KDE 4.7.2) 
OS:                Linux

After browsing 5 to 7 webpages it crashes. It seems there is a segmentation fault according to the backtrace that was conducted.

Reproducible: Always

Steps to Reproduce:
I would start rekonq again and turn on private browsing

Actual Results:  
It crashes after a couple of websites were visited.

Expected Results:  
Not supposed to crash. should be able to continue browsing.

OS: Linux (x86_64) release 3.0.0-12-generic
Compiler: gcc
Comment 1 Yoann Laissus 2011-11-18 08:00:16 UTC
Can you past here the backtrace please ?
Comment 2 keithluxeus 2011-11-21 02:17:53 UTC
Hello, this the backtrace that I found. I hope it helps, Thank you.

BACKTRACE:

Application: rekonq (rekonq), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f498741e780 (LWP 2294))]
Thread 14 (Thread 0x7f49699d8700 (LWP 2295)):
#0 0x00007f498142504c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
#1 0x00007f4985cebc2c in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2 0x00007f4985cebd59 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3 0x00007f4981420efc in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#4 0x00007f4986c4a89d in clone () from /lib/x86_64-linux-gnu/libc.so.6
#5 0×0000000000000000 in ?? ()
Thread 13 (Thread 0x7f49690d7700 (LWP 2296)):
#0 0x00007f497f854429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1 0x00007f4981ad4f3e in QEventDispatcherGlib::processEvents(QFlags) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#2 0x00007f4981aa8cf2 in QEventLoop::processEvents(QFlags) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#3 0x00007f4981aa8ef7 in QEventLoop::exec(QFlags) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#4 0x00007f49819c027f in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#5 0x00007f49819c2d05 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#6 0x00007f4981420efc in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#7 0x00007f4986c4a89d in clone () from /lib/x86_64-linux-gnu/libc.so.6
#8 0×0000000000000000 in ?? ()
Thread 12 (Thread 0x7f4963fff700 (LWP 2297)):
#0 0x00007f498142504c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
#1 0x00007f498684cfe2 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2 0x00007f498684d019 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3 0x00007f4981420efc in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#4 0x00007f4986c4a89d in clone () from /lib/x86_64-linux-gnu/libc.so.6
#5 0×0000000000000000 in ?? ()
Thread 11 (Thread 0x7f4962db7700 (LWP 2298)):
#0 0x00007f498142504c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
#1 0x00007f49819c31ab in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#2 0x00007f49839d3864 in ?? () from /usr/lib/libthreadweaver.so.4
#3 0x00007f49839d5e0b in ?? () from /usr/lib/libthreadweaver.so.4
#4 0x00007f49839d5e24 in ?? () from /usr/lib/libthreadweaver.so.4
#5 0x00007f49839d4ccf in ?? () from /usr/lib/libthreadweaver.so.4
#6 0x00007f49839d4d5b in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#7 0x00007f49819c2d05 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#8 0x00007f4981420efc in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#9 0x00007f4986c4a89d in clone () from /lib/x86_64-linux-gnu/libc.so.6
#10 0×0000000000000000 in ?? ()
Thread 10 (Thread 0x7f492027e700 (LWP 2299)):
#0 0xffffffffff60017b in ?? ()
#1 0x00007f492027daf0 in ?? ()
#2 0x00007fff8f5047e7 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)
Thread 9 (Thread 0x7f491beb4700 (LWP 2310)):
#0 0x00007f498142504c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
#1 0x00007f49819c31ab in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#2 0x00007f49839d3864 in ?? () from /usr/lib/libthreadweaver.so.4
#3 0x00007f49839d5e0b in ?? () from /usr/lib/libthreadweaver.so.4
#4 0x00007f49839d5e24 in ?? () from /usr/lib/libthreadweaver.so.4
#5 0x00007f49839d5e24 in ?? () from /usr/lib/libthreadweaver.so.4
#6 0x00007f49839d4ccf in ?? () from /usr/lib/libthreadweaver.so.4
#7 0x00007f49839d4d5b in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#8 0x00007f49819c2d05 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#9 0x00007f4981420efc in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#10 0x00007f4986c4a89d in clone () from /lib/x86_64-linux-gnu/libc.so.6
#11 0×0000000000000000 in ?? ()
Thread 8 (Thread 0x7f491b6b3700 (LWP 2311)):
#0 0x00007f498142504c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
#1 0x00007f49819c31ab in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#2 0x00007f49839d3864 in ?? () from /usr/lib/libthreadweaver.so.4
#3 0x00007f49839d5e0b in ?? () from /usr/lib/libthreadweaver.so.4
#4 0x00007f49839d4ccf in ?? () from /usr/lib/libthreadweaver.so.4
#5 0x00007f49839d4d5b in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#6 0x00007f49819c2d05 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#7 0x00007f4981420efc in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#8 0x00007f4986c4a89d in clone () from /lib/x86_64-linux-gnu/libc.so.6
#9 0×0000000000000000 in ?? ()
Thread 7 (Thread 0x7f491ad54700 (LWP 2312)):
#0 0x00007f4986c3e773 in poll () from /lib/x86_64-linux-gnu/libc.so.6
#1 0x00007f497f853f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2 0x00007f497f854429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3 0x00007f4981ad4f3e in QEventDispatcherGlib::processEvents(QFlags) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#4 0x00007f4981aa8cf2 in QEventLoop::processEvents(QFlags) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#5 0x00007f4981aa8ef7 in QEventLoop::exec(QFlags) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#6 0x00007f49819c027f in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#7 0x00007f4983fd27ce in ?? () from /usr/lib/libkio.so.5
#8 0x00007f49819c2d05 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#9 0x00007f4981420efc in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#10 0x00007f4986c4a89d in clone () from /lib/x86_64-linux-gnu/libc.so.6
#11 0×0000000000000000 in ?? ()
Thread 6 (Thread 0x7f491e8ed700 (LWP 2360)):
#0 0x00007f498142504c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
#1 0x00007f49819c31ab in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#2 0x00007f49839d3864 in ?? () from /usr/lib/libthreadweaver.so.4
#3 0x00007f49839d5e0b in ?? () from /usr/lib/libthreadweaver.so.4
#4 0x00007f49839d5e24 in ?? () from /usr/lib/libthreadweaver.so.4
#5 0x00007f49839d4ccf in ?? () from /usr/lib/libthreadweaver.so.4
#6 0x00007f49839d4d5b in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#7 0x00007f49819c2d05 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#8 0x00007f4981420efc in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#9 0x00007f4986c4a89d in clone () from /lib/x86_64-linux-gnu/libc.so.6
#10 0×0000000000000000 in ?? ()
Thread 5 (Thread 0x7f491f1ee700 (LWP 2435)):
#0 0x00007f498142504c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
#1 0x00007f4918c1df5c in ?? () from /usr/lib/adobe-flashplugin/libflashplayer.so
#2 0x00007f4918d3ca50 in ?? () from /usr/lib/adobe-flashplugin/libflashplayer.so
#3 0x00007f4918c1e1bc in ?? () from /usr/lib/adobe-flashplugin/libflashplayer.so
#4 0x00007f4918c1e60e in ?? () from /usr/lib/adobe-flashplugin/libflashplayer.so
#5 0x00007f4981420efc in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#6 0x00007f4986c4a89d in clone () from /lib/x86_64-linux-gnu/libc.so.6
#7 0×0000000000000000 in ?? ()
Thread 4 (Thread 0x7f491d2c6700 (LWP 2436)):
#0 0x00007f498142504c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
#1 0x00007f4918c1df5c in ?? () from /usr/lib/adobe-flashplugin/libflashplayer.so
#2 0x00007f4918d3ca50 in ?? () from /usr/lib/adobe-flashplugin/libflashplayer.so
#3 0x00007f4918c1e1bc in ?? () from /usr/lib/adobe-flashplugin/libflashplayer.so
#4 0x00007f4918c1e60e in ?? () from /usr/lib/adobe-flashplugin/libflashplayer.so
#5 0x00007f4981420efc in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#6 0x00007f4986c4a89d in clone () from /lib/x86_64-linux-gnu/libc.so.6
#7 0×0000000000000000 in ?? ()
Thread 3 (Thread 0x7f491cac5700 (LWP 2437)):
#0 0x00007f498142504c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
#1 0x00007f4918c1df5c in ?? () from /usr/lib/adobe-flashplugin/libflashplayer.so
#2 0x00007f4918d3ca50 in ?? () from /usr/lib/adobe-flashplugin/libflashplayer.so
#3 0x00007f4918c1e1bc in ?? () from /usr/lib/adobe-flashplugin/libflashplayer.so
#4 0x00007f4918c1e60e in ?? () from /usr/lib/adobe-flashplugin/libflashplayer.so
#5 0x00007f4981420efc in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#6 0x00007f4986c4a89d in clone () from /lib/x86_64-linux-gnu/libc.so.6
#7 0×0000000000000000 in ?? ()
Thread 2 (Thread 0x7f4911a25700 (LWP 2438)):
#0 0x00007f498142504c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
#1 0x00007f4918c1df5c in ?? () from /usr/lib/adobe-flashplugin/libflashplayer.so
#2 0x00007f4918d3ca50 in ?? () from /usr/lib/adobe-flashplugin/libflashplayer.so
#3 0x00007f4918c1e1bc in ?? () from /usr/lib/adobe-flashplugin/libflashplayer.so
#4 0x00007f4918c1e60e in ?? () from /usr/lib/adobe-flashplugin/libflashplayer.so
#5 0x00007f4981420efc in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#6 0x00007f4986c4a89d in clone () from /lib/x86_64-linux-gnu/libc.so.6
#7 0×0000000000000000 in ?? ()
Thread 1 (Thread 0x7f498741e780 (LWP 2294)):
[KCrash Handler]
#6 0x00007f497f86f0b5 in g_slice_alloc () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#7 0x00007f497f86f6e6 in g_slice_alloc0 () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#8 0x00007f497fb36ef9 in g_type_create_instance () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#9 0x00007f497fb175ac in ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#10 0x00007f497fb19e94 in g_object_newv () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#11 0x00007f497fb1b08c in g_object_new () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#12 0x00007f491859018a in gtk_plug_new_for_display () from /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0
#13 0x00007f4918c196fa in ?? () from /usr/lib/adobe-flashplugin/libflashplayer.so
#14 0x00007f4918c110af in ?? () from /usr/lib/adobe-flashplugin/libflashplayer.so
#15 0x00007f49859e474c in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#16 0x00007f49859e4f51 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#17 0x00007f49859e583a in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#18 0x00007f49858ab2c2 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#19 0x00007f49858ab5bb in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#20 0x00007f4985891a3a in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#21 0x00007f49859955de in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#22 0x00007f4985996147 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#23 0x00007f498595c097 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#24 0x00007f49857d5831 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#25 0x00007f49857d6299 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#26 0x00007f49856c890f in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#27 0x00007f498581a78f in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#28 0x00007f498581d986 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#29 0x00007f498581db59 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#30 0x00007f498581e8bf in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#31 0x00007f498559c788 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#32 0x00007f49856c47bd in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#33 0x00007f49856cc745 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#34 0x00007f49854cb496 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#35 0x00007f49854cb68f in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#36 0x00007f49854cba14 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#37 0x00007f498516b5f9 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#38 0x00007f4985d1d8ed in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#39 0x00007f4985d1e609 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#40 0x00007f492247f58d in ?? ()
#41 0x00007f492247d000 in ?? ()
#42 0x00007f4972ddc428 in ?? ()
#43 0x00007f491e9c55b0 in ?? ()
#44 0x00007f4913c43dd0 in ?? ()
#45 0×0000000000000000 in ?? ()



-----Original Message-----
From: Yoann Laissus <yoann.laissus@gmail.com>
To: keithluxeus <keithluxeus@aol.com>
Sent: Fri, Nov 18, 2011 3:00 am
Subject: [Bug 286804] rekonq crashes after browsing a couple of webpages in private browsing


https://bugs.kde.org/show_bug.cgi?id=286804

oann Laissus <yoann.laissus@gmail.com> changed:
           What    |Removed                     |Added
---------------------------------------------------------------------------
                CC|                            |yoann.laissus@gmail.com


-- Comment #1 from Yoann Laissus <yoann laissus gmail com>  2011-11-18 08:00:16 
--
an you past here the backtrace please ?
Comment 3 Andrea Diamantini 2011-11-22 05:02:25 UTC
Yes. It's the "usual" flash crash.

*** This bug has been marked as a duplicate of bug 281865 ***