Bug 285432

Summary: kwin crash in minecraft
Product: [Plasma] kwin Reporter: Dawid <dawid.dubanosow>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:

Description Dawid 2011-10-31 22:59:27 UTC
Application: kwin (4.6.5 (4.6.5))
KDE Platform Version: 4.6.5 (4.6.5)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-12-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:
i was playing minecraft in fullscreen mode, and clicking multiple left mouse click

The crash can be reproduced some of the time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f1b68dec7a0 (LWP 27078))]

Thread 3 (Thread 0x7f1b4d7db700 (LWP 27088)):
#0  0x00007f1b68634143 in select () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007f1b64a1132c in qt_safe_select (nfds=21, fdread=0x3a83a30, fdwrite=0x3a83cc8, fdexcept=0x3a83f60, orig_timeout=<value optimized out>) at kernel/qcore_unix.cpp:82
#2  0x00007f1b64a163d0 in QEventDispatcherUNIXPrivate::doSelect (this=0x3a83870, flags=..., timeout=0x0) at kernel/qeventdispatcher_unix.cpp:219
#3  0x00007f1b64a1704a in QEventDispatcherUNIX::processEvents (this=0x37f3660, flags=...) at kernel/qeventdispatcher_unix.cpp:919
#4  0x00007f1b649e8882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f1b649e8abc in QEventLoop::exec (this=0x7f1b4d7dadb0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f1b648ff924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007f1b649cac2f in QInotifyFileSystemWatcherEngine::run (this=0x3a81fb0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f1b64902175 in QThreadPrivate::start (arg=0x3a81fb0) at thread/qthread_unix.cpp:320
#9  0x00007f1b5efefd8c in start_thread (arg=0x7f1b4d7db700) at pthread_create.c:304
#10 0x00007f1b6863c04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f1b4cfda700 (LWP 27089)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f1b6749a2a2 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f1b677b3180) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f1b6749a2d9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7f1b677c1254) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f1b5efefd8c in start_thread (arg=0x7f1b4cfda700) at pthread_create.c:304
#4  0x00007f1b6863c04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f1b68dec7a0 (LWP 27078)):
[KCrash Handler]
#6  intel_region_buffer (intel=0x250a440, region=0x0, flag=2) at intel_regions.c:514
#7  0x00007f1b5051a6c2 in intelClearWithBlit (ctx=0x250a440, mask=2) at intel_blit.c:262
#8  0x00007f1b5051cd2a in intelClear (ctx=0x250a440, mask=2) at intel_clear.c:177
#9  0x00007f1b689b2c47 in KWin::SceneOpenGL::paintBackground (this=<value optimized out>, region=<value optimized out>) at ../../kwin/scene_opengl.cpp:921
#10 0x00007f1b689aa7ef in KWin::Scene::paintGenericScreen (this=0x24cb220, orig_mask=32) at ../../kwin/scene.cpp:188
#11 0x00007f1b689a7bda in KWin::Scene::finalPaintScreen (this=0x24cb220, mask=32, region=<value optimized out>, data=<value optimized out>) at ../../kwin/scene.cpp:178
#12 0x00007f1b689c3293 in KWin::EffectsHandlerImpl::paintScreen (this=0x27b7af0, mask=32, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:173
#13 0x00007f1b4f5e0626 in KWin::StartupFeedbackEffect::paintScreen (this=0x38508d0, mask=32, region=<value optimized out>, data=...) at ../../../kwin/effects/startupfeedback/startupfeedback.cpp:166
#14 0x00007f1b689c32f6 in KWin::EffectsHandlerImpl::paintScreen (this=0x27b7af0, mask=32, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#15 0x00007f1b66a84a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#16 0x00007f1b689c32f6 in KWin::EffectsHandlerImpl::paintScreen (this=0x27b7af0, mask=32, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#17 0x00007f1b4f58749d in KWin::LogoutEffect::paintScreen (this=0x3919a90, mask=32, region=..., data=...) at ../../../kwin/effects/logout/logout.cpp:207
#18 0x00007f1b689c32f6 in KWin::EffectsHandlerImpl::paintScreen (this=0x27b7af0, mask=32, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#19 0x00007f1b4f5a25cb in KWin::ShadowEffect::paintScreen (this=0x3754590, mask=32, region=..., data=...) at ../../../kwin/effects/shadow/shadow.cpp:189
#20 0x00007f1b689c32f6 in KWin::EffectsHandlerImpl::paintScreen (this=0x27b7af0, mask=32, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#21 0x00007f1b4f5b4eb8 in KWin::BlurEffect::paintScreen (this=<value optimized out>, mask=32, region=..., data=...) at ../../../kwin/effects/blur/blur.cpp:230
#22 0x00007f1b689c32f6 in KWin::EffectsHandlerImpl::paintScreen (this=0x27b7af0, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#23 0x00007f1b4f58c00d in KWin::PresentWindowsEffect::paintScreen (this=0x36b26f0, mask=0, region=..., data=...) at ../../../kwin/effects/presentwindows/presentwindows.cpp:205
#24 0x00007f1b689c32f6 in KWin::EffectsHandlerImpl::paintScreen (this=0x27b7af0, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#25 0x00007f1b66a84a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#26 0x00007f1b689c32f6 in KWin::EffectsHandlerImpl::paintScreen (this=0x27b7af0, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#27 0x00007f1b66a84a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#28 0x00007f1b689c32f6 in KWin::EffectsHandlerImpl::paintScreen (this=0x27b7af0, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#29 0x00007f1b66a84a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#30 0x00007f1b689c32f6 in KWin::EffectsHandlerImpl::paintScreen (this=0x27b7af0, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#31 0x00007f1b66a84a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#32 0x00007f1b689c32f6 in KWin::EffectsHandlerImpl::paintScreen (this=0x27b7af0, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#33 0x00007f1b4f573385 in KWin::DesktopGridEffect::paintScreen (this=<value optimized out>, mask=0, region=..., data=...) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:156
#34 0x00007f1b689c32f6 in KWin::EffectsHandlerImpl::paintScreen (this=0x27b7af0, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#35 0x00007f1b4f5a8bdf in KWin::SlideEffect::paintScreen (this=<value optimized out>, mask=0, region=..., data=...) at ../../../kwin/effects/slide/slide.cpp:86
#36 0x00007f1b689c32f6 in KWin::EffectsHandlerImpl::paintScreen (this=0x27b7af0, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#37 0x00007f1b4f56cbad in KWin::BoxSwitchEffect::paintScreen (this=0x3a5c290, mask=0, region=..., data=...) at ../../../kwin/effects/boxswitch/boxswitch.cpp:143
#38 0x00007f1b689c32f6 in KWin::EffectsHandlerImpl::paintScreen (this=0x27b7af0, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#39 0x00007f1b4f5c32c6 in KWin::CubeEffect::paintScreen (this=<value optimized out>, mask=0, region=..., data=...) at ../../../kwin/effects/cube/cube.cpp:698
#40 0x00007f1b689c32f6 in KWin::EffectsHandlerImpl::paintScreen (this=0x27b7af0, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#41 0x00007f1b66a84a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#42 0x00007f1b689c32f6 in KWin::EffectsHandlerImpl::paintScreen (this=0x27b7af0, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#43 0x00007f1b66a84a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#44 0x00007f1b689c32f6 in KWin::EffectsHandlerImpl::paintScreen (this=0x27b7af0, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#45 0x00007f1b66a84a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#46 0x00007f1b689c32f6 in KWin::EffectsHandlerImpl::paintScreen (this=0x27b7af0, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#47 0x00007f1b4f5bbdf6 in KWin::CoverSwitchEffect::paintScreen (this=0x3a66f20, mask=0, region=..., data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:126
#48 0x00007f1b689c32f6 in KWin::EffectsHandlerImpl::paintScreen (this=0x27b7af0, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#49 0x00007f1b66a84a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#50 0x00007f1b689c32f6 in KWin::EffectsHandlerImpl::paintScreen (this=0x27b7af0, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#51 0x00007f1b66a84a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#52 0x00007f1b689c32f6 in KWin::EffectsHandlerImpl::paintScreen (this=0x27b7af0, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#53 0x00007f1b4f5b23eb in KWin::ZoomEffect::paintScreen (this=0x3a68fc0, mask=0, region=..., data=...) at ../../../kwin/effects/zoom/zoom.cpp:341
#54 0x00007f1b689c32f6 in KWin::EffectsHandlerImpl::paintScreen (this=0x27b7af0, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#55 0x00007f1b689aa00f in KWin::Scene::paintScreen (this=0x24cb220, mask=0x7fff902b685c, region=0x7fff902b6920) at ../../kwin/scene.cpp:137
#56 0x00007f1b689bde53 in KWin::SceneOpenGL::paint (this=0x24cb220, damage=..., toplevels=<value optimized out>) at ../../kwin/scene_opengl.cpp:772
#57 0x00007f1b689a52f6 in KWin::Workspace::performCompositing (this=0x2470b20) at ../../kwin/composite.cpp:448
#58 0x00007f1b649fd1c9 in QObject::event (this=0x2470b20, e=<value optimized out>) at kernel/qobject.cpp:1190
#59 0x00007f1b63da69f4 in QApplicationPrivate::notify_helper (this=0x2360680, receiver=0x2470b20, e=0x7fff902b70b0) at kernel/qapplication.cpp:4462
#60 0x00007f1b63dab3ba in QApplication::notify (this=<value optimized out>, receiver=0x2470b20, e=0x7fff902b70b0) at kernel/qapplication.cpp:4341
#61 0x00007f1b681376c6 in KApplication::notify (this=0x7fff902b74b0, receiver=0x2470b20, event=0x7fff902b70b0) at ../../kdeui/kernel/kapplication.cpp:311
#62 0x00007f1b649e949c in QCoreApplication::notifyInternal (this=0x7fff902b74b0, receiver=0x2470b20, event=0x7fff902b70b0) at kernel/qcoreapplication.cpp:731
#63 0x00007f1b64a16f12 in sendEvent (this=0x23620c0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#64 QTimerInfoList::activateTimers (this=0x23620c0) at kernel/qeventdispatcher_unix.cpp:604
#65 0x00007f1b64a1705b in QEventDispatcherUNIX::processEvents (this=0x2305340, flags=...) at kernel/qeventdispatcher_unix.cpp:923
#66 0x00007f1b63e512ec in QEventDispatcherX11::processEvents (this=0x2305340, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#67 0x00007f1b649e8882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#68 0x00007f1b649e8abc in QEventLoop::exec (this=0x7fff902b73f0, flags=...) at kernel/qeventloop.cpp:201
#69 0x00007f1b649ececb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#70 0x00007f1b6894314c in kdemain (argc=<value optimized out>, argv=0x7fff902b7b48) at ../../kwin/main.cpp:542
#71 0x00007f1b68574eff in __libc_start_main (main=0x400740 <main(int, char**)>, argc=3, ubp_av=0x7fff902b7b48, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff902b7b38) at libc-start.c:226
#72 0x0000000000400669 in _start ()

This bug may be a duplicate of or related to bug 282981.

Possible duplicates by query: bug 283561, bug 283498, bug 283096, bug 282981, bug 282275.

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2011-10-31 23:41:28 UTC
driver bug
uncheck "suspend compositing for fullscreen windows" in "kcmshell4
kwincompositing", advanced tab

please do NOT post to the other bug, thanks.

*** This bug has been marked as a duplicate of bug 252817 ***