Bug 283498

Summary: kwin crashes when exiting "impressive"
Product: [Plasma] kwin Reporter: dberg58
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:

Description dberg58 2011-10-06 21:42:55 UTC
Application: kwin (4.6.2 (4.6.2))
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-11-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:
I was using impressive to view a pdf presentation. When I exited impressive Kwin crashed.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fdac63c07a0 (LWP 1544))]

Thread 3 (Thread 0x7fdaab233700 (LWP 1559)):
#0  0x00007fdac5c0a143 in select () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007fdac1fe832c in qt_safe_select (nfds=17, fdread=0x7fdaa4000ac0, fdwrite=0x7fdaa4000d58, fdexcept=0x7fdaa4000ff0, orig_timeout=<value optimized out>) at kernel/qcore_unix.cpp:82
#2  0x00007fdac1fed3d0 in QEventDispatcherUNIXPrivate::doSelect (this=0x7fdaa4000900, flags=..., timeout=0x0) at kernel/qeventdispatcher_unix.cpp:219
#3  0x00007fdac1fee04a in QEventDispatcherUNIX::processEvents (this=0x7fdaa40008e0, flags=...) at kernel/qeventdispatcher_unix.cpp:919
#4  0x00007fdac1fbf882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fdac1fbfabc in QEventLoop::exec (this=0x7fdaab232db0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fdac1ed6924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007fdac1fa1c2f in QInotifyFileSystemWatcherEngine::run (this=0x196b710) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fdac1ed9175 in QThreadPrivate::start (arg=0x196b710) at thread/qthread_unix.cpp:320
#9  0x00007fdabc5c7d8c in start_thread (arg=0x7fdaab233700) at pthread_create.c:304
#10 0x00007fdac5c1204d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fdaaaa32700 (LWP 1560)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fdac4a712a2 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7fdac4d8a180) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007fdac4a712d9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7fdac4d98254) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007fdabc5c7d8c in start_thread (arg=0x7fdaaaa32700) at pthread_create.c:304
#4  0x00007fdac5c1204d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fdac63c07a0 (LWP 1544)):
[KCrash Handler]
#6  0x00007fdaadf7f0a0 in intel_region_buffer () from /usr/lib/dri/i965_dri.so
#7  0x00007fdaadf726c2 in intelClearWithBlit () from /usr/lib/dri/i965_dri.so
#8  0x00007fdaadf74d2a in ?? () from /usr/lib/dri/i965_dri.so
#9  0x00007fdac5f88ce7 in KWin::SceneOpenGL::paintBackground (this=<value optimized out>, region=<value optimized out>) at ../../kwin/scene_opengl.cpp:921
#10 0x00007fdac5f8088f in KWin::Scene::paintGenericScreen (this=0x794e20, orig_mask=40) at ../../kwin/scene.cpp:188
#11 0x00007fdac5f7dc7a in KWin::Scene::finalPaintScreen (this=0x794e20, mask=40, region=<value optimized out>, data=<value optimized out>) at ../../kwin/scene.cpp:178
#12 0x00007fdac5f9bf19 in KWin::EffectsHandlerImpl::paintScreen (this=0x18c7430, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:173
#13 0x00007fdaacdf75a6 in KWin::StartupFeedbackEffect::paintScreen (this=0x19d35a0, mask=40, region=<value optimized out>, data=...) at ../../../kwin/effects/startupfeedback/startupfeedback.cpp:166
#14 0x00007fdac5f9bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x18c7430, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#15 0x00007fdac405ba18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=40, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#16 0x00007fdac5f9bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x18c7430, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#17 0x00007fdaacd9e44d in KWin::LogoutEffect::paintScreen (this=0x1ab9440, mask=40, region=..., data=...) at ../../../kwin/effects/logout/logout.cpp:207
#18 0x00007fdac5f9bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x18c7430, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#19 0x00007fdaacdb957b in KWin::ShadowEffect::paintScreen (this=0x194a650, mask=40, region=..., data=...) at ../../../kwin/effects/shadow/shadow.cpp:189
#20 0x00007fdac5f9bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x18c7430, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#21 0x00007fdaacdcbe68 in KWin::BlurEffect::paintScreen (this=<value optimized out>, mask=40, region=..., data=...) at ../../../kwin/effects/blur/blur.cpp:230
#22 0x00007fdac5f9bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x18c7430, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#23 0x00007fdaacda2fbd in KWin::PresentWindowsEffect::paintScreen (this=0x1ccdf60, mask=8, region=..., data=...) at ../../../kwin/effects/presentwindows/presentwindows.cpp:205
#24 0x00007fdac5f9bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x18c7430, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#25 0x00007fdac405ba18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#26 0x00007fdac5f9bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x18c7430, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#27 0x00007fdac405ba18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#28 0x00007fdac5f9bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x18c7430, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#29 0x00007fdac405ba18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#30 0x00007fdac5f9bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x18c7430, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#31 0x00007fdac405ba18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#32 0x00007fdac5f9bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x18c7430, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#33 0x00007fdaacd8a365 in KWin::DesktopGridEffect::paintScreen (this=0x1947c50, mask=8, region=..., data=...) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:155
#34 0x00007fdac5f9bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x18c7430, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#35 0x00007fdaacdbfb8f in KWin::SlideEffect::paintScreen (this=<value optimized out>, mask=8, region=..., data=...) at ../../../kwin/effects/slide/slide.cpp:86
#36 0x00007fdac5f9bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x18c7430, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#37 0x00007fdaacd83bad in KWin::BoxSwitchEffect::paintScreen (this=0x1b12930, mask=8, region=..., data=...) at ../../../kwin/effects/boxswitch/boxswitch.cpp:143
#38 0x00007fdac5f9bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x18c7430, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#39 0x00007fdaacdda256 in KWin::CubeEffect::paintScreen (this=<value optimized out>, mask=8, region=..., data=...) at ../../../kwin/effects/cube/cube.cpp:698
#40 0x00007fdac5f9bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x18c7430, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#41 0x00007fdac405ba18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#42 0x00007fdac5f9bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x18c7430, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#43 0x00007fdac405ba18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#44 0x00007fdac5f9bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x18c7430, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#45 0x00007fdac405ba18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#46 0x00007fdac5f9bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x18c7430, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#47 0x00007fdaacdd2d86 in KWin::CoverSwitchEffect::paintScreen (this=0x1c4c7e0, mask=8, region=..., data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:126
#48 0x00007fdac5f9bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x18c7430, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#49 0x00007fdac405ba18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#50 0x00007fdac5f9bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x18c7430, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#51 0x00007fdac405ba18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#52 0x00007fdac5f9bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x18c7430, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#53 0x00007fdaacdc939b in KWin::ZoomEffect::paintScreen (this=0x190c9f0, mask=8, region=..., data=...) at ../../../kwin/effects/zoom/zoom.cpp:341
#54 0x00007fdac5f9bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x18c7430, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#55 0x00007fdac5f800af in KWin::Scene::paintScreen (this=0x794e20, mask=0x7fffb6e3ea6c, region=0x7fffb6e3eb30) at ../../kwin/scene.cpp:137
#56 0x00007fdac5f93ef3 in KWin::SceneOpenGL::paint (this=0x794e20, damage=..., toplevels=<value optimized out>) at ../../kwin/scene_opengl.cpp:772
#57 0x00007fdac5f7b396 in KWin::Workspace::performCompositing (this=0xabff30) at ../../kwin/composite.cpp:448
#58 0x00007fdac1fd41c9 in QObject::event (this=0xabff30, e=<value optimized out>) at kernel/qobject.cpp:1190
#59 0x00007fdac137d9f4 in QApplicationPrivate::notify_helper (this=0x69b9a0, receiver=0xabff30, e=0x7fffb6e3f2c0) at kernel/qapplication.cpp:4462
#60 0x00007fdac13823ba in QApplication::notify (this=<value optimized out>, receiver=0xabff30, e=0x7fffb6e3f2c0) at kernel/qapplication.cpp:4341
#61 0x00007fdac570d866 in KApplication::notify (this=0x7fffb6e3f6c0, receiver=0xabff30, event=0x7fffb6e3f2c0) at ../../kdeui/kernel/kapplication.cpp:311
#62 0x00007fdac1fc049c in QCoreApplication::notifyInternal (this=0x7fffb6e3f6c0, receiver=0xabff30, event=0x7fffb6e3f2c0) at kernel/qcoreapplication.cpp:731
#63 0x00007fdac1fedf12 in sendEvent (this=0x69d610) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#64 QTimerInfoList::activateTimers (this=0x69d610) at kernel/qeventdispatcher_unix.cpp:604
#65 0x00007fdac1fee05b in QEventDispatcherUNIX::processEvents (this=0x640340, flags=...) at kernel/qeventdispatcher_unix.cpp:923
#66 0x00007fdac14282ec in QEventDispatcherX11::processEvents (this=0x640340, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#67 0x00007fdac1fbf882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#68 0x00007fdac1fbfabc in QEventLoop::exec (this=0x7fffb6e3f600, flags=...) at kernel/qeventloop.cpp:201
#69 0x00007fdac1fc3ecb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#70 0x00007fdac5f191ec in kdemain (argc=<value optimized out>, argv=0x7fffb6e3fd58) at ../../kwin/main.cpp:542
#71 0x00007fdac5b4aeff in __libc_start_main (main=0x400740 <main(int, char**)>, argc=3, ubp_av=0x7fffb6e3fd58, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fffb6e3fd48) at libc-start.c:226
#72 0x0000000000400669 in _start ()

Possible duplicates by query: bug 283096, bug 282981, bug 282275, bug 281056, bug 280954.

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2011-10-06 22:04:21 UTC
driver bug, see dupe for workaround (disable compositing suspension for fullscreen windows, kcmshell4 kwincompositing, 3rd tab)

*** This bug has been marked as a duplicate of bug 252817 ***