Bug 282981

Summary: weird behavior in fullscreen mode
Product: [Plasma] kwin Reporter: dankjel
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Compiled Sources   
OS: Linux   
Latest Commit: Version Fixed In:

Description dankjel 2011-09-28 18:48:22 UTC
Application: kwin (4.6.2 (4.6.2))
KDE Platform Version: 4.6.2 (4.6.2) (Compiled from sources)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-10-generic i686
Distribution: Ubuntu 11.04

-- Information about the crash:
- Unusual behavior I noticed:

Every time i play a video fullscreen behavior is weird: screen bleeping, black screen. I often have to restart the system

The crash can be reproduced some of the time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7731720 (LWP 1677))]

Thread 3 (Thread 0xb2999b70 (LWP 1699)):
#0  0x01127d41 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x01871dd8 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x0193f525 in updateCurrentTime (this=0x94b1008, flags=..., timeout=0x0) at kernel/qeventdispatcher_unix.cpp:339
#4  QEventDispatcherUNIXPrivate::doSelect (this=0x94b1008, flags=..., timeout=0x0) at kernel/qeventdispatcher_unix.cpp:182
#5  0x01940326 in QEventDispatcherUNIX::processEvents (this=0x97314b8, flags=...) at kernel/qeventdispatcher_unix.cpp:919
#6  0x0190f289 in QEventLoop::processEvents (this=0xb2999280, flags=...) at kernel/qeventloop.cpp:149
#7  0x0190f522 in QEventLoop::exec (this=0xb2999280, flags=...) at kernel/qeventloop.cpp:201
#8  0x018192a0 in QThread::exec (this=0x94acc18) at thread/qthread.cpp:492
#9  0x018f0fdb in QInotifyFileSystemWatcherEngine::run (this=0x94acc18) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x0181bda2 in QThreadPrivate::start (arg=0x94acc18) at thread/qthread_unix.cpp:320
#11 0x063d2e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x0039373e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xb2190b70 (LWP 1700)):
#0  0x0016e416 in __kernel_vsyscall ()
#1  0x063d748c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x003a13fd in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0x00e12817 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0xf261c0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#4  0x00e12851 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0xf261c0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#5  0x063d2e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#6  0x0039373e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb7731720 (LWP 1677)):
[KCrash Handler]
#7  intel_region_buffer (intel=0x90f5cd0, region=0x0, flag=2) at intel_regions.c:514
#8  0x026f9ce2 in intelClearWithBlit (ctx=0x90f5cd0, mask=2) at intel_blit.c:262
#9  0x026fc4c0 in intelClear (ctx=0x90f5cd0, mask=2) at intel_clear.c:177
#10 0x027c2512 in _mesa_Clear (mask=<value optimized out>) at main/clear.c:241
#11 0x004fa84b in KWin::SceneOpenGL::paintBackground (this=0x911fb40, region=...) at ../../kwin/scene_opengl.cpp:921
#12 0x004f1562 in KWin::Scene::paintGenericScreen (this=0x911fb40, orig_mask=32) at ../../kwin/scene.cpp:188
#13 0x004faa31 in KWin::SceneOpenGL::paintGenericScreen (this=0x911fb40, mask=32, data=...) at ../../kwin/scene_opengl.cpp:909
#14 0x004ee7c0 in KWin::Scene::finalPaintScreen (this=0x911fb40, mask=32, region=..., data=...) at ../../kwin/scene.cpp:178
#15 0x005100fc in KWin::EffectsHandlerImpl::paintScreen (this=0x9434b70, mask=32, region=..., data=...) at ../../kwin/effects.cpp:173
#16 0x02b2c0e9 in KWin::StartupFeedbackEffect::paintScreen (this=0x95747f8, mask=32, region=..., data=...) at ../../../kwin/effects/startupfeedback/startupfeedback.cpp:166
#17 0x00510172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9434b70, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#18 0x00197256 in KWin::Effect::paintScreen (this=0x9690240, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#19 0x00510172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9434b70, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#20 0x02ace07f in KWin::LogoutEffect::paintScreen (this=0x9519ac8, mask=32, region=..., data=...) at ../../../kwin/effects/logout/logout.cpp:207
#21 0x00510172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9434b70, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#22 0x02ae9b10 in KWin::ShadowEffect::paintScreen (this=0x9500c90, mask=32, region=..., data=...) at ../../../kwin/effects/shadow/shadow.cpp:189
#23 0x00510172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9434b70, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#24 0x02afe013 in KWin::BlurEffect::paintScreen (this=0x9484348, mask=32, region=..., data=...) at ../../../kwin/effects/blur/blur.cpp:230
#25 0x00510172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9434b70, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#26 0x02ad2e6f in KWin::PresentWindowsEffect::paintScreen (this=0x9489030, mask=32, region=..., data=...) at ../../../kwin/effects/presentwindows/presentwindows.cpp:205
#27 0x00510172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9434b70, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#28 0x00197256 in KWin::Effect::paintScreen (this=0x953fca0, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#29 0x00510172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9434b70, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#30 0x00197256 in KWin::Effect::paintScreen (this=0x950f050, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#31 0x00510172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9434b70, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#32 0x00197256 in KWin::Effect::paintScreen (this=0x9688598, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#33 0x00510172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9434b70, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#34 0x00197256 in KWin::Effect::paintScreen (this=0x94f52b0, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#35 0x00510172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9434b70, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#36 0x00197256 in KWin::Effect::paintScreen (this=0x94692f0, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#37 0x00510172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9434b70, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#38 0x02ab97e9 in KWin::DesktopGridEffect::paintScreen (this=0x9485bb8, mask=32, region=..., data=...) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:155
#39 0x00510172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9434b70, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#40 0x02af0ce2 in KWin::SlideEffect::paintScreen (this=0x95ff268, mask=32, region=..., data=...) at ../../../kwin/effects/slide/slide.cpp:86
#41 0x00510172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9434b70, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#42 0x02ab2799 in KWin::BoxSwitchEffect::paintScreen (this=0x9465058, mask=32, region=..., data=...) at ../../../kwin/effects/boxswitch/boxswitch.cpp:143
#43 0x00510172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9434b70, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#44 0x02b0cbcc in KWin::CubeEffect::paintScreen (this=0x9629b20, mask=32, region=..., data=...) at ../../../kwin/effects/cube/cube.cpp:698
#45 0x00510172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9434b70, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#46 0x00197256 in KWin::Effect::paintScreen (this=0x96825c8, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#47 0x00510172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9434b70, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#48 0x00197256 in KWin::Effect::paintScreen (this=0x959cfa8, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#49 0x00510172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9434b70, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#50 0x02b05a0c in KWin::CoverSwitchEffect::paintScreen (this=0x9610508, mask=32, region=..., data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:126
#51 0x00510172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9434b70, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#52 0x00197256 in KWin::Effect::paintScreen (this=0x9464ed0, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#53 0x00510172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9434b70, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#54 0x00197256 in KWin::Effect::paintScreen (this=0x9554198, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#55 0x00510172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9434b70, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#56 0x02afb0c1 in KWin::ZoomEffect::paintScreen (this=0x950f368, mask=32, region=..., data=...) at ../../../kwin/effects/zoom/zoom.cpp:341
#57 0x00510172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9434b70, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#58 0x004ef98c in KWin::Scene::paintScreen (this=0x911fb40, mask=0xbf863818, region=0xbf8638a0) at ../../kwin/scene.cpp:137
#59 0x00506962 in KWin::SceneOpenGL::paint (this=0x911fb40, damage=..., toplevels=...) at ../../kwin/scene_opengl.cpp:772
#60 0x004eb886 in KWin::Workspace::performCompositing (this=0x9425858) at ../../kwin/composite.cpp:448
#61 0x01925214 in QObject::event (this=0x9425858, e=0xbf863dcc) at kernel/qobject.cpp:1190
#62 0x074cbd24 in QApplicationPrivate::notify_helper (this=0x903b1f0, receiver=0x9425858, e=0xbf863dcc) at kernel/qapplication.cpp:4462
#63 0x074d08ce in QApplication::notify (this=0xbf8640e4, receiver=0x9425858, e=0xbf863dcc) at kernel/qapplication.cpp:3862
#64 0x008243ca in KApplication::notify (this=0xbf8640e4, receiver=0x9425858, event=0xbf863dcc) at ../../kdeui/kernel/kapplication.cpp:311
#65 0x0047aabf in KWin::Application::notify (this=0xbf8640e4, o=0x9425858, e=0xbf863dcc) at ../../kwin/main.cpp:376
#66 0x019100bb in QCoreApplication::notifyInternal (this=0xbf8640e4, receiver=0x9425858, event=0xbf863dcc) at kernel/qcoreapplication.cpp:731
#67 0x019401e4 in sendEvent (this=0x903d0e0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#68 QTimerInfoList::activateTimers (this=0x903d0e0) at kernel/qeventdispatcher_unix.cpp:604
#69 0x01940338 in QEventDispatcherUNIX::processEvents (this=0x8ffaac0, flags=...) at kernel/qeventdispatcher_unix.cpp:923
#70 0x0758325a in QEventDispatcherX11::processEvents (this=0x8ffaac0, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#71 0x0190f289 in QEventLoop::processEvents (this=0xbf864024, flags=...) at kernel/qeventloop.cpp:149
#72 0x0190f522 in QEventLoop::exec (this=0xbf864024, flags=...) at kernel/qeventloop.cpp:201
#73 0x01913ecc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#74 0x074c98e7 in QApplication::exec () at kernel/qapplication.cpp:3736
#75 0x0047d5b2 in kdemain (argc=1, argv=0xbf864364) at ../../kwin/main.cpp:542
#76 0x080485bb in main (argc=1, argv=0xbf864364) at kwin_dummy.cpp:3

Possible duplicates by query: bug 282275, bug 281056, bug 280954, bug 280766, bug 280719.

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2011-09-28 18:54:12 UTC
driver bug
uncheck "suspend compositing for fullscreen windows" in "kcmshell4 kwincompositing", advanced tab

*** This bug has been marked as a duplicate of bug 252817 ***