Bug 282275

Summary: kwin chrashes after closing a full-screen flash video
Product: [Plasma] kwin Reporter: anton.schiela
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:

Description anton.schiela 2011-09-18 13:03:38 UTC
Application: kwin (4.6.2 (4.6.2))
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-11-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
After watching a "Sachgeschichen" Video from http://www.wdrmaus.de/ in full-screen mode, kwin crashes.

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f8313df17a0 (LWP 1488))]

Thread 3 (Thread 0x7f82f87a5700 (LWP 1494)):
#0  0x00007f831363c143 in select () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007f830fa1a32c in qt_safe_select (nfds=17, fdread=0x15f8850, fdwrite=0x15f8ae8, fdexcept=0x15f8d80, orig_timeout=<value optimized out>) at kernel/qcore_unix.cpp:82
#2  0x00007f830fa1f3d0 in QEventDispatcherUNIXPrivate::doSelect (this=0x15f8690, flags=..., timeout=0x0) at kernel/qeventdispatcher_unix.cpp:219
#3  0x00007f830fa2004a in QEventDispatcherUNIX::processEvents (this=0x2ac8800, flags=...) at kernel/qeventdispatcher_unix.cpp:919
#4  0x00007f830f9f1882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f830f9f1abc in QEventLoop::exec (this=0x7f82f87a4db0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f830f908924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007f830f9d3c2f in QInotifyFileSystemWatcherEngine::run (this=0x15b75c0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f830f90b175 in QThreadPrivate::start (arg=0x15b75c0) at thread/qthread_unix.cpp:320
#9  0x00007f8309ffad8c in start_thread (arg=0x7f82f87a5700) at pthread_create.c:304
#10 0x00007f831364404d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f82f7fa4700 (LWP 1495)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f83124a32a2 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f83127bc180) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f83124a32d9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7f83127ca254) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f8309ffad8c in start_thread (arg=0x7f82f7fa4700) at pthread_create.c:304
#4  0x00007f831364404d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f8313df17a0 (LWP 1488)):
[KCrash Handler]
#6  intel_region_buffer (intel=0x181d700, region=0x0, flag=2) at intel_regions.c:514
#7  0x00007f82fb4e46c2 in intelClearWithBlit (ctx=0x181d700, mask=2) at intel_blit.c:262
#8  0x00007f82fb4e6d2a in intelClear (ctx=0x181d700, mask=2) at intel_clear.c:177
#9  0x00007f83139bace7 in KWin::SceneOpenGL::paintBackground (this=<value optimized out>, region=<value optimized out>) at ../../kwin/scene_opengl.cpp:921
#10 0x00007f83139b288f in KWin::Scene::paintGenericScreen (this=0x16e43e0, orig_mask=32) at ../../kwin/scene.cpp:188
#11 0x00007f83139afc7a in KWin::Scene::finalPaintScreen (this=0x16e43e0, mask=32, region=<value optimized out>, data=<value optimized out>) at ../../kwin/scene.cpp:178
#12 0x00007f83139cdf19 in KWin::EffectsHandlerImpl::paintScreen (this=0x16bbb60, mask=32, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:173
#13 0x00007f82fa5515a6 in KWin::StartupFeedbackEffect::paintScreen (this=0x2ddc5f0, mask=32, region=<value optimized out>, data=...) at ../../../kwin/effects/startupfeedback/startupfeedback.cpp:166
#14 0x00007f83139cdfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x16bbb60, mask=32, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#15 0x00007f8311a8da18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#16 0x00007f83139cdfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x16bbb60, mask=32, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#17 0x00007f82fa4f844d in KWin::LogoutEffect::paintScreen (this=0x2b7fce0, mask=32, region=..., data=...) at ../../../kwin/effects/logout/logout.cpp:207
#18 0x00007f83139cdfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x16bbb60, mask=32, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#19 0x00007f82fa51357b in KWin::ShadowEffect::paintScreen (this=0x2a10610, mask=32, region=..., data=...) at ../../../kwin/effects/shadow/shadow.cpp:189
#20 0x00007f83139cdfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x16bbb60, mask=32, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#21 0x00007f82fa525e68 in KWin::BlurEffect::paintScreen (this=<value optimized out>, mask=32, region=..., data=...) at ../../../kwin/effects/blur/blur.cpp:230
#22 0x00007f83139cdfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x16bbb60, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#23 0x00007f82fa4fcfbd in KWin::PresentWindowsEffect::paintScreen (this=0x2b1de00, mask=0, region=..., data=...) at ../../../kwin/effects/presentwindows/presentwindows.cpp:205
#24 0x00007f83139cdfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x16bbb60, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#25 0x00007f8311a8da18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#26 0x00007f83139cdfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x16bbb60, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#27 0x00007f8311a8da18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#28 0x00007f83139cdfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x16bbb60, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#29 0x00007f8311a8da18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#30 0x00007f83139cdfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x16bbb60, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#31 0x00007f8311a8da18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#32 0x00007f83139cdfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x16bbb60, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#33 0x00007f82fa4e4365 in KWin::DesktopGridEffect::paintScreen (this=0x29535c0, mask=0, region=..., data=...) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:155
#34 0x00007f83139cdfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x16bbb60, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#35 0x00007f82fa519b8f in KWin::SlideEffect::paintScreen (this=<value optimized out>, mask=0, region=..., data=...) at ../../../kwin/effects/slide/slide.cpp:86
#36 0x00007f83139cdfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x16bbb60, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#37 0x00007f82fa4ddbad in KWin::BoxSwitchEffect::paintScreen (this=0x2c9a370, mask=0, region=..., data=...) at ../../../kwin/effects/boxswitch/boxswitch.cpp:143
#38 0x00007f83139cdfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x16bbb60, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#39 0x00007f82fa534256 in KWin::CubeEffect::paintScreen (this=<value optimized out>, mask=0, region=..., data=...) at ../../../kwin/effects/cube/cube.cpp:698
#40 0x00007f83139cdfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x16bbb60, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#41 0x00007f8311a8da18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#42 0x00007f83139cdfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x16bbb60, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#43 0x00007f8311a8da18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#44 0x00007f83139cdfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x16bbb60, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#45 0x00007f8311a8da18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#46 0x00007f83139cdfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x16bbb60, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#47 0x00007f82fa52cd86 in KWin::CoverSwitchEffect::paintScreen (this=0x2a64030, mask=0, region=..., data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:126
#48 0x00007f83139cdfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x16bbb60, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#49 0x00007f8311a8da18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#50 0x00007f83139cdfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x16bbb60, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#51 0x00007f8311a8da18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#52 0x00007f83139cdfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x16bbb60, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#53 0x00007f82fa52339b in KWin::ZoomEffect::paintScreen (this=0x2b0c7f0, mask=0, region=..., data=...) at ../../../kwin/effects/zoom/zoom.cpp:341
#54 0x00007f83139cdfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x16bbb60, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#55 0x00007f83139b20af in KWin::Scene::paintScreen (this=0x16e43e0, mask=0x7fff2ea3caec, region=0x7fff2ea3cbb0) at ../../kwin/scene.cpp:137
#56 0x00007f83139c5ef3 in KWin::SceneOpenGL::paint (this=0x16e43e0, damage=..., toplevels=<value optimized out>) at ../../kwin/scene_opengl.cpp:772
#57 0x00007f83139ad396 in KWin::Workspace::performCompositing (this=0x19d7910) at ../../kwin/composite.cpp:448
#58 0x00007f830fa061c9 in QObject::event (this=0x19d7910, e=<value optimized out>) at kernel/qobject.cpp:1190
#59 0x00007f830edaf9f4 in QApplicationPrivate::notify_helper (this=0x1573940, receiver=0x19d7910, e=0x7fff2ea3d340) at kernel/qapplication.cpp:4462
#60 0x00007f830edb43ba in QApplication::notify (this=<value optimized out>, receiver=0x19d7910, e=0x7fff2ea3d340) at kernel/qapplication.cpp:4341
#61 0x00007f831313f866 in KApplication::notify (this=0x7fff2ea3d740, receiver=0x19d7910, event=0x7fff2ea3d340) at ../../kdeui/kernel/kapplication.cpp:311
#62 0x00007f830f9f249c in QCoreApplication::notifyInternal (this=0x7fff2ea3d740, receiver=0x19d7910, event=0x7fff2ea3d340) at kernel/qcoreapplication.cpp:731
#63 0x00007f830fa1ff12 in sendEvent (this=0x1574380) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#64 QTimerInfoList::activateTimers (this=0x1574380) at kernel/qeventdispatcher_unix.cpp:604
#65 0x00007f830fa2005b in QEventDispatcherUNIX::processEvents (this=0x1518340, flags=...) at kernel/qeventdispatcher_unix.cpp:923
#66 0x00007f830ee5a2ec in QEventDispatcherX11::processEvents (this=0x1518340, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#67 0x00007f830f9f1882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#68 0x00007f830f9f1abc in QEventLoop::exec (this=0x7fff2ea3d680, flags=...) at kernel/qeventloop.cpp:201
#69 0x00007f830f9f5ecb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#70 0x00007f831394b1ec in kdemain (argc=<value optimized out>, argv=0x7fff2ea3ddd8) at ../../kwin/main.cpp:542
#71 0x00007f831357ceff in __libc_start_main (main=0x400740 <main(int, char**)>, argc=3, ubp_av=0x7fff2ea3ddd8, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff2ea3ddc8) at libc-start.c:226
#72 0x0000000000400669 in _start ()

Possible duplicates by query: bug 281056, bug 280954, bug 280766, bug 280719, bug 280613.

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2011-09-18 13:39:45 UTC
driver bug, disable compositing suspension for fullscreen windows (kcmshell4 kwincompositing) as workaround.

*** This bug has been marked as a duplicate of bug 252817 ***