Bug 281186

Summary: maximizing a full-size window causes title bar corruption
Product: [Plasma] kwin Reporter: S. Christian Collins <s_chriscollins>
Component: decorationsAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED FIXED    
Severity: normal CC: eric.erfanian, hugo.pereira.da.costa, ismail
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: picture of corruption

Description S. Christian Collins 2011-09-01 19:50:13 UTC
Created attachment 63293 [details]
picture of corruption

Version:           unspecified (using KDE 4.7.0) 
OS:                Linux

When maximizing a window that has been manually sized to take up the entire screen, the title bar becomes graphically corrupt.  I have tried many different window decorations, and this only happens with Oxygen.  The bug also only occurs when desktop effects are enabled.

Here is a video of the bug in action: http://www.youtube.com/watch?v=Hf7BwY5W4HQ

I have also attached a screenshot of the corruption.

Reproducible: Always

Steps to Reproduce:
1) Make sure Oxygen is the window decorator and kwin desktop effects are enabled.
2) Open Dolphin (although any program should do).
3) Resize Dolphin using the window borders so that it takes up the entire desktop, from the top of the screen down to the panel.
4) Click the maximize button.

Actual Results:  
The title bar becomes corrupted.  If you restore the window from the maximized state, the maximize button appears stuck in a depressed state.

Expected Results:  
There should be no corruption.

** My System **
OS: Kubuntu 11.04 64-bit w/ KDE 4.7.0
Motherboard: ASRock X58 Extreme3 (Intel X58 chipset)
CPU: Intel Core i7 (2.8 GHz quad-core)
RAM: 12GB DDR3
Video: Dell NVIDIA GeForce 7800 GTX w/ 256 MB RAM (PCI Express)
Sound Card #1: Sound Blaster Audigy 2 ZS Gold
Sound Card #2: Echo Gina3G
Linux Kernel: 2.6.38-11-generic
NVIDIA video driver: 275.09.07
Screen Resolution: 1280 x 960
Comment 1 Ismail Donmez 2011-09-01 19:58:07 UTC
Very nice reproduce video, I saw this with KMail2 multiple times. Using ATI with open source radeon driver.
Comment 2 Hugo Pereira Da Costa 2011-09-02 06:02:42 UTC
I can reproduce with some applications (mainly, libreoffice).
I do not think it is an oxygen issue but rather kwin. Re-assigning.
Comment 3 Martin Flöser 2011-09-25 08:38:50 UTC
I am able to reproduce it with Java applications but so far have not been able to reproduce with a real application.

Given the state how it looks like for me, it seems like the window is rendered as maximized but the decoration is still providing the decoration for not-maximized causing the decoration to be scaled down (and including the shadows).
Comment 4 S. Christian Collins 2012-02-09 14:25:04 UTC
I can't reproduce this anymore since I've upgraded to KDE 4.8.  Anybody else still having the problem?
Comment 5 eric.erfanian 2012-08-08 20:03:10 UTC
I did not experience this exact distortion, but I did have title bar distortion issues when my panel was at the top of the screen and I dragged the window to the top to auto-maximize.
Comment 6 Thomas Lübking 2012-08-08 22:55:32 UTC
@eric
Mind to elaborate a bit on what you saw (rather that it's actually not this ;-)
Or is it just the title alignment?
(And does it hold for 4.9 as well?)
Comment 7 eric.erfanian 2012-08-08 23:23:42 UTC
Sure Thomas.

The title looked like it got too big to fit in the bar. Perhaps it was an issue with the TitleHeight in the FormaN theme as well.

I believe at the time the window was maximized and then I dragged it up to the top to auto fill and it got confused. No issues when the panel was on bottom, just on top. At any rate I cannot replicate it now in 4.9.
Comment 8 Thomas Lübking 2012-08-09 20:23:19 UTC
Ok, thanks for the update (closing as works for me by comments #4 and #7 - original bug looks like typical NPOT issue)
Comment 9 Martin Flöser 2013-01-09 09:37:58 UTC
marking as fixed as of latest comments. If still an issue please reopen.