Bug 281056

Summary: KWin crashed during full-screen flash video play
Product: [Plasma] kwin Reporter: Jens <jb300180>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:

Description Jens 2011-08-30 15:10:26 UTC
Application: kwin (4.6.2 (4.6.2))
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-11-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:

I was watching football using NFLs "Gamepass".
It ran as a flash full-screen video in google-chrome.
When changing volume with my laptop's button kwin crashed.
Compositing can lead to kwin crashing too.

The crash can be reproduced some of the time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7feaed7ad7a0 (LWP 1522))]

Thread 3 (Thread 0x7fead2133700 (LWP 1533)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007fead2132bd0 in ?? ()
#2  0x00007fffb05ff7b2 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 2 (Thread 0x7fead1932700 (LWP 1534)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007feaebe612a2 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7feaec17a180) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007feaebe612d9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7feaec188254) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007feae39b8d8c in start_thread (arg=0x7fead1932700) at pthread_create.c:304
#4  0x00007feaed00204d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7feaed7ad7a0 (LWP 1522)):
[KCrash Handler]
#6  intel_region_buffer (intel=0x2732400, region=0x0, flag=2) at intel_regions.c:514
#7  0x00007fead4e726c2 in intelClearWithBlit (ctx=0x2732400, mask=2) at intel_blit.c:262
#8  0x00007fead4e74d2a in intelClear (ctx=0x2732400, mask=2) at intel_clear.c:177
#9  0x00007feaed378ce7 in KWin::SceneOpenGL::paintBackground (this=<value optimized out>, region=<value optimized out>) at ../../kwin/scene_opengl.cpp:921
#10 0x00007feaed37088f in KWin::Scene::paintGenericScreen (this=0x2727080, orig_mask=40) at ../../kwin/scene.cpp:188
#11 0x00007feaed36dc7a in KWin::Scene::finalPaintScreen (this=0x2727080, mask=40, region=<value optimized out>, data=<value optimized out>) at ../../kwin/scene.cpp:178
#12 0x00007feaed38bf19 in KWin::EffectsHandlerImpl::paintScreen (this=0x3860f20, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:173
#13 0x00007fead3f065a6 in KWin::StartupFeedbackEffect::paintScreen (this=0x3bc3030, mask=40, region=<value optimized out>, data=...) at ../../../kwin/effects/startupfeedback/startupfeedback.cpp:166
#14 0x00007feaed38bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x3860f20, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#15 0x00007feaeb44ba18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=40, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#16 0x00007feaed38bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x3860f20, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#17 0x00007fead3ead44d in KWin::LogoutEffect::paintScreen (this=0x3a026a0, mask=40, region=..., data=...) at ../../../kwin/effects/logout/logout.cpp:207
#18 0x00007feaed38bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x3860f20, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#19 0x00007fead3ec857b in KWin::ShadowEffect::paintScreen (this=0x3978200, mask=40, region=..., data=...) at ../../../kwin/effects/shadow/shadow.cpp:189
#20 0x00007feaed38bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x3860f20, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#21 0x00007fead3edae68 in KWin::BlurEffect::paintScreen (this=<value optimized out>, mask=40, region=..., data=...) at ../../../kwin/effects/blur/blur.cpp:230
#22 0x00007feaed38bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x3860f20, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#23 0x00007fead3eb1fbd in KWin::PresentWindowsEffect::paintScreen (this=0x38c0bd0, mask=8, region=..., data=...) at ../../../kwin/effects/presentwindows/presentwindows.cpp:205
#24 0x00007feaed38bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x3860f20, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#25 0x00007feaeb44ba18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#26 0x00007feaed38bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x3860f20, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#27 0x00007feaeb44ba18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#28 0x00007feaed38bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x3860f20, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#29 0x00007feaeb44ba18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#30 0x00007feaed38bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x3860f20, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#31 0x00007feaeb44ba18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#32 0x00007feaed38bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x3860f20, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#33 0x00007fead3e99365 in KWin::DesktopGridEffect::paintScreen (this=0x38e0f70, mask=8, region=..., data=...) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:155
#34 0x00007feaed38bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x3860f20, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#35 0x00007fead3eceb8f in KWin::SlideEffect::paintScreen (this=<value optimized out>, mask=8, region=..., data=...) at ../../../kwin/effects/slide/slide.cpp:86
#36 0x00007feaed38bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x3860f20, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#37 0x00007fead3e92bad in KWin::BoxSwitchEffect::paintScreen (this=0x3a57ea0, mask=8, region=..., data=...) at ../../../kwin/effects/boxswitch/boxswitch.cpp:143
#38 0x00007feaed38bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x3860f20, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#39 0x00007fead3ee9256 in KWin::CubeEffect::paintScreen (this=<value optimized out>, mask=8, region=..., data=...) at ../../../kwin/effects/cube/cube.cpp:698
#40 0x00007feaed38bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x3860f20, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#41 0x00007feaeb44ba18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#42 0x00007feaed38bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x3860f20, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#43 0x00007feaeb44ba18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#44 0x00007feaed38bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x3860f20, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#45 0x00007feaeb44ba18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#46 0x00007feaed38bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x3860f20, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#47 0x00007fead3ee1d86 in KWin::CoverSwitchEffect::paintScreen (this=0x3b681e0, mask=8, region=..., data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:126
#48 0x00007feaed38bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x3860f20, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#49 0x00007feaeb44ba18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#50 0x00007feaed38bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x3860f20, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#51 0x00007feaeb44ba18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#52 0x00007feaed38bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x3860f20, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#53 0x00007fead3ed839b in KWin::ZoomEffect::paintScreen (this=0x3a57c40, mask=8, region=..., data=...) at ../../../kwin/effects/zoom/zoom.cpp:341
#54 0x00007feaed38bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x3860f20, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#55 0x00007feaed3700af in KWin::Scene::paintScreen (this=0x2727080, mask=0x7fffb04b70bc, region=0x7fffb04b7180) at ../../kwin/scene.cpp:137
#56 0x00007feaed383ef3 in KWin::SceneOpenGL::paint (this=0x2727080, damage=..., toplevels=<value optimized out>) at ../../kwin/scene_opengl.cpp:772
#57 0x00007feaed36b396 in KWin::Workspace::performCompositing (this=0x2a505f0) at ../../kwin/composite.cpp:448
#58 0x00007feae93c41c9 in QObject::event (this=0x2a505f0, e=<value optimized out>) at kernel/qobject.cpp:1190
#59 0x00007feae876d9f4 in QApplicationPrivate::notify_helper (this=0x262fb40, receiver=0x2a505f0, e=0x7fffb04b7910) at kernel/qapplication.cpp:4462
#60 0x00007feae87723ba in QApplication::notify (this=<value optimized out>, receiver=0x2a505f0, e=0x7fffb04b7910) at kernel/qapplication.cpp:4341
#61 0x00007feaecafd866 in KApplication::notify (this=0x7fffb04b7d10, receiver=0x2a505f0, event=0x7fffb04b7910) at ../../kdeui/kernel/kapplication.cpp:311
#62 0x00007feae93b049c in QCoreApplication::notifyInternal (this=0x7fffb04b7d10, receiver=0x2a505f0, event=0x7fffb04b7910) at kernel/qcoreapplication.cpp:731
#63 0x00007feae93ddf12 in sendEvent (this=0x2631eb0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#64 QTimerInfoList::activateTimers (this=0x2631eb0) at kernel/qeventdispatcher_unix.cpp:604
#65 0x00007feae93de05b in QEventDispatcherUNIX::processEvents (this=0x25d4340, flags=...) at kernel/qeventdispatcher_unix.cpp:923
#66 0x00007feae88182ec in QEventDispatcherX11::processEvents (this=0x25d4340, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#67 0x00007feae93af882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#68 0x00007feae93afabc in QEventLoop::exec (this=0x7fffb04b7c50, flags=...) at kernel/qeventloop.cpp:201
#69 0x00007feae93b3ecb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#70 0x00007feaed3091ec in kdemain (argc=<value optimized out>, argv=0x7fffb04b83a8) at ../../kwin/main.cpp:542
#71 0x00007feaecf3aeff in __libc_start_main (main=0x400740 <main(int, char**)>, argc=3, ubp_av=0x7fffb04b83a8, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fffb04b8398) at libc-start.c:226
#72 0x0000000000400669 in _start ()

Possible duplicates by query: bug 280954, bug 280766, bug 280719, bug 280613, bug 280499.

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2011-08-30 20:17:17 UTC
driver bug, see dupe for workaround (disable fullscreen unredirection)

*** This bug has been marked as a duplicate of bug 252817 ***