Bug 280396

Summary: crash when trying opening "import --> camera"
Product: [Applications] digikam Reporter: jpi <imhofjp>
Component: Import-Gphoto2Assignee: Digikam Developers <digikam-bugs-null>
Status: RESOLVED FIXED    
Severity: crash CC: caulier.gilles
Priority: NOR    
Version: 2.0.0   
Target Milestone: ---   
Platform: openSUSE   
OS: Linux   
Latest Commit: Version Fixed In: 8.1.0

Description jpi 2011-08-19 06:43:34 UTC
Application: digikam (2.0.0)
KDE Platform Version: 4.7.00 (4.7.0) "release 10"
Qt Version: 4.7.3
Operating System: Linux 2.6.37.6-0.7-desktop x86_64
Distribution: "openSUSE 11.4 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
plantage quand j'essaie d'ouvrir le menu "Import" --> "appareil photo"  --> d├ętection automatique" (Nikon...)

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fadda64d800 (LWP 3681))]

Thread 10 (Thread 0x7fadbd281700 (LWP 3682)):
#0  0x00007fadd1e2338c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fadd5a2a77b in wait (this=<value optimized out>, mutex=0xc65028, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0xc65028, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00000000005b6cf0 in Digikam::ScanController::run() ()
#4  0x00007fadd5a2a095 in QThreadPrivate::start (arg=0xd22250) at thread/qthread_unix.cpp:320
#5  0x00007fadc9ae69e3 in ?? () from /usr/X11R6/lib64/libGL.so.1
#6  0x00007fadd1e1ea3f in start_thread () from /lib64/libpthread.so.0
#7  0x00007fadd408967d in clone () from /lib64/libc.so.6
#8  0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7fadbca80700 (LWP 3683)):
#0  0x00007fadd4080503 in poll () from /lib64/libc.so.6
#1  0x00007fadcc357114 in ?? () from /lib64/libglib-2.0.so.0
#2  0x00007fadcc357650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#3  0x00007fadd5b3e286 in QEventDispatcherGlib::processEvents (this=0xd13c10, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fadd5b128d2 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fadd5b12ae5 in QEventLoop::exec (this=0x7fadbca7fc80, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fadd5a277a4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007fadd5af4008 in QInotifyFileSystemWatcherEngine::run (this=0xd832a0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fadd5a2a095 in QThreadPrivate::start (arg=0xd832a0) at thread/qthread_unix.cpp:320
#9  0x00007fadc9ae69e3 in ?? () from /usr/X11R6/lib64/libGL.so.1
#10 0x00007fadd1e1ea3f in start_thread () from /lib64/libpthread.so.0
#11 0x00007fadd408967d in clone () from /lib64/libc.so.6
#12 0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7fadb7fff700 (LWP 3686)):
#0  0x00007fadd1e2338c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fadd5a2a77b in wait (this=<value optimized out>, mutex=0xe409f8, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0xe409f8, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fadd7c74407 in Digikam::ParkingThread::run() () from /usr/lib64/libdigikamcore.so.2
#4  0x00007fadd5a2a095 in QThreadPrivate::start (arg=0xe409e0) at thread/qthread_unix.cpp:320
#5  0x00007fadc9ae69e3 in ?? () from /usr/X11R6/lib64/libGL.so.1
#6  0x00007fadd1e1ea3f in start_thread () from /lib64/libpthread.so.0
#7  0x00007fadd408967d in clone () from /lib64/libc.so.6
#8  0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7fadac7fd700 (LWP 3687)):
#0  0x00007fadd1e236f9 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fadc8968981 in ?? () from /usr/lib64/libxine.so.1
#2  0x00007fadc9ae69e3 in ?? () from /usr/X11R6/lib64/libGL.so.1
#3  0x00007fadd1e1ea3f in start_thread () from /lib64/libpthread.so.0
#4  0x00007fadd408967d in clone () from /lib64/libc.so.6
#5  0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7fadab3c0700 (LWP 3688)):
#0  0x00007fadd1e236f9 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fadc89766bf in ?? () from /usr/lib64/libxine.so.1
#2  0x00007fadc9ae69e3 in ?? () from /usr/X11R6/lib64/libGL.so.1
#3  0x00007fadd1e1ea3f in start_thread () from /lib64/libpthread.so.0
#4  0x00007fadd408967d in clone () from /lib64/libc.so.6
#5  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7fadaabbf700 (LWP 3689)):
#0  0x00007fadd1e22650 in __pthread_mutex_unlock_usercnt () from /lib64/libpthread.so.0
#1  0x00007fadcc3564e5 in g_main_context_query () from /lib64/libglib-2.0.so.0
#2  0x00007fadcc35701b in ?? () from /lib64/libglib-2.0.so.0
#3  0x00007fadcc357650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#4  0x00007fadd5b3e286 in QEventDispatcherGlib::processEvents (this=0x1cb6480, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007fadd5b128d2 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fadd5b12ae5 in QEventLoop::exec (this=0x7fadaabbec70, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007fadd5a277a4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#8  0x00007fadb62c3694 in Phonon::Xine::XineThread::run() () from /usr/lib64/kde4/plugins/phonon_backend/phonon_xine.so
#9  0x00007fadd5a2a095 in QThreadPrivate::start (arg=0x1d85630) at thread/qthread_unix.cpp:320
#10 0x00007fadc9ae69e3 in ?? () from /usr/X11R6/lib64/libGL.so.1
#11 0x00007fadd1e1ea3f in start_thread () from /lib64/libpthread.so.0
#12 0x00007fadd408967d in clone () from /lib64/libc.so.6
#13 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7fadaa1b8700 (LWP 3690)):
#0  0x00007fadd4080503 in poll () from /lib64/libc.so.6
#1  0x00007fadd368c4df in ?? () from /usr/lib64/libpulse.so.0
#2  0x00007fadd367e2a6 in pa_mainloop_poll () from /usr/lib64/libpulse.so.0
#3  0x00007fadd367e8d9 in pa_mainloop_iterate () from /usr/lib64/libpulse.so.0
#4  0x00007fadd367e990 in pa_mainloop_run () from /usr/lib64/libpulse.so.0
#5  0x00007fadd368c47b in ?? () from /usr/lib64/libpulse.so.0
#6  0x00007fadca791cf8 in ?? () from /usr/lib64/libpulsecommon-0.9.22.so
#7  0x00007fadc9ae69e3 in ?? () from /usr/X11R6/lib64/libGL.so.1
#8  0x00007fadd1e1ea3f in start_thread () from /lib64/libpthread.so.0
#9  0x00007fadd408967d in clone () from /lib64/libc.so.6
#10 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fada59b6700 (LWP 3691)):
#0  0x00007fadd1e2338c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fadc897a9fb in ?? () from /usr/lib64/libxine.so.1
#2  0x00007fadc9ae69e3 in ?? () from /usr/X11R6/lib64/libGL.so.1
#3  0x00007fadd1e1ea3f in start_thread () from /lib64/libpthread.so.0
#4  0x00007fadd408967d in clone () from /lib64/libc.so.6
#5  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fad99c2c700 (LWP 3707)):
[KCrash Handler]
#6  0x00007fadd402e39d in realloc () from /lib64/libc.so.6
#7  0x00007fadc9ae806b in ?? () from /usr/X11R6/lib64/libGL.so.1
#8  0x00007fadc4c2d9f7 in ?? () from /usr/lib64/tls/libnvidia-tls.so.275.21
#9  0x00007fadc8bc2187 in register_platform (d=0x7fadb839a480, dispatch=0x7fadc8de7b80, name=<value optimized out>) at control.c:2015
#10 0x00007fad98ff8ec6 in gp_port_library_list (list=0x7fadb8361f60) at libusb.c:94
#11 0x00007fadd3daf568 in foreach_func (filename=0x7fadb839db65 "/usr/lib64/libgphoto2_port/0.8.0/usb", data=0x7fadb8361f60) at gphoto2-port-info-list.c:243
#12 0x00007fadcfc75a41 in foreachfile_callback (dirname=0x7fadb802e020 "/usr/lib64/libgphoto2_port/0.8.0", data1=<value optimized out>, data2=0x7fadb8361f60) at libltdl/ltdl.c:1836
#13 0x00007fadcfc75697 in foreach_dirinpath (search_path=<value optimized out>, base_name=0x0, func=0x7fadcfc75770 <foreachfile_callback>, data1=0x7fad99c29d58, data2=0x7fadb8361f60) at libltdl/ltdl.c:710
#14 0x00007fadcfc76681 in lt_dlforeachfile (search_path=<value optimized out>, func=0x7fadd3daf490 <foreach_func>, data=0x7fadb8361f60) at libltdl/ltdl.c:1865
#15 0x00007fadd3daf97d in gp_port_info_list_load (list=0x7fadb8361f60) at gphoto2-port-info-list.c:290
#16 0x000000000073ecb4 in Digikam::GPCamera::doConnect() ()
#17 0x00000000007708ff in Digikam::CameraController::executeCommand(Digikam::CameraCommand*) ()
#18 0x000000000077a549 in Digikam::CameraController::run() ()
#19 0x00007fadd5a2a095 in QThreadPrivate::start (arg=0x29e89e0) at thread/qthread_unix.cpp:320
#20 0x00007fadc9ae69e3 in ?? () from /usr/X11R6/lib64/libGL.so.1
#21 0x00007fadd1e1ea3f in start_thread () from /lib64/libpthread.so.0
#22 0x00007fadd408967d in clone () from /lib64/libc.so.6
#23 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fadda64d800 (LWP 3681)):
#0  0x00007fadd4080503 in poll () from /lib64/libc.so.6
#1  0x00007fadca544c2a in ?? () from /usr/lib64/libxcb.so.1
#2  0x00007fadca5462df in xcb_wait_for_reply () from /usr/lib64/libxcb.so.1
#3  0x00007fadd23ae2bd in _XReply () from /usr/lib64/libX11.so.6
#4  0x00007fadd2392837 in XGetWindowProperty () from /usr/lib64/libX11.so.6
#5  0x00007fadd4cdf081 in QETWidget::translatePropertyEvent (this=0x42700b0, event=<value optimized out>) at kernel/qapplication_x11.cpp:4926
#6  0x00007fadd4ce1f20 in QApplication::x11ProcessEvent (this=0x7fff9393a5a0, event=0x7fff9393a0b0) at kernel/qapplication_x11.cpp:3856
#7  0x00007fadd4d08f12 in x11EventSourceDispatch (s=0xbad5f0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#8  0x00007fadcc356bd3 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#9  0x00007fadcc3573b0 in ?? () from /lib64/libglib-2.0.so.0
#10 0x00007fadcc357650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#11 0x00007fadd5b3e22f in QEventDispatcherGlib::processEvents (this=0xb55bb0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#12 0x00007fadd4d08bae in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#13 0x00007fadd5b128d2 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#14 0x00007fadd5b12ae5 in QEventLoop::exec (this=0x7fff9393a3d0, flags=...) at kernel/qeventloop.cpp:201
#15 0x00007fadd5b16f2b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#16 0x0000000000687465 in main ()

This bug may be a duplicate of or related to bug 268267.

Possible duplicates by query: bug 279646, bug 279616, bug 268267.

Reported using DrKonqi
Comment 1 caulier.gilles 2011-08-19 07:56:29 UTC

*** This bug has been marked as a duplicate of bug 268267 ***
Comment 2 caulier.gilles 2023-05-05 05:38:14 UTC
Fixed with #268267